PDA

View Full Version : 12" pbook battery/meter problem


evil
Aug 31, 2004, 11:39 AM
im hoping someone can help me out with this problem i am having. i have a 12inch pbook rev A and theres something wrong with the battery or battery meter. When the pbook is fully charged the meter will drop down at a normal rate to around 55 % and then the computer will just shut off as if the battery is dead. If i then plug it in to charge it it says that the battery is at 0 %. i am only getting somewhere around an hour until the meter drops down to around 55% and shuts off.
anyone have any help to offer me? please.

vraxtus
Aug 31, 2004, 11:41 AM
im hoping someone can help me out with this problem i am having. i have a 12inch pbook rev A and theres something wrong with the battery or battery meter. When the pbook is fully charged the meter will drop down at a normal rate to around 55 % and then the computer will just shut off as if the battery is dead. If i then plug it in to charge it it says that the battery is at 0 %. i am only getting somewhere around an hour until the meter drops down to around 55% and shuts off.
anyone have any help to offer me? please.



I had this problem with an older iBook... just get a new battery.

evil
Aug 31, 2004, 11:43 AM
I had this problem with an older iBook... just get a new battery.

why do you think its a battery problem? i checked my battery capacity in terminal and it was fine. id like to be pretty sure its the battery before i go out and buy a new one.

dotnina
Aug 31, 2004, 12:13 PM
Have you tried resetting the PMU? I'm not exactly sure what this does, but it seems people do this when they're having battery problems.

vraxtus
Aug 31, 2004, 12:19 PM
why do you think its a battery problem? i checked my battery capacity in terminal and it was fine. id like to be pretty sure its the battery before i go out and buy a new one.


Well, I'll ask this first... how old is your battery? The old Wallstreet batteries died out in about 2 years... COMPLETELY. So with a Rev A I'd almost 100% guarantee it's the battery.

evil
Aug 31, 2004, 12:58 PM
ok i reset the pmu and i hope this works.

the battery is as old as the computer..about 1 year and 4 months or so.

evil
Aug 31, 2004, 01:00 PM
well, it just died at 30 %. darn.
any other suggestions anyone? i really dont want to have to buy a new battery..especially if that wont even fix teh problem.
i really cant even afford to buy a new battery