PDA

View Full Version : No video at top menu after installing Overflow




Tomball
Feb 25, 2010, 05:08 PM
Apple TV firmware 3.0.2; atvusb-creator-1.0.b13

I loaded ATVCreator patchstick and rebooted. I installed Sapphire, XMBC, nitroTV successfully. But I got an error installing Overflow and was asked to restart.

After restarting I had no video. Fooling around with the Remote app on my iPhone I found I had core AppleTV functionality - i.e. I could play movies, tv shows, music videos; and I have SSH access. But no video when I'm at the top level menu.

Adapting instructions in this post (http://forums.macrumors.com/showpost.php?p=9242129&postcount=2) I removed Overflow.frappliance from /System/Library/CoreServices/Finder.app/Contents/PlugIns and rebooted. No video.

I removed SoftwareMenu.frappliance and rebooted; then downloaded SoftwareMenu-1.0b1.run from here (http://iscripts.googlecode.com/files/SoftwareMenu-1.0b1.run), ran it and restarted. No video. I rebooted. Still no video.

Any more suggestions before I do a Factory Restore, update to 3.0.2 and reinstall the PatchStick?

I can't check the Awkward.org forums as they are down.



Billy Boo Bob
Feb 25, 2010, 08:19 PM
Well, sorry, but I don't have a fix... I had the same thing happen, but I didn't install Overflow. I think I just ran NitoTV and ATVFiles. At that point I still had Finder, but once I restarted Finder I lost main menu (Finder) like you did.

I'm running a full restore (had to go with Menu & minus for 6 seconds) and will start from the top after OS update is done.

I'll go for restarting Finder after each and every operation I do to see if I can nail down the culprit (seems the only thing we both did was NitoTV).

Good idea about setting up iPhone Remote app. I'll do that first thing before running any mods.

Another note (probably not related) was that I attempted to install Perian and Rowmote through Software Menu, and when the "downloading" screen came up it went immediately back to the previous menu.

I see right away in Software Menu that it says "Update Me" for itself, but when I tried running the updater further down the list I got a similar error and it forced a Finder restart. I'm wondering if Software Menu that gets installed with ATVUSB-Creator (b13) needs some updating.

[Update 1]
Well, at the ATVUSB-Creator site (http://code.google.com/p/atvusb-creator/updates/list) I found a comment in a cry for help thread that talks about ATVFiles being the culprit. So, I guess I'll leave that alone for a while. My guess is that when you installed one of the others (Sapphire / XBMC / NitoTV) your trouble started.

Since Software Menu doesn't want to install Perian, I'm going to take a shot at NitoTV and see if it will run OK. If so then I'll have NitoTV install Perian (I think it does that, as well).

You didn't say if you ever restarted the Finder and/or actually used the first apps, or just installed inside Software Menu and moved on until the error forced a Finder restart. It could be that one of the others is causing the trouble (I'm guessing the problem apps are not compatible with the new Finder layout), but you said you only removed Overflow. Perhaps, since you have SSH access OK you should remove the others one at a time and see if one of them is the actual culprit.

Tomball
Feb 25, 2010, 09:46 PM
I forgot that I also installed ATVFiles.

I deleted it and rebooted and I've got video at the top level.

Thanks for the hint.

Tomball
Feb 25, 2010, 10:12 PM
As a newbie I have to ask about your title - Macrumors 6502. It's been a while since I've see 6502 - takes me back to my first Apple IIe.

Billy Boo Bob
Feb 25, 2010, 11:52 PM
Well, I just ended up installing NitoTV and used it to install everything else I needed. Since a couple other computers and this ATV will be using my video files, I'll just go with iTunes and run the shared library. Too many near full drives connected with video files scattered all over to have other computer users track them all down, as well as the ATV having to mount all kinds of drives just to access them all with ATVFiles or Nito's Files.

Tomball
Feb 26, 2010, 11:29 AM
Check this post (http://code.google.com/p/atvusb-creator/issues/detail?id=429&q=softwaremenu#c3)

You were right, my problem was due to ATVFiles. Things working perfectly after installing ATVFiles-1.3.0b1.

You can either ssh ATVFiles-1.3.0b1 to Atv or run the following command from terminal

Type:
wget http://ericiii.net/sa/appletv/ATVFiles-1.3.0b1.run

Once the .run file is on atv you can install from terminal

Type:
chmod +x ATVFiles-1.3.0b1.run

Type:
./ATVFiles-1.3.0b1.run


ATVFiles-1.3.0b1 is installed and working.