PDA

View Full Version : PB wouldn't turn on


dorqiekat
Sep 1, 2004, 02:37 PM
When I tried to turn on my PB this morning, it wouldn't power on. I'd push the power button and it'd make that clicking noise, but no joy. After about 5 min of trying, it finally powered. Is this a common problem?

emw
Sep 1, 2004, 04:54 PM
When you say "clicking sound" do you mean the sound the button makes when it's pushed, or the startup chime?

Sometimes the Powerbook will just take a few moments for the screen to register that it's starting up (go to the gray startup screen) even though it's been started for some amount of time. So, push the power button and just wait 10 seconds and everything should be good to go.

If, on the other hand, you pushed the power button, waited some amount of time, and the PB didn't start up (repeatedly), then it may be a bum switch and I'd have it checked out. Another way to check is to see if once the PB has started up, if you push the power button, does it quickly (and always) go to the "Sleep, Restart, Shutdown" dialog? If it does, then the switch would appear to be working and there may be another issue.

I'm assuming, of course, that there aren't other issues (not plugged in, bad battery, etc.).

Mord
Sep 1, 2004, 06:25 PM
my ibook did the same thing, it died completely as did my tv at the same time, i could not get it to boot so i left it overnight with the battery taken out and the next morning it worked, i do that with my macs when they get a problem, leave them unplugged for a while and it sorts itself out, sounds weird but it works.

emw
Sep 2, 2004, 06:44 AM
my ibook did the same thing, it died completely as did my tv at the same time, i could not get it to boot so i left it overnight with the battery taken out and the next morning it worked, i do that with my macs when they get a problem, leave them unplugged for a while and it sorts itself out, sounds weird but it works.

Have you tried resetting the PRAM? That is essentially what you do if you leave it unplugged with the battery out as well, I think. It may be a faster way to accomplish the same thing.

mojo2go
Sep 2, 2004, 12:16 PM
When I tried to turn on my PB this morning, it wouldn't power on. I'd push the power button and it'd make that clicking noise, but no joy. After about 5 min of trying, it finally powered. Is this a common problem?
This exact thing happened to me about a week after I got my PB. I tried several times and nothing happened. (I had been using battery power but I knew for a fact it was not low.) I let it sit for awhile and stewed about it. I was already to box it up and return it to the store, when as a last resort, I plugged it in - and it worked fine. No problems since.

My kids like to say "user error"...it's possible it was in sleep mode (?) when I "turned it on" - (which in essence turned it off) - and then didn't give it enough time for the next few button clicks. Chances are you aren't as ditzy as me :p

However, I would say if it happens again - don't hesitate to take it in or call for repair.