PDA

View Full Version : Cannot Connect Clients to 10.6 server




nyquist11
Mar 1, 2010, 04:59 PM
Last week I installed a new server on my network using a att u-verse box as my modem/router, and was able to set-up a vpn server and connect to it from my iphone from my office. I have 3 macbooks running 10.6 and one imac running 10.4 and none of these seem to be detecting the server as the manual says it will. From one of the macbooks, and I assume the others, I can connect with server admin to the server and modify settings. I also have a DNS name from cheapnames.com and would like it to point to the server for web, vpn, and mail connections. I had to disable the DNS server to allow me to connect to the server over server admin. My computer detects it over Bonjour but will not let me screen share, or connect to it in the finder window (button next to screen share). I have open directory enabled, and an username that matches the users of each of the macbooks and the imac, yet there is still no connection. When I attempt to connect through login settings I get an error code (2200) "Could not resolve address". What should I change to get the computers connected to the server (still behind my u-verse router)? Thank you for your help. :apple::apple:



TheCoupe
Mar 1, 2010, 07:06 PM
Hi, the one thing you need to ensure when setting up Mac OS X Server, is that the DNS is turned on and functioning properly as a lot of the other functions, such as iCal server, Address book server, Mail server etc, all rely on it.

So firstly, make sure your dns is turned on.
Secondly, make sure Kerberos is working for Open Directory
Thirdly, make sure in your network preferences, to have your server IP listed as the FIRST dns address (this is what catches a lot of people out - without this, the DNS on the server will most definitely not work)

If your client computers are trying to ping the domain of the server, they too must have the IP address of the server as their FIRST dns address in network settings.

Once you have done this... your 10.6 clients should pick up the server no problems and will possibly be prompted for client setup.

Failing that, you can open your system preference on the client machines, click on accounts, followed by Login Options... to the right, you will see 'Join', where you can type in your server's domain (once you have ping tested to make sure it works and resolves) and configure your directory access that way.

Any other problems, give me a shout, but hopefully this should get you started.

nyquist11
Mar 1, 2010, 08:34 PM
Thank you for your response. I have just enabled the DNS server. For some reason I cannot launch server admin without it crashing. None of my macbooks seem to want to connect to the server, and I am still getting the same error code after I press the join button. I do not know anything about DNS, but does my att box have to be turned off in some way in order to make this work?:confused:

calderone
Mar 1, 2010, 10:27 PM
If DNS is running and setup properly, you need to point your clients to the server.

To check if DNS is working, run the following command on the server:

sudo changeip -checkhostname

You should see something like:

Primary address = 192.168.1.2

Current HostName = myserver.example.com
DNS HostName = myserver.example.com

The names match. There is nothing to change.
dirserv:success = "success"


If you see that, DNS is working. If it errors, DNS is not setup properly. You should go back and find the problem (the guide below will help you).

If it checks out, on your client machines, change their primary DNS server to your servers IP address. So for the example above it would be 192.168.1.2.

To test that lookups are working, run this on the clients:

nslookup myserver.example.com

This should list the DNS server IP, 192.168.1.2 and the result:

Server: 192.168.1.2
Address: 192.168.1.2

Name: myserver.example.com
Address: 192.168.1.2


You then need to bind the machines to the ODM.

For 10.5, /Applications/Utilities/Directory Utility.app
For 10.6, Systems Preferences, Accounts, Login Option, Join or
/System/Library/Core Services/Directory Utility.app

Use your servers address, you may be asked for authentication (directory admin) if you checked "required authenticated binding."

Now, he is where most flounder. They add users in WGM, but they do not specify a home directory location. This is necessary, even if not using network homes. If you want local homes and have existing users, set it the /Users *Be sure to change ownership on the present local home*

This guide is for 10.5 but it is pretty much the same: http://www.afp548.com/filemgmt_data/files/Leopard%20Server%20Quickstart%20Guide.pdf

I recommend reading this fully and then read through it again while going through the steps.

nyquist11
Mar 2, 2010, 05:02 PM
I did enable the DNS server and change one of my clients to connect to it from system preferences, but then the client lost its internet connection. This is why I thought there may be some conflict with the Att box. :confused:

nyquist11
Mar 2, 2010, 06:06 PM
I Get:


Primary address = 192.168.1.90

Current HostName = server.companynet.net
DNS HostName = companyserver

To fix the hostname please run /usr/sbin/changeip for your system with the
appropriate directory with the following values

Is this wrong? how do I change the DNS HostName?

calderone
Mar 2, 2010, 06:59 PM
DNS is setup improperly. Follow the instructions given in the return message.

Your clients did not lose their internet connection, they lost the ability to resolve external names. You need to configure the DNS service with forwarder addresses (In the Settings tabs). You can use the AT&T DNS servers or some other DNS service (google, opendns, etc).

The DNS server only returns information for the zones you have configured. Any domains that the server is not an authority for are passed onto the forwarder addresses.

Please read the PDF I linked, it covers DNS.

cpguru21
Mar 3, 2010, 08:58 AM
Just curious....

looking at what you are discussing here, are you trying to configure and connect remotely? if so you may want to try setting up and connecting on local lan of your server first, then once that is working try over the wan.

Also, located here:

http://www.apple.com/server/macosx/resources/documentation.html

are some great documentations that may help you get DNS up and running.

I have a remote (satellite offices) set up all connecting to my 10.6 snow leopard open directory across firewall (open bsd maybe?). On remote offices, even though i had DNS set up properly, dns does not work accross VPN, at least in my case. OSX likes everything to work on naming. What I did to make the system work (ichat, open directory etc...) was add an entry in to host file for my server name. I did not have the option to set up dns forwarding, as I do not have access to my firewalls.

I may be off on my help here, calderone has the best response in troubleshooting whats wrong with your dns setup.

Also:

When I originally set up my OSX 10.6 clean installs, I had to reinstalled a few times. Reason: change my host name after setup of snow leopard servers. According to apple tech...the original setup hits some configuration files that dont get hit later on if you change your host name. I have also found it easier to try to set up DNS from the original install.

Pick a host name from the beginning and commit to it. Don't change it.

If you do not have data yet on the servers you may want to try this. You can export your OD to a backup and all your users etc, then re-import after you reinstall.

Hope some of this info helps.

In regards to your modem you keep mentioning.....not sure where this comes in to play. Is this the gateway to internet for the server side? If so, you can tell dns to forward all requests for names it cant resolve to the modem ip so you can resolve dns for web pages etc.

nyquist11
Mar 4, 2010, 07:05 AM
I was able to connect to my server over screen sharing for the first time when I disconnected from by AEBS and to my router directly. I also was able to join my open directory server. I was not able to login even after my specification of the home folder for users. I do believe file sharing is working because I can connect over time machine and backup.

calderone
Mar 4, 2010, 09:36 AM
I was able to connect to my server over screen sharing for the first time when I disconnected from by AEBS and to my router directly. I also was able to join my open directory server. I was not able to login even after my specification of the home folder for users. I do believe file sharing is working because I can connect over time machine and backup.

What did you specify as the home folder? If it was a network share, you need to enable automount in Server Admin for that particular share.

You can use dscl in Terminal to make sure the client is reading the OD properly and seeing the correct home directory.

nyquist11
Mar 5, 2010, 06:45 AM
What did you specify as the home folder? If it was a network share, you need to enable automount in Server Admin for that particular share.

You can use dscl in Terminal to make sure the client is reading the OD properly and seeing the correct home directory.

I set the auto mount in /users and made sure automount was enabled. This didn't seem to work. Then I fixed the dns server and connected the clients to it. Still no luck. Then I looked on the sharepoint page and realized that the sharepoint was on l-somethingV/120.0.1 which isn't the ip address for my server. Any way to change this?