PDA

View Full Version : High Pitched Sound When MBA Connected to TV and Hi-Fi




dehory
Mar 2, 2010, 07:07 PM
When I connect to an HD TV using the Mini DisplayPort (via a Monoprice Mini DP-DVI dongle and a Monoprice DVI-HDMI cable) and to a Hi-Fi system using the headphone out, the Hi-Fi speakers emit a loud and persistent high-pitched whine.

The whine disappears when I disconnect the Mini DP dongle, and also when I disconnect the audio cable so that the sound is playing through the internal speakers. There's no whine when I connect earphones to the MBA instead of the Hi-Fi. I don't have another external display with which to test the issue, so I'm not sure if this sound exists when the computer's connected to, say, an ACD.

I'm surprised that this problem doesn't seem to have been mentioned on this board, but it's well documented on the Apple boards (1 (http://discussions.info.apple.com/thread.jspa?messageID=10739011), 2 (http://discussions.apple.com/thread.jspa?threadID=2310674), 3 (http://discussions.apple.com/thread.jspa?threadID=2310674), 4 (http://discussions.info.apple.com/message.jspa?messageID=8987559)). The consensus over there is that it's a fundamental design flaw in the MBA and that the only solution (http://discussions.apple.com/thread.jspa?messageID=9072336#9072336) is to get a ground loop isolator. Has anyone here had the problem and been successful in getting it fixed by Apple?

The reason I ask is because my MBA has fallen victim to another common audio problem (http://discussions.apple.com/thread.jspa?threadID=1736638&tstart=0) for which I may need to bring it in for servicing, and I am not sure if it would be a waste of everyone's time to have them attempt fixing the problem.



dehory
Mar 3, 2010, 04:51 PM
Seems like nobody else here is afflicted by this problem, but this may prove useful to someone in the future.

One way I discovered to minimize the high pitched tone is to use the TV's line-in socket, rather than going directly through the Hi-Fi receiver.

It seems perhaps the latter amplifies the line signal to the extent that the tone is particularly loud. Even though my TV's audio gets routed through the Hi-Fi receiver anyway, the TV's line-in appears to be less sensitive than the Hi-Fi's.

Another possible explanation is that the ground loop somehow becomes more of a problem when video is going into one piece of equipment and audio into another, but that's entirely speculative on my part.

The net effect in any case is that when I do this in combination with maxing out the volumes in MPlayer Extended (VLC will probably also do the same job) and my MBA, the whine is barely, barely (perhaps not at all) audible beneath the movie.

chown33
Mar 3, 2010, 08:12 PM
Another possible explanation is that the ground loop somehow becomes more of a problem when video is going into one piece of equipment and audio into another, but that's entirely speculative on my part.

Good guessing! That's what a ground loop is: two points in a circuit that should be at the same ground potential but aren't. And one good way to do it is to have a long distance non-ideal conductor between two ground points.

When the two points aren't at the same potential, a current flows between them (ground loop current), and that current flowing through the resistance between the two points develops a voltage that is effectively added to the input signal (a summing junction).

Scottsdale
Mar 3, 2010, 10:39 PM
Good guessing! That's what a ground loop is: two points in a circuit that should be at the same ground potential but aren't. And one good way to do it is to have a long distance non-ideal conductor between two ground points.

When the two points aren't at the same potential, a current flows between them (ground loop current), and that current flowing through the resistance between the two points develops a voltage that is effectively added to the input signal (a summing junction).

Nice info. Good post.

Consultant
Mar 4, 2010, 01:30 AM
Is the TV connected to a different power strip than the receiver?

Moodikar
Mar 5, 2010, 01:25 AM
I've had this issue.
I'm a DJ. I've owned the rev B and currently the rev C.
The Rev B was like this immediately on my TV and sound system.
I returned my rev B to Apple and even gave them a portable powered speaker so they can hear it. When they played a song and then stopped it, they could hear a high pitch sound. After a minute, it would switch to a beeping noise (as if on standby) till it cut out. As soon as I played music again, it would return (as it initiated it). Apple here in Toronto tried to replace various parts inside (the motherboard, sound connectors, cable, etc). When that didn't work, they tried it on 4 new Macbook airs and had the same problem. Finally, they gave me a new Macbook Pro.

I hated using the Pro so when the Rev C came out, tried my luck again. This time it was less noticeable. You can only hear it on a TV when you turn it up. It is not noticed on a sound system (especially since I DJ and do a lot of corporate events using mac to play music).

In both revisions, you cannot hear it on headphones. Weird.
To get by, I've turned all my movies up louder (by saving them again with Quicktime 7 after adjusting the volume setting). The louder the signal, the more you can turn down the TV volume and the less noticeable of the high pitch.

It's hard to prove this situation although there is an issue.

stoconnell
Mar 5, 2010, 11:59 AM
Are you using the AC adapter connected via the 2 prong in-brick plug or using the 3 prong extended plug. I am curious if the addition of the grounding prong helps or not.

dehory
Mar 5, 2010, 12:17 PM
Good guessing! That's what a ground loop is: two points in a circuit that should be at the same ground potential but aren't...

Thanks for confirming this hunch!

Is the TV connected to a different power strip than the receiver?

No, the same one. I did try plugging my MBA into different power outlets, but this made no difference.

Are you using the AC adapter connected via the 2 prong in-brick plug or using the 3 prong extended plug. I am curious if the addition of the grounding prong helps or not.

I used the extended plug, but the ground prong did not help.