PDA

View Full Version : rev. A MBA keyboard backlight issue




Alkiera
Mar 16, 2010, 11:10 AM
I've had issues with the keyboard backlight for some time; until recently, it had been off, and the keyboard options to turn adjust brightness would pop up with the circle/slash 'no' symbol when pressed.

Well, I recently managed to get my MBA to where it wouldn't boot. (Word of warning, don't try to update the XML2/XSLT libraries and fail. It's bad.) So I had to do an archive&reinstall, as I hadn't backed up everything on the machine, and didn't wanna lose it all.

After it rebooted from the 2nd DVD, I saw something I hadn't seen in over a year... backlights, behind my keys. I hit the adjustment keys, and was able to dim them, and turn them back up. Amazing!

Then I installed the 10.5.8 update (disc installed 10.5.1), and now the lights are back to the way they were before... off, and acting disabled. All the settings are the same, the lights just worked under 10.5.1, and not under 10.5.8.

Is it possible a kext or something is causing this? That a clean reinstall then update to 10.5.8 would have them working, at least until I reinstall whatever program is interfering in the first place? Or is there some problem with 10.5.8 breaking the settings? Possible the kext(or whatever) wasn't running under 10.5.1, and that's why I had lights until the update?

I've decided that I need a linux vmware image for playing around with advanced Ruby stuff... hosing the macos XML libraries with an update just isn't cool. 8(