PDA

View Full Version : rotten mini media center wifi performance .... any ideas??




itsjustmeee
Mar 23, 2010, 10:40 AM
I'm noticing that my new mini HTPC has very sketchy wifi performance. I know it's not the actual mini itself ... it's just that it's receiving a lot of interference from the rest of my media components. It's sitting near my 46' sony tv and the sony home theatre with Airplay wireless speakers. From what I'm reading in various forums, lots of mini owners are running into wifi issues. The newer ones are very prone to wifi interference. Almost to the point where some people say they should be recalled. Placement of the mini by just a few inches away from other devices can make a huge difference. For example last night I was only connecting at 6 Mb/s and then I turned off my LaCie drive (which was about a foot away) and then it connected at closer to 14 Mb/s. BTW, I'm using a new airport extreme at 5GHz for my wifi. People on other forums have even suggested to pick up the mini, move it into other various positions (like on it's side) and then go to speedtest.net and see if it helps.

My question is will buying an airport express and putting it near the mini help? How about changing channels on my airport extreme? Any other suggestions??



mstrze
Mar 23, 2010, 11:00 AM
Well...the absolutely fastest speeds will be obtained by hooking an ethernet cable between your router and the Mini.

itsjustmeee
Mar 23, 2010, 11:05 AM
mstrze, I'm aware of that, but it's not feasible for me to have the modem and router sitting in the living room. I need it in my office and hooked up to my mac pro and at this time, and running a cable between those rooms is a bit impractical right now. I was just hoping for "tweaking" suggestions here.

mstrze
Mar 23, 2010, 11:19 AM
Hmm...you absolutely need it in your office? MacPro doesn't have an Airport card? Maybe the MacPro will have fewer issues connecting wirelessly than the Mini will and this alternative setup will save you money and headaches from trying something that may or may not work.

I just say this because my router and modem (and printer) is in my bedroom while my computer setup is in our front office area...about 40 ft away.

itsjustmeee
Mar 23, 2010, 11:29 AM
Actually, my mac pro doesn't have an airport card. It's an early '08 and at least at that time, they didn't include one. It's seems crazy that they would leave something like that out, but they did.

Bye Bye Baby
Mar 23, 2010, 11:49 AM
What about extending your network with an airport express?

I have done that and find that it boosts the quality of reception in the whole house.

mattwolfmatt
Mar 23, 2010, 11:53 AM
Did you recently upgrade the memory or the Hard drive? When I did that in my mini, I accidentally pulled out the airport wire. From then on airport signal was sketchy.

itsjustmeee
Mar 23, 2010, 12:05 PM
I haven't opened the mini, it's just as it was out of the box. I've been playing around with switching channels on my airport extreme and interestingly enough, the lower channels on the 5GHz band work much better. I took off the auto setting on "Radio Channel Selection" and tried all of the upper frequencies and couldn't connect at anything faster than 10Mb/s. And when I set it to channel 48, it clocked in at 20 Mb/s ..... go figure!

If I can't keep a consistent streaming speed, I just might go with adding an airport express next to it.

Flynnstone
Mar 23, 2010, 12:15 PM
Simple answer:
Run ethernet cable. Not likely a real possibility since you're using wireless for other stuff as well.
But I always find hardwire as less hassle.

srexy
Mar 23, 2010, 03:43 PM
Definitely play with the channels. Also look at potential barriers to your wireless signal such as wooden bookshelves, components that are in the way, metal shelving etc. One of the things that always plagued reception in my house is that the wireless N signal allegedly works much better on the horizontal plane than the vertical. I had my AEBS directly below my MacBook Pro but one story down and the performance was horrendous. I added a second AEBS (my first was pre gigabit) on the 3rd floor and now I have virtually no dead-spots in the house.

I think you do know this but in case you don't - if you alt+click on your airport indicator, it will give you your signal strength.

waw74
Mar 23, 2010, 06:13 PM
There are also ethernet over power adapters, I've never used one, but something to look into

fpnc
Mar 23, 2010, 06:29 PM
...People on other forums have even suggested to pick up the mini, move it into other various positions (like on it's side) and then go to speedtest.net and see if it helps...
You shouldn't use SpeedTest or any other internet bandwidth testing utility or website since the broadband throughput from your ISP can change radically from minute to minute.

Since you're testing with a Mac mini can you enable file sharing and try a wireless file transfer to/from that system using another Mac?

As a case in point, I get about 20Mbps both to and from a PowerPC Mac mini that is connected to an Airport Express in an extended network mode (WDS). My Airport Extreme (which is my main router) is about 30 feet away from my Airport Express and both basestations are running 802.11n in the b/g compatible mode. I'd like to be able to run 5GHz, 802.11n-only mode but I've found that Apple has pretty poor support (or none at all) for creating a WDS network over 5GHz 802.11n. I've also found that my Airport Express slows down quite dramatically after a week or two of operation which requires a power restart of both basestations about every ten days. The differences in the transfer rates can be quite dramatic before the restart -- usually a factor of about twenty to one (when "bad" the transfer rate can fall to less than 2Mbps and after a restart it goes back up to 20Mbps and stays that way for days afterward). I also enable interface robustness and am using WPA2 Personal wireless security.

itsjustmeee
Mar 24, 2010, 10:47 AM
So after a day of playing around with all of the settings on the airport extreme, I've determined the problem has to lie elsewhere. Changing the channels has mixed results ..... but the bottom line is just that the mini won't pick up a consistent wifi signal. When I first got it, I took it to applecare and it worked like a charm in the store. It was getting away over 25 Mb/s, but here at home it's all over the place (unlike my 2 macbooks which always get over 20 Mb/s.) The best that I can figure out is that 1, the new minis have rotten shielding and 2, it's where I have it placed. It is about 2 1/2 feet away behind my sony 46 inch tv which is about 35 feet from the AEBS. That seems to be the culprit. I thought it might be the wireless speakers with the surround, but they are using the 2.4 band. Does anyone else have a problem with TVs interfering with wifi?

Also, I read in one forum that HDMI cables can actually send out a signal that will interfere as well. I have no idea if that's true or not.

wysinawyg
Mar 24, 2010, 11:10 AM
As a development of one of your earlier thoughts, how about using an Airport Express located in the room (but away from the hifi equipment) and then hard wire the mini to the Airport Express?

That way you should be able to circumvent any local interference issues.

srexy
Mar 24, 2010, 01:07 PM
So after a day of playing around with all of the settings on the airport extreme, I've determined the problem has to lie elsewhere. Changing the channels has mixed results ..... but the bottom line is just that the mini won't pick up a consistent wifi signal. When I first got it, I took it to applecare and it worked like a charm in the store. It was getting away over 25 Mb/s, but here at home it's all over the place (unlike my 2 macbooks which always get over 20 Mb/s.) The best that I can figure out is that 1, the new minis have rotten shielding and 2, it's where I have it placed. It is about 2 1/2 feet away behind my sony 46 inch tv which is about 35 feet from the AEBS. That seems to be the culprit. I thought it might be the wireless speakers with the surround, but they are using the 2.4 band. Does anyone else have a problem with TVs interfering with wifi?

Also, I read in one forum that HDMI cables can actually send out a signal that will interfere as well. I have no idea if that's true or not.

The only surefire way you're going to find out if it is a placement issue is to move it out of its current location. If you haven't already, enable screensharing from the system preferences, unplug it from its current location and move it to a well exposed area then use another mac to connect and see what kind of reception you're getting.

statik13
Mar 24, 2010, 01:24 PM
You could always use an airport express as a wireless bridge.

My mac mini was having troubles with reception due to how close I have it to my TV & stereo. I ended up just disabling the wifi on my Mac Mini and running an ethernet cable to my airport express that was located a few feet away from my HiFi equipment.

Worked like a charm. I get great reception now.

statik13
Mar 24, 2010, 01:26 PM
As a development of one of your earlier thoughts, how about using an Airport Express located in the room (but away from the hifi equipment) and then hard wire the mini to the Airport Express?

That way you should be able to circumvent any local interference issues.

Whoops, didn't notice somebody already suggested it.

+1.

itsjustmeee
Mar 24, 2010, 02:24 PM
Srexy, I was talking to apple support, and that's exactly what we did ... enable screen sharing and started moving stuff around and turning off my media devices and my wifi speed was all over the place. Sometimes I thought we found what was interfering, and one minute it was fine and others slow as molasses even with things off and on around it. Statik13, I'm coming to the same conclusion that you already did. Looks like there's a trip to the Apple store in my very near future!

vwDavid
Mar 24, 2010, 05:59 PM
are you using a monoprice mini-display port cable? If so that could be your problem. Change to wifi channel 11 or complain to monoprice and get your cable swapped.

http://forums.macrumors.com/showthread.php?t=877281

itsjustmeee
Mar 24, 2010, 10:12 PM
So I got an airport express today and put it a good 10 feet away from the tv (and 10 feet closer to the airport extreme), disabled the wifi on the mini and hooked it up to the express via ethernet. And I'm still getting mixed results. I was on the phone to an apple upper level wifi expert for a good 30 minutes today. We tried everything .... switching channels on the extreme, using the express to "join a network", "extend a network" and still with mixed results. Bottom line is that it HAS to be the placement of the extreme and how the express sees it. Sitting on my couch 6 feet away, I get a consistant 23 Mb/s on my macbook. There is nothing even near the express now. No electrical devices, not a thing. Could be the wiring in the house .... who knows. I'm going to try and move the extreme a few feet closer later and see what happens then.

I guess my last move could be to move the modem and router to the mini and then use the express for my mac pro in my office. It's just that I upload a lot of big files with my work and having the mac pro wired always made more sense.

vwDavid
Mar 25, 2010, 12:13 AM
what is your video interface? My mini displayport adapter killed my wifi. its a long shot but try w/o it.

itsjustmeee
Mar 25, 2010, 01:38 AM
Well that's the interesting thing. The mini is now hooked up to the airport express that's 10 feet away by ethernet, so I'm totally bypassing the wifi in the mini. It's been a real mystery, but if it's solvable, I'll figure it out eventually!

agwilson
Mar 25, 2010, 02:37 AM
I'm noticing that my new mini HTPC has very sketchy wifi performance. I know it's not the actual mini itself ... it's just that it's receiving a lot of interference from the rest of my media components. It's sitting near my 46' sony tv and the sony home theatre with Airplay wireless speakers. From what I'm reading in various forums, lots of mini owners are running into wifi issues. The newer ones are very prone to wifi interference. Almost to the point where some people say they should be recalled. Placement of the mini by just a few inches away from other devices can make a huge difference. For example last night I was only connecting at 6 Mb/s and then I turned off my LaCie drive (which was about a foot away) and then it connected at closer to 14 Mb/s. BTW, I'm using a new airport extreme at 5GHz for my wifi.

I noticed you are using Airplay wireless speakers. Have you tried turning off all parts of this: base unit and separates? Try turning all parts of it off and each individual speaker if you can or unplug them. Then try testing your network over a period of time, 15 minutes or so.

itsjustmeee
Mar 25, 2010, 10:26 AM
I did try turning off each of the 3 media components with mixed results. They sony airplay speakers use 2.4 Ghz band and I'm running the airport extreme with dual band ... 5 Ghz for the computers and 2.4 for my iphone. The mystery continues.

minimacman
May 13, 2010, 04:31 PM
The mystery continues.

What was your solution? RSVP!

Oliver

brand
May 13, 2010, 06:53 PM
Actually, my mac pro doesn't have an airport card. It's an early '08 and at least at that time, they didn't include one. It's seems crazy that they would leave something like that out, but they did.

It's not that Apple left the Airport card out of your Mac Pro, instead you neglected to order a Mac Pro with a Airport card in it. I have a early 2008 Mac Pro with an Airport card in it because I chose to order the Mac Pro with a Airport card in it.

ljonesj
May 14, 2010, 09:18 AM
i would try using g instead of n as sometimes the frequencies can be blocked by walls and other things and the higher the freq like 5ghz are closer together in there sin wave so a wall can actually hit and bounce it back