PDA

View Full Version : No digital audio out?




speters
Apr 6, 2010, 02:17 AM
I had a bunch of people over to watch some movies and I could not get any sound out of the spdif connection. I have and 8 Core Mac Pro with the digital out connected to my home theater. I use either xmbc, or vlc to play back my .mkv files apple dvd player for dvd's. I have been doing this for about 8 months and I have hd no issue getting 5.1 from the dvd player. It took me a while to figure out how to get 5.1 from xmbc and vlc but I was eventually able to do it. I was have been using snow leopard since it first came out. Well yesterday I updated to 10.6.3. I had no issues getting audio out lof the line level but when I select the spdif I get nothing from the dvd player, xmbc or vlc. I have found that when I go into the prefs and select digital out, then go into xmbc or vlc then go back to prefs in sometimes jumps back to the line level output. I have checked the prefs audio settings for xmbc and vlc and they are all set correctly but I still get no sound. Does anyone have any advice? I eve tried swapping out my spdif cable with no luck. Can anyone help me



jcschlic
Apr 6, 2010, 09:08 AM
Is audio via SPDIF through iTunes working? I would try to narrow this down as much as I could. Try playing a regular audio file...

iTris666
Apr 6, 2010, 10:01 AM
I have no problem playing regular audio through SPDIF in vlc (with the (encoded) option) , but I'm not sure If I tried with Dolby Digital or DTS signal since 10.6.3 . I'll try that this evening. I have a 2008 Octo Mac Pro.

fpnc
Apr 6, 2010, 03:03 PM
You don't say how you got xmbc and vlc to work but I wonder if you did that through a custom, third-party extension or driver. If so, then I'd suspect that this non-Apple extension is your problem.

iTris666
Apr 6, 2010, 04:52 PM
dolby works fine in vlc. Note that I have a USB audio interface which is used as default output. vlc has optical for itself.

speters
Apr 7, 2010, 12:20 AM
I have no audio through itunes either. I do get sound when using the line out, but nothing with the digital out. The thing I don't understand is that I had this working for the last 6-8 months. I am trying to think what I have changed since I last had it working. There are several things that I have done, 1) updated to 10.6.3. 2) Updated Perian. 3) After updating perian I think that I might have run a terminal command "defaults write com.cod3r.a52codec attemptPassthrough 1" and "defaults delete com.cod3r.a52codec attemptPassthrough". I am not sure if that could have had any effect?

I have checked the cable and tried in with another source, and it and the input on my processor are both working. The crazy thing is that I also have a dual core G5 running 10.5.6 and everything use to work fine on that as well, but now I can no longer get audio from that computers spdif as well. But again, I am pretty sure that I had updated perian and ran the same command line. Thinking that maybe it was perian, I first ran "Remove Perian" from the preferences, then actually went into library and deleted. But still no sound.

In normal situation if I had two sources that I couldn't get sound from I would say it either has to be either the cable or the input on the audio processor. But if I hook up a normal dvd player to that same cable and input I get sound. So I am thinking there must be something going on with computers. My HT processor is the Theta Casablanca III, and on the front panel there is a blue light that is lit up when it is locked onto a signal, so it is getting a signal. Does anyone have any ideas?

Thanks,
Steve

iTris666
Apr 8, 2010, 02:26 AM
Go to Audio and Midi configuration in the utilities folder and make sure the digital out is configured to 48000 Hz 2ch-16bits.

The perian walkthrough ask you to go there and change the values. Maybe you set the values and forgot.