PDA

View Full Version : OSX Server 'mDNSresponder' Error




zyggiepyggie
Apr 9, 2010, 03:27 AM
Hi,

I'm new to the forums, have been browsing for a couple of weeks but have never posted before.

I'm having some issues running OS X Server 10.5 on a Mac Pro (not sure what year it is) that I'm hoping someone will be able to shed some light on.

Basically, the server has been used for a while for nothing more than storage of old data until recently when I decided to transfer the data somewhere else and re-use the server for controlling network policies. There were a lot of errors looping in sys.log for a few days which I had trouble clearing, in the end I decided to format it completely and re-install OS X. I concluded the errors had formed from a year of having no attention payed to it.

It installed fine, I set up a couple of things in Workgroup Manager rebooted and then the following error was looping at start up.

OSXServer com.apple.launchd[1] (com.apple.mDNSresponder[31]): posix_spawnp ("/usr/sbin/mDNSresponder",...): no such file or directory

The number at the end of '(com.apple.mDNSresponder[31]):' was counting up, it got to about 61 before I decided it wasn't going to work.

I figured I'd done something wrong and re-installed the OS. This time everything was going well for 4 -5 days after various reboots/testing different policies it was coming back up - had no errors or anything that made me cautious of it going down again.

Yesterday, after a day of not using it I tried to wake it from the screensaver and it wouldn't. I tried pretty much everything I could think of to avoid hard resetting it but in the end I bit the bullet and upon rebooting the same error started cycling.

Now, I know vaugely what mDNSresponder is used for but I don't understand why the directory is disappearing/becoming corrupted. Is there an unwritten rule that you shouldn't hard reset servers that I've never heard? Or am I screwing something up when initially setting it up?

Sorry I've dragged on, I just want to try and include as much detail as possible.

Cheers,
Jake.

EDIT: I can access the server in Safe Mode.