PDA

View Full Version : Bookmarks GONE from iMac, but remain on iPhone/iPad - Manual sync not restoring them




mconk
Apr 13, 2010, 08:38 PM
Hey guys,

This morning I noticed every single one of my bookmarks in the bookmarks bar, and bookmarks menu in Safari on my iMac have magically disappeared. However, they are still present on my iPad, and on my iPhone.

I have Mobile Me setup to auto-sync across all devices, so I am not qute sure what the heck has happened. I *DID* try to go into Mobile Me system prefs, and clicked Advanced>Reset Sync Data>Selected Bookmarks, and chose to replace Mobile Me data with the data on the computer....and nothing.

If my iPad, iPhone, and iMac (geeze, the iEverything is getting redundant!) are all syncing automatically across the board, you'd think since my iPad/iPhone both still have the bookmarks listed correctly in Safari, that when I manually overwrite the data on my computer, with the MobileMe data, it would push the iPad/iPhone bookmarks back onto the computer....no??

I would consider myself a pretty advanced level Mac user...but cannot for the life of me figure out how to even find where the MobileMe sync data is even stored...I poked around the iDisk...nothing there, as far as I can see.

What would you guys suggest doing at this point? Should I connect my iPhone or iPad via iTunes - or will a sync through iTunes wipe out all of my bookmarks on the device, since theyre now gone from the computer? This is what I would presume would happen. In iTunes, there is an option to manually push new data onto the DEVICE, but not vice-versa from the device to the computer...at least it wasnt setup that way last time I checked. This would be incredibly useful, if it was setup to go both ways.

I think I am back to square one...send me some ideas!!!

Thanks,
Michael



mconk
Apr 13, 2010, 08:59 PM
Alright, so I came across a blog post from a few days ago, from someone who has experienced the same exact issue.

http://www.zeldman.com/2010/04/09/disappearing-bookmarks-bug/

One of the very last comments, he mentioned how he turned bookmark syncing OFF on his iPhone, then simply turned it back ON, and then forced MobileMe to replace the computers data, with the MobileMe data. Simple enough.

However, when I try to re-enable bookmark syncing on my iPad, a prompt displays which states: There are existing bookmarks on your iPad. Would you like to merge them with your MobileMe account. My first though it, YES...duh! BUT, I do NOT have ANY CLUE what is on already on the mobile me server. IU want to say that theres NOTHING there at all, since mobile me wiped my imacs safari browser totally clean...but, it wants to MERGE them form the iPad. Maybe its just worded that way no matter what? It is giving the false idea that Mobile Me already contains bookmarks...which i dont think is true, but I guess anything is possible at this point.

I am still wondering how to view the Mobile Me bookmark file, so I can see exactly what is up inthe cloud right now, and try to get to the bottom of this...

jasava67eg
Jul 29, 2010, 03:30 PM
Gidday, I suspect that after this amount of time you've probably resolved your issue. However . . .I had the exactly the same issue (except with my Macbook) a couple of days ago (iPad only just released in NZ).

I deleted my MobileMe account from the Ipad (it had been automatically synced during the iPad initial set up with itunes), and then added it again manually on the iPad.

All seems to be working properly now, with bookmarks syncing both ways beteen iPad, Macbook and iPod Touch.

Cheers

todddixon
Aug 1, 2010, 06:22 PM
Gidday, I suspect that after this amount of time you've probably resolved your issue. However . . .I had the exactly the same issue (except with my Macbook) a couple of days ago (iPad only just released in NZ).

I deleted my MobileMe account from the Ipad (it had been automatically synced during the iPad initial set up with itunes), and then added it again manually on the iPad.

All seems to be working properly now, with bookmarks syncing both ways beteen iPad, Macbook and iPod Touch.

Cheers

Thanks for your input on this. I was going to try something similar with my customer today who was experiencing this issue. After reading this I rang her and she did it over the phone and now it all appears to be behaving. Tx again! [From and expat Kiwi living in Oz]