PDA

View Full Version : I ***** hate Subtitles!!!




cwazytech
Apr 15, 2010, 08:05 PM
***Let me apologize in advance by saying that this thread is not about how I don't want subtitles, rather, how I do want them during a foreign language portion of a movie I am currently encoding. If you came here thinking it was a thread about hating subtitles that show up during the movie then I am sorry for wasting the precious few seconds it took for you to realize this is not what you wanted to read. I am sorry for the inconvenience. Have a nice day:)***

I have a new DVD that I have encoded 8 times and cannot, for the life of me, get the foreign subtitles to work during the non-english speaking parts. I'm giving it another major go, but I feel like I've tried every combination of the "foreign language search", "english subtitles", and "forced only" settings I can think of. Has anyone mastered the subtitle dilemma?



Icaras
Apr 15, 2010, 08:15 PM
Your thread title is highly misleading.

cwazytech
Apr 15, 2010, 08:31 PM
Your thread title is highly misleading.

How so? I am talking about subtitles and I do hate them.

Icaras
Apr 15, 2010, 08:52 PM
How so? I am talking about subtitles and I do hate them.

But you want them. You need them. A conundrum?

NGL
Apr 15, 2010, 08:52 PM
How so? I am talking about subtitles and I do hate them.

It sounds like you are trying to remove annoying subtitles that you don't want, instead of trying to display the subtitles.

-Nick

cwazytech
Apr 15, 2010, 09:06 PM
Your thread title is highly misleading.

Sorry for the inconvenience. I added a disclaimer hoping it helps since I can't figure out how to change the title.

Icaras
Apr 15, 2010, 09:10 PM
Sorry for the inconvenience. I added a disclaimer hoping it helps since I can't figure out how to change the title.

heh, it's no problem. Nice disclaimer lol. Sorry though, I don't have a solution. I just came in curious about the title ;)

Balin64
Apr 15, 2010, 09:24 PM
I always had good luck with MacTheRipper and subtitled DVD's even old ones like Blade. Sorry I can't be more helpful.

tbayrgs
Apr 15, 2010, 10:12 PM
What DVD are you tried to encode?

BTW, I agree with you in that I hate the fact that there is no easy solution to add these types of subtitles to blu-ray encodes using MakeMKV and Handbrake using a Mac.

cwazytech
Apr 15, 2010, 10:41 PM
What DVD are you tried to encode?

2012

Corruptitudes
Apr 15, 2010, 11:00 PM
2012

I had problems with that as well. I didnt realize there were subtitles until it got to the Chinese people talking...

Are you using handbrake to encode? There is a subtitle setting that will finally put the subtitles in, I believe it was forced and default is what I checked...

cwazytech
Apr 15, 2010, 11:22 PM
Are you using handbrake to encode? There is a subtitle setting that will finally put the subtitles in, I believe it was forced and default is what I checked...

Yes. I am using HB. Which English Subtitle track did you use because there are 3 of them?

theLimit
Apr 16, 2010, 12:16 AM
Try playing the movie in DVD player and see what subtitle track it uses, then try that with your HB encode. That usually works for me.

ravenvii
Apr 16, 2010, 03:13 AM
I came into the thread planning to insult your intelligence, but saw the disclaimer.

Move on to the next post, folks, nothing to see here.

mrgreen4242
Apr 16, 2010, 08:24 AM
Have you tried the search for forced subs option?

cwazytech
Apr 16, 2010, 08:30 AM
Have you tried the search for forced subs option?

Yes. And yes to your next question.

mchalebk
Apr 16, 2010, 09:13 AM
I had a problem with forced subtitles on French Kiss. Nothing worked. I did a search in the Handbrake forum and they suggested using the snapshot:

http://forum.handbrake.fr/viewtopic.php?f=6&t=13969

I tried that and it worked. Not sure if it will fix your problem, but it did mine.

B.A.T
Apr 17, 2010, 09:27 AM
I ran into this problem this week while trying to rip both of the Kill Bill movies. Here is how I figured out how to do it. It may take a little bit of time up front but it will save you hours in the end.

1) Open the movie in HB
2) Go to the subtitles section and add english
3) Click on picture settings at the top of the HB window
4) Click on "live preview" and make a 60 second preview of the section of the movie where there are subtitles.

At this point you will see if there are subtitles where you want them. Often there will be subtitles through the entire movie. When this happens go back to source and pick the next movie file (vts_01_2.vob) and repeat the steps above. You may have to do this a few times but eventually you will figure it out. Each movie is different but it works. Good luck.

cwazytech
Apr 17, 2010, 12:10 PM
I had a problem with forced subtitles on French Kiss. Nothing worked. I did a search in the Handbrake forum and they suggested using the snapshot:

http://forum.handbrake.fr/viewtopic.php?f=6&t=13969

I tried that and it worked. Not sure if it will fix your problem, but it did mine.

This solution worked. Thanks a bunch.

mchalebk
Apr 19, 2010, 11:45 AM
This solution worked. Thanks a bunch.

Apparently, some DVDs do something odd with their forced subs that doesn't mesh well with the latest HB release. Fortunately the snapshots can save our butts when this happens. Glad to hear it worked.