PDA

View Full Version : AppleTv keeps dropping Network Connection




Rockdoc
Apr 26, 2010, 01:52 PM
Ok, so I have had my Appletv for a couple of years now and have never had a problem connecting and staying connected to my wi-fi network, which in turn doesn't connect to my itunes until I reconnect. However, for some reason for the last month or so I have had to re-type (which is a pain on the Atv remote) my entire password (15+ digits) everytime I use my appletv. This is driving me crazy, so...here is my setup and what I have tried, any help would be great!

I use a logitech univeral remote and thought that perhaps because the remote shuts down the appletv when you use something else like the SAT receiver or PS3 that it was a remote setting...I have reprogrammed my remote to not shut down the Atv when I switch devices(sat, ps3)...still same problem. Next I moved to my firewall settings on my Imac which is running OS 10.5 and thought that perhaps the firewall setting was blocking the connection to my Itunes and somehow(yes I am desperate) kicking the Atv off the network and not allowing me to stay connected to my network and itunes. So I changed my firewall settings and still no change in problem.

I should note that I do sleep my computer and use the Apple-tab-quite funtcion to close itunes, firefox mail etc when they are not in use...I did try leaving my itunes open yesterday and this morning Atv still lost connection to network.

Help???



mstrze
Apr 26, 2010, 02:06 PM
A couple things:

AppleTV does not 'shut down' per se. It goes into a standby mode. I also have a Logitech remote and experience this same thing. In fact, more often than not...it doesn't even necessarily go into the true standby mode. It certainly does not shut off...there is no power-off option for ATV.

You need to have iTunes up and running on the computer. This is why you are losing the connection I feel. You can sleep your computer and choose the option to 'wake on wireless' to allow your computer to only be accessed by ATV when it needs to be.

('wake on wireless' is a Snow Leopard option...I don't think you have the option on 10.5...although I could be wrong)


How you were not having connection issues before with iTunes not up and running is beyond me. :confused:


EDIT: What did you change in the past month? Software update?

Rockdoc
Apr 27, 2010, 02:59 PM
It seems like I have started to have the problem since I switched to the logitech universal remote. I even tried changing the power off sequence for my devices and switched the Atv to remain on. I am aware that the Atv stays in standby, but when I have switched actions to use the Atv it starts up with the apple logo in the middle of the screen. Before I hooked up the remote it would open to front row or the picture slideshow when I switched inputs through the tv remote. Feels like I am rambling...I think I am going to go back to the Apple remote for a couple of days to see if that works. If not I would consider an upgrade to Snow Lep.

Thanks for the ideas and help!

mstrze
Apr 28, 2010, 07:12 AM
Weird...seeing the Apple logo implies to me that the AppleTV IS being turned OFF by the Logitech remote.

Like you, when I usually turn on my system with the remote, I see either the photo montage (if it was 'shut down' in the middle of playing something) or the main menu. I NEVER see the Apple logo unless I physically unplug and replug the unit.

Maybe Logitech has actually stumbled on some sort of IR combination that allows the ATV to power down?? That would be odd...cause the ATV really isn't designed to 'shut off'.

rayward
Apr 28, 2010, 11:58 AM
FYI, "wake on network" only works on newer Macs, even if you have SL installed. I have a 24" iMac running SL (see sig.), but it is not capable of responding to a wake demand through the network. I set the CPU to be always on, and that fixed the issue I had with the ATVs dropping the link to iTunes.

I've never had an issue with my ATVs dropping the network itself, and I use 3 different models of Harmony remote on 4 individual ATVs.

Rockdoc
May 6, 2010, 08:59 PM
So, I am by no means a genius, but I certainly don't stumble around electronics like I have been...however, I have run out of ideas and options for getting my appletv to retain it's network connection. In fact, now it doesn't even remember the last movie I loaded on there.

Here is what I have tried since my last post...

Disconnecting power cable and doing a complete restart

Disconnected and unlearned logitech remote

Left iTunes up and running for over 24 hours

Reststarted router

Result: appletv still can't retain network connection!

Any thoughts?

cwaddell2002
May 6, 2010, 10:19 PM
Have you tried restoring your ATV to factory defaults? Also - wired ethernet is the way to go... you may not have even changed anything in your setup, but if a neighbor has a new network, or a new pice of network equipment, or moved a router, or even furniture, it could be interfering with your reception. If you want and or need to stay with your wireless connection, you might want to log into your router and make sure it is on a channel as far away from other networks as possible. To get a clear picture of what is going on wirelessly in your neighborhood, try kisMAC. My ATV has been running wired for 2 years with maybe a monthly glitch that requires a reboot (although that usually has to do with HDMI handshake issues with my AVR and plasma...)

Tasc
May 15, 2010, 08:42 PM
I'm having the same problem with my AppleTV and it just started happening within the last couple months. The wireless connection keeps getting dropped and I have to reenter all the information. I'm wondering if this has anything to do with the latest software update (if one was even released recently), since I never had this problem before.

The other possibility is I replaced my aging wrt54g router with a Linksys 320n router a few months back, which also could be the culprit - or just a coincidence.

supermanfan
May 15, 2010, 09:15 PM
I'm having the same problem with my AppleTV and it just started happening within the last couple months. The wireless connection keeps getting dropped and I have to reenter all the information. I'm wondering if this has anything to do with the latest software update (if one was even released recently), since I never had this problem before.

The other possibility is I replaced my aging wrt54g router with a Linksys 320n router a few months back, which also could be the culprit - or just a coincidence.

I too have started to see this in the last couple months I have four ATVs in my house and at least three of the four have this happen frequently (one a week). The fourth is not used too often, so not sure about that one.

I created a separate wifi network for my G devices (making the N and G bands separate), but that did not help.

Rockdoc
May 15, 2010, 11:52 PM
So, I am finally back up and running without a dropped network and also not having any issues with Itunes not finding Appletv.

Here is what I finally did.

I reprogrammed my logitech remote to no longer control any Appletv features except sound.

I did a factory reset and then loaded all 80gb of content back on the appletv.

Almost 2 weeks now and not once have I had to put network passwords nor have I encountered any issues with Itunes finding device.

Hope that helps...I will at some point add appletv back to logitech universal remote, which may end up answering my original problem.