PDA

View Full Version : Problem connecting to the network (with a cable)




tiny_101
May 4, 2010, 12:20 PM
Hi there,

I am having trouble connecting to the network on my Mac (w/ a cable), though my MacBook (wireless) has no problems. Under "Network", it says that the Ethernet Status is connected and is set to get an IP address (169.254.58.1) via DHCP. I'm not sure if this is of any importance, but the IP on my MacBook is 192.168.1.64.

Any guidance/suggestions would be much appreciated. Thanks in advance!



satcomer
May 5, 2010, 04:37 PM
OK do you have any MAC address filtering security on your Wireless router? Are you sure you have a good cable, etc?

RedTomato
May 6, 2010, 04:29 AM
If your wireless macbook is connected to the internet with IP 192.168.1.64 then your iMac should have an IP of 192.168.1.x (where x could be any number between 0 and 255.)

I think 169.254.58.1 is a self-assigned IP address - it seems that your iMac is connecting to the router but not getting an IP address from the router, so it is creating its own.

Are you sure that the two computers are connecting to the same router? It's possible that the macbook is connecting to a different wifi network.

Try connecting the macbook via a cable to the router (turn off wifi on the macbook) and see what ip address it gets, and then go into the router settings to see if there's anything stopping it giving the iMac an IP address.

bld44
May 8, 2010, 12:54 PM
If your wireless macbook is connected to the internet with IP 192.168.1.64 then your iMac should have an IP of 192.168.1.x (where x could be any number between 0 and 255.)


Not necessarily - it all depends on the local network is configured. If it's a self-assigned address, network preferences is going to say that the status is self-assigned and cannot connect to the internet:
http://lh4.ggpht.com/_gsl1Y6syQ7A/SqjryHNTt_I/AAAAAAAAAKs/TCZqeZL7VkE/s512/screenshot.png

If you're not getting a self-assigned message, the cable should be good - the issue is going to be with your router (mac address filtering, etc) and your mac's network settings (I know, real specific)...

tiny_101
May 11, 2010, 06:59 PM
Hi there,

Thanks for all the replies. This is actually extremely embarrassing, but I didn't bother to check which ports the cable was plugged into... and it turns out the service provider's tech rep plugged it into the wrong port.

Sorry for the trouble. I'll check more carefully next time :p Thanks again.

RedTomato
May 12, 2010, 02:35 AM
LOL :)

Sometimes the simple ones are the hard ones. You do kinda expect tech people to know what they're doing. Well spotted.