PDA

View Full Version : Airport Express printer problems..


MacFan26
Oct 1, 2004, 06:48 PM
I just got a Lexmark z816, which is plugged into the USB port on my Airport Express. When I try to print something, it is recognized through rendezvous, but it automatically stops the jobs. So, if I go to the printer and click on "start jobs" it says "opening printer connection" and then just stops the jobs again. The printer works fine when it is directly plugged into my powerbook, and my airport express works fine otherwise. Any ideas on why this isn't working? I've searched the knowlegebase, etc.

andysmith
Oct 2, 2004, 06:30 AM
I've heard problems with Lexmark printers and routers that have a print server built in - apparently they're very non-standard.

MacFan26
Oct 2, 2004, 01:21 PM
well...that sucks! Guess I'm out of luck for right now :(

MacFan26
Feb 1, 2005, 06:47 PM
Sorry to bring up this thread again, especially considering I started it, but has anyone else had a similar problem and been able to fix it? I've looked through the Lexmark knowledge base and haven't found anything related to Airport, I'm getting annoyed that I can't figure out how to use it with my Express :(

tomh
Mar 22, 2005, 04:59 AM
Can't help you directly because I'm having the same problems with an Epson Photo Stylus 830u.

I can at least give you some hope in that until two days ago my setup with wireless printing on the Epson had worked just fine for six months - printing from both a PowerBook G4 from anywhere in the house as well as an Airport Extreme equipped iMac G4. Then the ink cartridges ran out (hardly the first time) and since then it has been a bust. I had to print some diagrams so finally resorted to a plugging the USB cable directly into the Powerbook. I can't help wondering if that changed some setting in a most subtle way.

Since then I've done hard and soft resets of the Airport Express (internet access has worked all through this), deleted and added the print queue, re-booted the machines, rebooted everything at once, upgraded to Express 6.1.1 firmware, and followed various Mac site suggestions. None of it has worked so I'll chase down Epson tommorrow although I've seen nothing on the Website that would really help. It would seem I have the latest drivers. Will let you know if I solve this.

tomh
Mar 23, 2005, 03:24 AM
Okay MacFan26. This took more headbutting than should have been needed but this appears to be a common problem that no one has a handle on (and we've got separate threads that need combining). However, this should work for any printer.

In Printer Setup Utility under the "Printer List" window, select the Add icon to get the list and then select "IP Printing" from the top half of the window rather than the normal "Rendezvous". When you do this you get a drop-down window with several fields.

From the top:
First field is "Printer Type" - that should show a small split screen with Rendezvous at the top and 3-4 options below such as "LPD/LPR". Select Rendezvous.

Second field is "Printer Address" and when you put the mouse on the up/down arrow button you should see the name of your printer in bold. Select it (you might also see something greyed out - for me this was "Socket/HP Jet Direct", but of course you can't select greyed out items).

Next field was "Queue Name" but this had nothing to select and remained inert when passed over by the mouse - so ignore.

Final field was "Model" - with the base option "Generic". However, when I went through the list I found a ton of printer drivers using the CUPS+Gimp-Print models rather than the manufacturers. So I picked my Epson model and that was that. Saw Lexmark there as well but not your model so you might need to download it - or you take a gamble and pick one Lexmark Z... They all seemed to use the same driver anyway - CUPS+Gimp-Printv4.2.5. I thought I'd have to download these from the subscription site that develops them (just Google) but perhaps OS X 10.3.8 had some built in.

Another thread I've seen here states that printers like Epson have not been built with networks in mind (??) and so their drivers may not work on Airport Express. Would explain my problems but NOT why it worked for the previous six months.

After this everything worked like a charm. Repeated the process on my Powerbook since I did not want to share a desktop-linked printer that might not be accessible when the desktop is asleep.

Good luck

MacFan26
Mar 23, 2005, 07:25 PM
That's awesome, looks like you went through a lot of trouble to figure that out, lol. I'm swamped with work this week, but I'll try this this weekend, thanks in advance :)