PDA

View Full Version : iTunes LOST HD episode - bad frame rate




McGiord
May 16, 2010, 07:47 PM
Hello I recently bought an episode of LOST and the frame rate was terrible.
I have a 40" Sony LCD TV, it is 60 Hz refresh rate but the video was really off like an old image still stutter for fast action scenes and also for non fast movement, also the audio was off with the video. Do you also had experienced this type of issue with iTunes HD content?



richprice79
May 17, 2010, 12:28 AM
Wirelessly posted (iPhone : Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1_3 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7E18 Safari/528.16)

This is unusual I watch lost through apple tv on a 1080p set and have not experienced this.

rikers_mailbox
May 17, 2010, 01:17 AM
Likely that it's your TV, probably doing some kind of image processing which could result in dropped frames.

My Samsung has an optional 120Hz motion-smoothing feature that ruins an otherwise clean HD signal. Turning it off (back to 60Hz) or turning on "Game Mode" on the TV fixes the problem.

HD video codecs are a mess.

alehel
May 17, 2010, 06:20 AM
I remember I had an issue with an episode of Night Stalker I purchased on iTMS. The audio went off half way through. I contacted Apple support and they granted me a new download. The new one had no problems. I know this isn't the same problem as you are having, but a new download might solve it as it did for me. Apple might have replaced the episode as a result of discovering this problem as well.

roidy
May 17, 2010, 10:17 AM
I remember I had an issue with an episode of Night Stalker I purchased on iTMS. The audio went off half way through. I contacted Apple support and they granted me a new download. The new one had no problems. I know this isn't the same problem as you are having, but a new download might solve it as it did for me. Apple might have replaced the episode as a result of discovering this problem as well.

I agree. I've had a couple of bad downloads from iTunes that have been solved by redownloading them. McGiord before you start ripping your system apart looking for the problem, contact Apple tell them the episode isn't playing right and they'll let you redownload it. Do you have this problem on any other files because if it was your TV I would expect to see it on multiple different files as well. Which episode is it anyway?