PDA

View Full Version : Keep iPad screen from going to sleep




thecause007
May 18, 2010, 10:11 AM
Any ideas on how to keep the iPad screen from going to sleep due to inactivity? I want to use it as a calendar on my desk, but it doesn't do much good if I can't see the screen after a few minutes.



sandyjmacdonald
May 18, 2010, 10:23 AM
Any ideas on how to keep the iPad screen from going to sleep due to inactivity? I want to use it as a calendar on my desk, but it doesn't do much good if I can't see the screen after a few minutes.

RTFM. But seriously, you can change it in the settings. It's the Auto-lock setting you want.

thecause007
May 18, 2010, 10:27 AM
Wow. Intuitive name.

So that gives me up to 15 minutes, and then I am SOL. What I'm looking for is to prevent it from going to sleep period.

melman101
May 18, 2010, 10:30 AM
Wow. Intuitive name.

So that gives me up to 15 minutes, and then I am SOL. What I'm looking for is to prevent it from going to sleep period.

Ok, well I am going to assume you have a Work Exchange account on there. I just read a post that says, your exchange server has the ability to not allow "NEVER" on the AutoLock settings for security reasons.

antiprotest
May 18, 2010, 10:30 AM
Wow. Intuitive name.

So that gives me up to 15 minutes, and then I am SOL. What I'm looking for is to prevent it from going to sleep period.

You don't see the "Never" option?

elfxmilhouse
May 18, 2010, 10:31 AM
Wow. Intuitive name.

So that gives me up to 15 minutes, and then I am SOL. What I'm looking for is to prevent it from going to sleep period.

You don't see the "Never" option?


do you have an exchange account configured?

sometimes the policy of the server doesnt allow never sleep mode on a mobile device.

thecause007
May 18, 2010, 10:38 AM
Nada on the "never" option for me. You had me worried that I was really losing my mind for a second.

Yep, I do have an exchange account configured, which is what I'm using for my calendar, contacts, and obviously email. Unfortunately we have our exchange server hosted by MS so there is probably a slim to none chance of getting that changed. Any way around this?

melman101
May 18, 2010, 10:40 AM
Nada on the "never" option for me. You had me worried that I was really losing my mind for a second.

Yep, I do have an exchange account configured, which is what I'm using for my calendar, contacts, and obviously email. Unfortunately we have our exchange server hosted by MS so there is probably a slim to none chance of getting that changed. Any way around this?

Sadly, you'll need to talk to the Exchange Admin, or remove the exchange account.

kaelell
May 18, 2010, 10:41 AM
find an app which does your calender functions and has a no-lock option built in I guess?

sandyjmacdonald
May 18, 2010, 10:45 AM
Wow. Intuitive name.

So that gives me up to 15 minutes, and then I am SOL. What I'm looking for is to prevent it from going to sleep period.

Sorry if I sounded sarcastic. I was just joking around. ;)

Does this happen even when you're watching movies?

Maybe worth emailing Apple to make them aware of the issue? If enough people do, then they might offer a workaround.

thecause007
May 18, 2010, 10:55 AM
Sadly, you'll need to talk to the Exchange Admin, or remove the exchange account.

Getting anything out of our IT dept. is like trying to convince your wife that she looks fine in that dress. Guess I'll have to figure something else out. It's kind of a catch-22, since if I disable the exchange account I lose the calendar that I want to be able to see. Maybe I can sync my exchange calendar with another iCal calendar?

For me, having the iPad act as an always on desk calendar that keeps up with my exchange calendar seems like a killer use case.

thecause007
May 18, 2010, 11:12 AM
Sorry if I sounded sarcastic. I was just joking around. ;)

Does this happen even when you're watching movies?

Maybe worth emailing Apple to make them aware of the issue? If enough people do, then they might offer a workaround.

Luckily movies work fine, although it does time out while listening to music, which is kind of annoying. Usually the screen times out right before I want to skip a track.

I can see the logic behind having the setting, so I doubt Apple would do anything about it. It really boils down to allowing the exchange admin have control over the devices, so the sheeple don't get into trouble on their own. I was a little surprised to see the heavy hand extended to the iPad though, since it seems like more of a consumer device and less business-like than the iPhone.

WilliamG
May 18, 2010, 11:27 AM
Nada on the "never" option for me. You had me worried that I was really losing my mind for a second.

Yep, I do have an exchange account configured, which is what I'm using for my calendar, contacts, and obviously email. Unfortunately we have our exchange server hosted by MS so there is probably a slim to none chance of getting that changed. Any way around this?


You are losing your mind. There is a "never" option in there.

sassenach74
May 18, 2010, 11:32 AM
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1_3 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7E18 Safari/528.16)

Nada on the "never" option for me. You had me worried that I was really losing my mind for a second.

Yep, I do have an exchange account configured, which is what I'm using for my calendar, contacts, and obviously email. Unfortunately we have our exchange server hosted by MS so there is probably a slim to none chance of getting that changed. Any way around this?


You are losing your mind. There is a "never" option in there.

Or you didn't bother reading the thread.

chuckduquette
Sep 26, 2010, 10:07 PM
What you're looking for is property idleTimerDisabled of the UIApplication object. To disable the idle timer,

[[UIApplication sharedApplication] setIdleTimerDisabled:YES];

See the UIApplication class reference for more details.