PDA

View Full Version : Powerbook G4 video playback very slow!




cliffcuts
May 19, 2010, 12:43 PM
Can anyone suggest the reason why my powerbook G4 can't playback video smoothly??



noodlemanc
May 19, 2010, 01:32 PM
Can anyone suggest the reason why my powerbook G4 can't playback video smoothly??

What sort of video? Is it online streaming video or offline video being played via Quicktime or iTunes?

mrsir2009
May 19, 2010, 01:42 PM
Is it flash online video?

iThinkergoiMac
May 19, 2010, 05:01 PM
What's the resolution of the video? What are the specs on your PBG4 (proc speed, RAM, and video card)?

Anything above 480p is going to have a tendency to stutter (1080p isn't going to happen generally, with very few exceptions). If it's H.264, that's not going to be pretty either.

If you use NicePlayer and your video card supports hardware-accelerated CoreImage/Video, you can use it to accelerate video playback, resulting in smoother video.

cliffcuts
Jul 8, 2010, 05:46 AM
Hardware Overview:

Armed with this information can anyone venture to guess why I can't playback video of any kind. Can't playback quicktime or streaming. Is there a way to clean out your computer or find out what's slowing it down?


Model Name: PowerBook G4 15"
Model Identifier: PowerBook5,6
Processor Name: PowerPC G4 (1.2)
Processor Speed: 1.67 GHz
Number Of CPUs: 1
L2 Cache (per CPU): 512 KB
Memory: 2 GB
Bus Speed: 167 MHz
Boot ROM Version: 4.9.1f3
Serial Number (system): xxxxxxxxxxxx
Hardware UUID: 00000000-0000-1000-8000-001124417492
Sudden Motion Sensor:
State: Enabled
Version: 1.0

cliffcuts
Jul 8, 2010, 05:50 AM
ATI Mobility Radeon 9700:

Chipset Model: ATY,RV360M11
Type: Display
Bus: AGP
VRAM (Total): 64 MB
Vendor: ATI (0x1002)
Device ID: 0x4e50
Revision ID: 0x0000
ROM Revision: 113-xxxxx-160
Displays:
Color LCD:
Resolution: 1280 x 854
Depth: 32-Bit Color
Core Image: Hardware Accelerated
Main Display: Yes
Mirror: Off
Online: Yes
Quartz Extreme: Supported
Built-In: Yes
Display Connector:
Status: No Display Connected

spinnerlys
Jul 8, 2010, 05:50 AM
What kind of video are you talking about? Is it HD or SD, which format has it (.mp4, .mov, .avi, .mkv) and what codec does it use (CMD+I while in QT)?
Do you have examples or links?

Have a look at Activity Monitor (Applications > Utilities) and select All Processes and sort by CPU to see what the culprit may be while playing the video.

image below uses sorting by CPU as an example
http://farm5.static.flickr.com/4141/4745264042_9c23afdbc9_b.jpg


No need to double post, you can edit your posts via the http://forums.macrumors.com/images/buttons/edit.gif button on the bottom right of your posts.

http://forums.macrumors.com/images/buttons/edit.gifhttp://forums.macrumors.com/images/buttons/quote.gifhttp://forums.macrumors.com/images/buttons/multiquote_off.gif

cliffcuts
Jul 14, 2010, 12:08 AM
thanks. it's still slow but it's a little better now.:)

CTrav86
Jul 14, 2010, 05:00 PM
The only video I really have problems with (other than HD of course) is online streaming video (Flash). The only way I can get moderately smooth playback with Flash is to set the video resolution really low, like 288p. Yeah, it doesn't look good at all, but at least it's somewhat watchable. I've never had problems with watching DVD's or .avi, .mkv... etc. Just streaming. If you haven't, try watching video in VLC, it seems to work well for me on my PB.

piercedsphynx
Aug 7, 2010, 01:18 AM
I had the EXACT same problem with my PowerBook G4... Everything else on the computer worked flawlessly except for streaming flash videos. I have the 12" model. 1.5 Ghz, 1.25 GB RAM.... People will tell you its the CPU and that the G4 is obsolete, it's the drivers, it's your internet connection, etc etc It's NONE of these. In my case, YES, the CPU usage goes up to almost 100%, but there is a reason for that! The wonderful folks at nVidia and their failure to properly support Flash playback on the nVidia Go 5200. The video hardware does not properly process the video so the CPU tries to compensate, resulting in slow playback and high CPU usage. If you hold down CTRL and click the video, go to "Settings", UNCHECK "enable hardware acceleration", you should notice a DRAMATIC improvement, whereas before the videos were unwatchable, and now they should play relatively smoothly, even in full screen! Hope this works for you as it did for me!

raysfan81
Aug 8, 2010, 11:51 AM
What browser are you using? I notice much better video performance on my G4 when I'm using Camino or Opera.

iThinkergoiMac
Aug 9, 2010, 11:03 AM
Nice tip on unchecking hardware acceleration. Works on my PowerBook as well, which has an ATI card, not Nvidia.