PDA

View Full Version : G4 MMD White Screen




Retrosonic
Jun 1, 2010, 02:28 PM
Guys...hopefully someone can help me.

I just acquired a G4 MDD Power Mac. Dual 1 Ghz processors.

I pulled the HD out of my older g4, connected it, and powered the machine up. The HD has OSX 10.5 and works fine in the older G4.

The first thing I notice is that the Small fan (in the door) is spinning, but the Large fan under the Power Supply is NOT.
The red light on the Motherboard is on.

What happens is that all I get is a white screen, with the Apple Logo, and the spinning circle. it never acceses the hard drive and boots into 10.5

What does this point to? I hope the Dual processors are not the problem here. But that large fan not spinning worries me.

Any help is appreciated!
thanks,
Retro



AlexMaximus
Jun 1, 2010, 03:00 PM
I am used to the G4 MDD and it's little perks over the years. However, I never had the problem that the case fan would not fire up when booting. The case fan is the big one in front of the heat sink (120mm x 38, usually Delta fan)
If the case fan does not start spinning during booting, it's most likely damaged or wear out. Since the system runs usually a kind of fan check, it may not boot correctly because of the failed fan to protect itself for overheating.

The best exchange fan for the 120 is a silentX model with 18db noise level.

good luck

Retrosonic
Jun 1, 2010, 04:22 PM
Thanks for the reply Alex. You may be right. Maybe I'll get a cheap replacement, put it in a see what happens, I'd have to have a working fan in there regardless.



Anyone else have any thoughts on what to do to troubleshoot this problem?

thanks,
Retro

666sheep
Jun 2, 2010, 01:21 AM
Regardless of fan malfunction, zap PRAM and it should boot. Check carefully fan's plug and cables. There is no fan check in MDD AFAIK. OFC this big fan is needed to not overheat CPU, but you can run machine without it just for few minutes (not longer), to check if it will boot into OS.