PDA

View Full Version : How are you suppose to NAT with snow leopard server mini with only 1 ethernet port?




yalag
Jun 8, 2010, 03:15 PM
How are you suppose to NAT with snow leopard server mini with only 1 ethernet port?



belvdr
Jun 8, 2010, 03:19 PM
Subinterfaces are the way to do this, although not a very secure method to do so.

yalag
Jun 8, 2010, 03:23 PM
Subinterfaces are the way to do this, although not a very secure method to do so.

Do you have any info on subinterfaces? Also, why is this so hard? Apple built this server themselves, did they mess up?

belvdr
Jun 8, 2010, 03:24 PM
It's more or less aimed for folks not requiring their Mac to route.

Creating subinterfaces is nothing more than assigning more than one IP to a particular interface. Google "router on a stick" and you'll find more info.

AlanShutko
Jun 8, 2010, 03:33 PM
You could also pick up a USB ethernet adapter.

Consultant
Jun 8, 2010, 04:06 PM
You could also pick up a USB ethernet adapter.

Yeah Apple makes one "for MacBook Air," but works on recent Macs.

Serif
Jun 9, 2010, 05:22 AM
The USB ethernet adapter is a nice piece of kit and I've used it as the Internet facing interface on a Mac Mini server with success.

If you wish to use the built in ethernet for both the internal LAN and your Internet connection then sub interfaces are the way to go, preferably using a VLAN capable switch.

fredfnord
Jun 9, 2010, 12:10 PM
I'm using one of these at home with Server and a mini. Works just fine. Only issue is that occasionally, when I do a software update that requires a reboot, sometimes I have trouble getting it to start using the USB ethernet port. It looks like it's working (lights blink once a second when I ping, etc), but for some reason it just doesn't recognize any incoming packets.

Every time this has happened, I've screwed around with the settings some (changed them, changed back), and rebooted, and it's started working again. And since I don't have to update very often, this is not a big issue.

-fred