PDA

View Full Version : Slooow Steam download




I'mAMac
Jun 13, 2010, 07:46 PM
I'm currently downloading TF2 on my mac and its interminable. I'm getting 150 Mbit/s which is just awful. When I download on win7 i'm usually getting 1 MB/s and sometimes higher. Is there something I can do to speed this up or is it just a common problem on macs for now?



TheShinyMac
Jun 13, 2010, 07:53 PM
Im taking some screen shots on how to help hold on!

TRUCRACKER
Jun 13, 2010, 07:53 PM
I'm currently downloading TF2 on my mac and its interminable. I'm getting 150 Mbit/s which is just awful. When I download on win7 i'm usually getting 1 MB/s and sometimes higher. Is there something I can do to speed this up or is it just a common problem on macs for now?

In the past few days there have been DOZENS of threads about this.

I'mAMac
Jun 13, 2010, 07:54 PM
In the past few days there have been DOZENS of threads about this.

Oh that was the problem now it works. Thank you.

TheShinyMac
Jun 13, 2010, 07:56 PM
GO to preferences and change your settings accordingly

TRUCRACKER
Jun 13, 2010, 07:57 PM
Oh that was the problem now it works. Thank you.

Yeah it's called "searching". You should try it!

I'mAMac
Jun 13, 2010, 08:05 PM
Yeah it's called "searching". You should try it!

First of all, you have to learn how to count because I DID use the search before posting and the alleged dozens of posts regarding this problem were not to be found. The problem with the couple of posts I did find is that they did not help. I copied the files and changed my download settings before making this post again and nothing worked. If that is too hard to understand then just don't say anything. Click the back button, it's even easier than using search.

TheShinyMac: Those are my current settings and I even changed to a different country because I heard the US servers were slow. Didn't make a difference though :(

TRUCRACKER
Jun 13, 2010, 08:09 PM
First of all, you have to learn how to count because I DID use the search before posting and the alleged dozens of posts regarding this problem were not to be found. The problem with the couple of posts I did find is that they did not help. I copied the files and changed my download settings before making this post again and nothing worked. If that is too hard to understand then just don't say anything. Click the back button, it's even easier than using search.

TheShinyMac: Those are my current settings and I even changed to a different country because I heard the US servers were slow. Didn't make a difference though :(

Yes it is kind of hard to understand that none of those threads had any info that could help. Really, there were so many that if none helped, you should just wait it out.

I'mAMac
Jun 13, 2010, 08:17 PM
Yes it is kind of hard to understand that none of those threads had any info that could help. Really, there were so many that if none helped, you should just wait it out.

Logical...if no previous information helped why bother trying to find a solution that works? I'm glad society doesn't abide by this train of thought.

If there were this abundance of threads about the same thing then you should have some answers. Or be able to direct me to one that addresses my problem exactly.

TRUCRACKER
Jun 13, 2010, 08:23 PM
Logical...if no previous information helped why bother trying to find a solution that works? I'm glad society doesn't abide by this train of thought.

If there were this abundance of threads about the same thing then you should have some answers. Or be able to direct me to one that addresses my problem exactly.

Maybe there isn't a solution if no one found one. Maybe the servers are very busy since TF2 is so popular. Who knows?