PDA

View Full Version : Safari 5 not playing nice with PPC.




applesupergeek
Jun 14, 2010, 04:48 PM
It might just be an issue with a corrupt update but safari won't load any web pages for me on my pbook 12". And lately I 've been reading around other mac sites, that it's causing all sorts of issues for ppc macs, to the extent that people switch to (as I have) to firefox in the interim. And that would be a damn shame if we are stuck with safari 4 on the ppc for sure...

Experiences?



MacHamster68
Jun 14, 2010, 05:05 PM
as i run several operating systems on my Mac mini G4 1.42 (leopard,tiger,panther,debian ,ubuntu , soon morph os too)
i have installed safari Version 5.0 (5533.16) under leopard and i have so far no issues whatsoever with it , works perfectly well, opens all websites , plays html5 beta , cant complain about anything

applesupergeek
Jun 14, 2010, 05:35 PM
as i run several operating systems on my Mac mini G4 1.42 (leopard,tiger,panther,debian ,ubuntu , soon morph os too)
i have installed safari Version 5.0 (5533.16) under leopard and i have so far no issues whatsoever with it , works perfectly well, opens all websites , plays html5 beta , cant complain about anything

thanks for the heads up mate, maybe something in my install is corrupt like I said, I 'll try reinstalling asap. Here is another negative opinion from a roughly drafted user, just for reference:

In contrast, I had to revert to Firefox (latest) on the PPC machine (because Safari5 refuses to start) and it is much slower than Safari 4 was (and despite a few neat features is a real clunker to work with and look at!).
http://www.roughlydrafted.com/2010/06/08/apples-ios-wwdc-strikes-back-after-googles-android-io/#more-4339

Hrududu
Jun 14, 2010, 05:58 PM
I would think it was probably a bad install. I haven't had any problems with it on any of my PPC systems.

drewdle
Jun 14, 2010, 07:16 PM
Another suggestion: clear out the Safari folders in both your home Library folder and the system Library folder. Thus any settings carried over from Safari 4 that may be causing issues can be gotten rid of. Before doing this, however, backup your Bookmarks.plist and History.plist from the Safari folder inside you Home folder (so, say, copy them to the Desktop) so you don't lose that information.

I haven't had any issues with Safari 5 on my systems. Made things faster on the iMac, actually.

applesupergeek
Jun 15, 2010, 08:11 AM
Another suggestion: clear out the Safari folders in both your home Library folder and the system Library folder. Thus any settings carried over from Safari 4 that may be causing issues can be gotten rid of. Before doing this, however, backup your Bookmarks.plist and History.plist from the Safari folder inside you Home folder (so, say, copy them to the Desktop) so you don't lose that information.

I haven't had any issues with Safari 5 on my systems. Made things faster on the iMac, actually.

That's a great suggestion, thanks.

zen.state
Jun 15, 2010, 08:17 AM
I know the best way to fix Safari.. use Camino. :)

MacHamster68
Jun 16, 2010, 06:04 AM
I know the best way to fix Safari.. use Camino. :)

camino is good, i love it , but no html5 video support in camino , at least i cant watch any with camino:( , despite flashplayer runs a tiny bit better if you use camino ;)

marc.richards7
Jun 16, 2010, 09:16 AM
Well, I'm new here, but not new to Macs. I have a 17" PowerBook as you can tell in my sig. I had issues with Safari 5 when I downloaded it from Apple's website. I uninstalled it and done a little reminiscence. I remembered when Safari 4 came out, and I installed from Apple's website, it wouldn't load the pages. I uninstalled it, restarted, and then used the Software Update utility. Afterwards, it was better, but I still had issues. After booting from the OS Install DVD, and repairing the permissions, it was all good again. Hope I helped. Peace.

zmttoxics
Jun 16, 2010, 09:42 AM
You can always try a nightly build of WebKit (the real Safari beta).

http://nightly.webkit.org/

applesupergeek
Jun 16, 2010, 06:43 PM
I might have to do that.... it just won't load any webpages on my ppc mac no matter what I do, or how I install it...:(

zen.state
Jun 17, 2010, 12:31 AM
Just upgraded to 5 and it works great for me. Seems faster than ever.

FourCandles
Jun 17, 2010, 02:36 AM
I have an old iBook G4 (so similar architecture to the powerbooks) running Leopard and Safari 5...no problems here. Can't say it's any faster than 4 though, and the Reader is a little sluggish.

MacHamster68
Jun 17, 2010, 06:44 AM
seems to be a mystery thing with safari 5 , some like me have no problems whatsoever with it and others cant even load webpages or are not even able start it at all :confused:

Plymouthbreezer
Jun 17, 2010, 08:42 AM
Running fine here on my G5 (10.5) and G4 (10.4.11) iMacs... It did crash twice, initially, on my MacBook Pro, which I thought was odd.

However, after a few restarts and permission repairs, it seems to be functioning okay.

applesupergeek
Jun 17, 2010, 02:07 PM
seems to be a mystery thing with safari 5 , some like me have no problems whatsoever with it and others cant even load webpages or are not even able start it at all :confused:

Yes it is very strange indeed, still no luck here, despite permissions repair, and checking the usual suspects... what's even funnier (in an ironic, frustrating way, lol) is that the safari 5 leopard .dmg won't even mount anymore...

applesupergeek
Jun 26, 2010, 03:29 PM
No matter what I 've done safari 5.0 won't load any pages, nada, the blue bar (which btw is very distracting) just gets stuck at 1/5 and nothing loads. I 've reinstalled it countless times....

And I 've tried everything except re-installing os x. Which of course I am not prepared to do for obvious reasons. I now had to get pacifist to reinstall safari 4.05. It's just so strange that 5.0 won't work while every other browser I have, the boring ff and the great opera work seamlessly.

bizzle
Jun 26, 2010, 05:34 PM
No matter what I 've done safari 5.0 won't load any pages, nada, the blue bar (which btw is very distracting) just gets stuck at 1/5 and nothing loads. I 've reinstalled it countless times....

And I 've tried everything except re-installing os x. Which of course I am not prepared to do for obvious reasons. I now had to get pacifist to reinstall safari 4.05. It's just so strange that 5.0 won't work while every other browser I have, the boring ff and the great opera work seamlessly.
Export your bookmarks (File > Export Bookmarks) and then delete the following;

/Users/YOURUSERNAME/Library/Safari
/Users/YOURUSERNAME/Library/Preferences/com.apple.Safari.plist
/Users/YOURUSERNAME/Library/Preferences/com.apple.Safari.RSS.plist

This will remove all Safari preferences and should resolve your issue. Also make sure you have no nonsense in your InputMethods folder.

/Library/Input Methods/

If you have something in there called CT_Loader, remove it, and restart.

Also, in Safari, go to Preferences > Advanced and uncheck "Warn when visiting a fraudulent website". If the Google database that runs that option, or you have something in a firewall or your network connection blocking it, you'll have similar issues.

Once all of that is done, import your bookmarks.

applesupergeek
Jun 26, 2010, 06:07 PM
Thanks for the help buddy, and for taking the time to write this, I 've done most of what you suggest already, except for the input methods. But my input methods folder is empty.

I also tried turning off the firewall, exempting safari from it, etc. etc.

I have not tried un-checking the fraudulent sites, but I will do so, in the future when I gather up the courage to re-install 5.0, because at the moment I am so relieved that at least 4.05 runs.

I also wonder if this version of safari is at all optimised for ppc. I would really like to see some memory footprint, speed, etc. tests comparing the this and the previous version on ppc.