PDA

View Full Version : New G5-Old Firewire Card wont work


dlastmango
Nov 5, 2004, 10:25 PM
What kind of card do i need to look for. It isn just a PCI card isnt it? I think that is what the old one was. But the notches on the connectors were in the wrong position so it didnt fit.
I'd like to find a 3 Firewire and 2 USB 2.0 card.. any suggestions ...thanks


Chris

Sun Baked
Nov 5, 2004, 10:36 PM
What kind of card do i need to look for. It isn just a PCI card isnt it? I think that is what the old one was. But the notches on the connectors were in the wrong position so it didnt fit.
I'd like to find a 3 Firewire and 2 USB 2.0 card.. any suggestions ...thanks


ChrisThe PCI card was probably the ancient 5V Standard.

The G5, like the original G4 XServe switch to requiring 3.3V PCI cards.

www.barefeats.com

was playing around with some firewire/usb 2 PCI cards.

and

http://www.xlr8yourmac.com/G5/powermac_g5_docs_updates.html#storytop

has some issues regarding "other" issues relating to these cards.