PDA

View Full Version : Xcode needs restart to refresh changes




Brendo
Jul 10, 2010, 12:12 AM
Firstly here is what I have.

Xcode Version 3.2.3 (1628)
iMac OS X Version 10.6.4

Here is the problem.

1. I enter code into xcode.
2. Open Interface Builder from the xib file.
3. Add say...a button to the view.
4. Go to to connect the outlets for the button using the Files Owner, but they don't show up.
5. I then check I have saved all files in Interface Builder and Xcode and try again. Same problem.
6. I then shut down interface builder and reopen it. Still no outlets.
7. I shut down Interface builder, and Xcode and restart the project, and the outlets now work.

This process of make changes, shut everything down, and then open it all again is time consuming, and annoying, is their any way to have xcode and Interface builder sync and update when saving. I haven't been able to find how. Any help would be much appreciated. Cheers :confused:



PhoneyDeveloper
Jul 10, 2010, 12:48 AM
They normally stay in sync. In the bottom left corner of you xib window there is an LED image. It's supposed to be green, indicating that the file is in sync with a project. If it's yellow or grey there is a problem. If you move the mouse over the LED it may tell you something about the error.

If there are funny characters in the path to the project folder it can cause this problem.

kingthong
Oct 6, 2010, 06:59 AM
Hey i just started using Xcode and am facing the same problem. absolutely no clue why this happens!
and my filenames are fine too.

PhoneyDeveloper
Oct 6, 2010, 10:27 AM
What about the color of the led?

Try clearing the recent documents menu in Xcode.

Also, try opening the xib file by double-clicking in the Finder with the project open instead of opening it from the project window.

kingthong
Oct 7, 2010, 09:53 AM
What about the color of the led?

Try clearing the recent documents menu in Xcode.

Also, try opening the xib file by double-clicking in the Finder with the project open instead of opening it from the project window.


Hey i had a bunch of xcodeproj files open and in my 'recent projects' list. i removed them from where it was stored(documents\...) and now xcode seems to be working fine!