PDA

View Full Version : Popping Sound in Safari 5 when using Youtube, Hulu and Rhapsody




SLR2009
Jul 13, 2010, 02:59 PM
Hi, I have a Quad Core Mac Pro which is running Snow Leopard 10.6.4. I have 8 gigs of memory. I am using Safari 5 and the latest version of Flash Player.

This issue doesn't happen all the time but once it occurs it will keep happening until I quit Safari and then reopen it. After that it will begin happening again after a certain period of time.

It seems to occur when I have Safari open for extended periods of time and the memory pageouts increase. When I play music through the Rhapsody player, youtube or hulu and visit various sites at the same time, there's a popping or stuttering in the audio for a second or two.

The popping noise will occur when browsing a site while playing audio in Safari either through Youtube, Hulu or Rhapsody. The noise will occur when I click on a link to go to a website.

the Popping will occur when I quit Safari as well, it's sort of like a sound that shouldn't be there. It sounds almost like static electricity when you touch it.

The only thing that stops the popping is by Quitting Safari and reopening it. After that I won't hear the noise while browsing sites for a period of time. It will come back eventually though.

I have uninstalled and reinstalled the Flash player, repaired permissions in disk utility, rebuilt my drive with Disk Warrior, reinstalled Safari, and installed the 10.6.4 Combo update but the issue remains.

Please help



MacKeeperFanMod
Jul 13, 2010, 06:11 PM
What version of Flash Player you have. If you put the latest beta, then put last Stable version.
If not help, try a different browser and tell the results.

SLR2009
Jul 13, 2010, 07:29 PM
I appreciate the help. I am using Flash Player Version 10.1. Although I mostly use Safari, I have not noticed the popping noise when using Firefox. I reinstalled Flash player again, first by uninstalling it and then restarting my Mac.

As an update I was playing music through Rhapsody in Firefox and I heard the popping noise. So it's occurring in Firefox as well.

SLR2009
Jul 18, 2010, 04:02 PM
Please help, This issue is very frustrating. do you guys think that I should perform an archive and install?

eddified
Oct 13, 2010, 12:36 PM
I have this exact same problem, but with Firefox. I'm not sure if it would happen with safari too.

This is an extremely annoying problem. I'm wondering if it's caused by sleep, not sure. I'm going to try disabling Flash and see if that seems to fix things. I don't know if it's flash that is the problem but I suppose if it's common to firefox and safari, Flash is a suspect. I'll post my findings back here.
I'm on snow leopard 10.6.4, brand new macbook pro 15".

Oh, did I mention that the popping sound happens at the start of EVERY sound coming out of the computer? So if I have a Terminal open and I try to backspace past the beginning of the command prompt, I hear a default beep, but even that default beep will have the static sound at the start of it. If i have music playing through the speakers, then any default beeps that happen during the music won't have the problem, but once the music stops, beeps after that will have the static sound at the start of it. Once I close firefox and reopen it, the static sound problem will go away for a while (a few hours maybe), but only to come back later.

If you don't know what I mean by "default beep", I think system prefs call it the "alert" sound or something like that.

eddified
Oct 13, 2010, 12:41 PM
OK, the problem just happened again now, and instead of restarting firefox, I disabled flash from within firefox's plugins page and the problem went away.