PDA

View Full Version : Snow Lepoard, Tiger and Xserve Permissions




JuggoPop
Jul 26, 2010, 04:41 PM
Hello,

I have searched Google and this forum for the answer I am looking for, however I am not sure I am using the correct terms to find my answer(s). I thought maybe I could get some help here.

At the company I work for, we use an Xserve for storing our client/project data. We do this in a way that all of our employees have access to what they need, but not everything on the server.

For example, we have user groups and users in those groups. Each staff member is defined by a group that allows them to see only what has been approved. Admin, can see everything while a graphic artist can see basic folders and graphics folder, but not admin folders or programming folders, etc.

Most of this was setup in a way that when files are added or folders are created, the permissions are auto set based on the level of who they are and where the folder resides.

All of our machines have been Macs with Tiger and various windows machines as needed. Recently we upgraded two of the stations to Snow Leopard.

Now that the update is complete, we see that the permissions information in the "get info" is different. I for example, used to create a new folder on the server, then drag a document from my desktop to the new folder.

Once that was complete I would need to (sometimes) view the "get info" and change the owner from my USERNAME to ADMIN. In doing this it would gray out and but would be in the correct group and everything was fine.

If I didn't check this and the admin came along and tried to move folders and files, they would run into issues because I would still be the owner as my USERNAME. And if they were moving 20 gigs of info, tracking down the single file that is assigned to me caused a major time issues.

So after the upgrade to Snow Leopard, I can have a decent amount of access on my machine (my username shows up etc), but on the Xserve any folders I create are assigned properly (no issues there), but the files that get dropped in show via a Tiger machine that the owner is still me. The admin is on an older machine that cannot be upgraded.

When I view the "get info" on the Snow Leopard machine I get a different GUI of that section that says "Everyone" and "No Access". I'm not even listed in there and I can't pick Admin or type it in as I did before.

Can someone tell me how I go about either viewing the "get info" permissions section as I used to in Tiger... or explain how I would adjust the access to get the same settings as before with this new interface.

I am lost and the server admin doesn't want to deal with this issue. He can fix it by moving it to his desktop and then back and everything gets corrected, but that is not a solution.

Thank you for your time and I apologize for being long winded in my first post here.



JuggoPop
Jul 28, 2010, 04:30 PM
If no one knows, can someone point me to another forum where I might also post this question?

Or suggest some terms I might search for in Google...
I have looked around, but don't know if I am even using the correct terms needed to find my answer(s).

VideoFreek
Jul 29, 2010, 05:48 PM
If no one knows, can someone point me to another forum where I might also post this question? I'd give the Apple support forum for OS X Server (http://discussions.apple.com/forum.jspa?forumID=1348) a try. There are guys active over there who appear to be permissions gods, and they may be able to help.

JuggoPop
Jul 30, 2010, 06:53 AM
Thanks!