PDA

View Full Version : Combo Drive in Dual 867 G4 is misbehaving


Dunepilot
Nov 22, 2004, 05:10 AM
Hi everyone,

While watching a DVD in bed the other night, I just shut down my Mac as I felt myself falling asleep. So all apps quit, then the machine (running 10.3.6) went into the shutdown process. I fell asleep immediately, then woke up about 2 hours later to hear the fan still running with a black screen. I performed a hard reset, and went back to sleep.

Waking up on Sunday, I started up my machine again, and ran fsck -f in single user boot. It fixed a couple of minor problems (probably created by the slightly wierd shutdown), but after booting fully into the OS, I found out that the optical combo drive (a Philips CDD5101) won't accept any media any more. If you insert a DVD it spits it back out a few seconds later. Same thing with CDs of any description. You can hear that the drive isn't even trying to spin up the disc.

What has happened? Has the firmware got corrupted or something? How do I reinstall it, if so, and where can I get the firmware for this drive from (the Philips site doesn't help me there). I've tried booting this machine from OS 9.2.2, OS 10.2.6 and OS 10.3.6 (from different hard disks), and that doesn't rectify the problem, so I'm pretty sure this isn't to do with the OS getting damaged.

If somebody could help me out here, that'd be great.
Cheers
Dune

wrldwzrd89
Nov 22, 2004, 06:03 AM
Hi everyone,

While watching a DVD in bed the other night, I just shut down my Mac as I felt myself falling asleep. So all apps quit, then the machine (running 10.3.6) went into the shutdown process. I fell asleep immediately, then woke up about 2 hours later to hear the fan still running with a black screen. I performed a hard reset, and went back to sleep.

Waking up on Sunday, I started up my machine again, and ran fsck -f in single user boot. It fixed a couple of minor problems (probably created by the slightly wierd shutdown), but after booting fully into the OS, I found out that the optical combo drive (a Philips CDD5101) won't accept any media any more. If you insert a DVD it spits it back out a few seconds later. Same thing with CDs of any description. You can hear that the drive isn't even trying to spin up the disc.

What has happened? Has the firmware got corrupted or something? How do I reinstall it, if so, and where can I get the firmware for this drive from (the Philips site doesn't help me there). I've tried booting this machine from OS 9.2.2, OS 10.2.6 and OS 10.3.6 (from different hard disks), and that doesn't rectify the problem, so I'm pretty sure this isn't to do with the OS getting damaged.

If somebody could help me out here, that'd be great.
Cheers
Dune
I just did a google search, and there appears to be no firmware updates for Macs using that particular drive. My thinking is that it's quite possible that the odd shutdown somehow zapped the CD drive electronics. I really don't know for sure though.

Dunepilot
Nov 22, 2004, 07:13 AM
I just did a google search, and there appears to be no firmware updates for Macs using that particular drive. My thinking is that it's quite possible that the odd shutdown somehow zapped the CD drive electronics. I really don't know for sure though.

Is that really all that likely? I've never heard of such a thing happening before!

Also, if I'm going to have to replace this drive, is a Pioneer DVR-108 a good way to go?

Cheers
Dune

wrldwzrd89
Nov 22, 2004, 10:59 AM
Is that really all that likely? I've never heard of such a thing happening before!

Also, if I'm going to have to replace this drive, is a Pioneer DVR-108 a good way to go?

Cheers
Dune
Neither have I. I HIGHLY recommend Pioneer drives - either the DVR-108 or the DVR-A08 would be your best choice.

Dunepilot
Nov 25, 2004, 09:27 AM
Neither have I. I HIGHLY recommend Pioneer drives - either the DVR-108 or the DVR-A08 would be your best choice.

Will be getting a DVR-108 as soon as the ebay seller puts it my way
:D

caveman_uk
Nov 25, 2004, 10:09 AM
I'm not sure the DVR-108 is supported natively by the iApps - though obviously it's supported by toast. I have the DVR-107D and that is definately supported by the iApps without further tweaking. If you need a hack to get the 108 supported then Patchburn is the way to go.

Mechcozmo
Nov 25, 2004, 01:14 PM
Next time, though, quit all your applications and THEN shut the computer down. That's my only real idea... maybe zapping the PRAM would work?

Dunepilot
Dec 3, 2004, 05:30 AM
Okay, so the new Superdrive works very nicely now that I've installed patchburn and I've even put together my first ever DVD using my Powermac and iDVD. No installation, nothing.

But here's the kicker - my mate tried installing the dodgy combo drive in his Celeron (yuuurgh!) machine, running Windows 2K, and it works perfectly!

Zapping the pram sounds like a good idea - I'll try that if/when I get the drive back. It's command-p-r isn't it?

Cheers
Dune

5300cs
Dec 3, 2004, 09:09 AM
Zapping PRAM (http://docs.info.apple.com/article.html?artnum=2238) ;)

Sorry, aren't you pissed that the old drive died like that? If it were me, I'd be really pissed :mad: