PDA

View Full Version : Yikes G4 With 10.3 Stalling at Startup -- common problem?


Makosuke
Nov 22, 2004, 03:53 PM
I take care of an office network that is at this point about one-third 400MHz PCI Graphics G4s (yes, the good Yikes! models from before the speed-hit)--five of them with various HD and RAM configs.

They were up until last week running a mix of 10.2, 10.3, and OS9. I've now upgraded all of them to 10.3.5 or 10.3.6, but on three of them I'm seeing a weird issue where, when starting up, the computer will frequently stall dead before doing anything other than powering up and spinning up the hard drive.

The monitor goes dead (as in no signal, so it goes to sleep, not just grey or black) after turning on for part of a second, the hard drive and fans stay on, but there is no disk activity to indicate that boot is proceeding, and it will only respond to a hard restart.

I haven't experimented extensively, but once this happens the only way to bring it back seems to be to zap the PRAM (fully, the full three chimes), at which point the monitor immediately kicks in and it boots properly. It definitely doesn't do this on all of them, it's definitely not due to any particular version of 10.3, and it would seem that at least some of the time it starts working properly for a while after repeating the restart-pram zap procedure about three times and/or doing an Open Firmware reset-all.

Is this an odd symptom of a dying motherboard battery (though the voltage on it looks ok, and they keep time), some other boneheaded thing that I'm not thinking of, or is this a known problem with this model? Google was unhelpful.

For reference, these are totally fresh re-format, re-install with factory 10.3.5 discs, no tweaks, all SW updates, manually-applied 10.3.6 from combo updater, so they're as clean as you can get.

(Incidentally, they definitely worked fine under 9.x and 10.2, though there seemed to be a delay with a flashing question mark folder on restart before they found the startup drive before. )

rickvanr
Nov 22, 2004, 04:07 PM
my b&w would do that if i booted into 9 and then back to 10.3, are they doing that by chance?

Makosuke
Nov 22, 2004, 04:18 PM
Well, the first reboot was of course from 9 to 10.3, but not the subsequent ones, so that's not the only reason in any case.

It's also, of course, somewhat intermittent--after a few zaps and restarts and a reset-all it seems ok for as long as I care to test it, then it'll pop back up again.

Thanks for the suggestion, though.

Sun Baked
Nov 22, 2004, 04:51 PM
You might want to change the Monitor Settings, the cards can run faster that originally called for -- but it may mean the machine won't boot.

So I'd say check the resolution, and most likely -- turn down the scan rate (it's probably giving an error during the system check sequence.)

The fact that it's booting after zapping the PRAM (which resets the monitor to 640x480 @ 60Hz) means it could be the resolution/scan rate settings.

Just pull up a copy of the video cards original specs, and the specs for the monitor and play matchmaker -- until you find a decent setting.

---

If you are using one of the widgets to drive the monitors at an odd resolution/scan rate this could be it.

NOTE: I'm assuming a CRT.

slooksterPSV
Nov 22, 2004, 05:37 PM
They stall you say? Here is what I'd try: yes Zap the PRAM but using like TechTools or another PRAM zapping program (sometimes just a hard zap doesn't clear everything), repairing permissions, checking the disk for errors by booting up with the OS X install disc... Other than that, I can't think of anything else to try... Would resetting the PMU help??? I dunno... run fsck, you can hold a key to boot in verbose mode......... Thats all I can say.

Makosuke
Nov 23, 2004, 04:31 PM
Thank you both Sun Baked and slooksterPSV for the suggestions.

slooksterPSV: All good suggestions, but I've already done the standard disk checks (both Apple and the Applecare version of TechToolPro), zapped the PRAM (though I haven't tried a 3rd party tool to do it), and did the "reset-nvram" and "reset-all" via Open Firmware (as well as the CUDA button on the motherboard), none of which appear to be consistent fixes.

Sun Baked: What you describe fits the problem, and this was the first thing I looked at. However, I'm using "recommended" monitor settings via the standard Apple control panel, and the resolution is well within the original specs for the Rage 128, so that seems unlikely. Besides, they seem to work some of the time with no changes, so that doesn't quite make sense.

Well, I've got a new motherboard battery, so I'm going to try that next and see if it helps.

If there are any other suggestions, though, I'd love to hear them.

Makosuke
Nov 24, 2004, 10:20 PM
Well, after a great deal of experimentation, I've identified what the problem is, although I have no idea why it's doing this.

The issue, as Sun Baked suggested, is with certain resolution/scanrate combinations.

If the stored settings put the monitor in 800X600, or 1024X768 (at least at 75Hz & 85Hz), or 1280X960 @ 75Hz, it'll start up just fine.

If, however, the monitor is set at 1152x864, the computer will stall on a black screen as soon as powered up. At 1280X960 @ 85Hz, you can see why--the apple appears in a very low resolution, then the system panics as soon as the spinner would appear, which is presumably what's happening at other resolutions without the visual indicator. These panics aren't logged, apparently, since it's so early in the boot process.

Zapping the PRAM will reset the boot resolution to something acceptable, allowing it to get past the inital problem area and boot normally, even after it switches to the "bad" resolution once the screen goes blue.

This is totally repeatable, though I have no idea what's causing it. I do emphasize that I'm running a completely clean OS install, 10.3.6 recognizes the specific model of the monitor, and these resolutions are not only available in the Monitors preference panel, but they work just fine if I select them after boot. It's only when it tries to boot into them that it dies.

(Also, in my more thorough troubleshooting, I tried basically everything: repeated PRAM zaps and OF resets, new battery, pulled the battery, bled down the capacitors, held the CUDA button for a while, and left it unplugged for several minutes to be sure. None of the above make any difference under 10.3.5 or .6)

Anybody with a Yikes! G4 care to try this and see if it's universal?

Sun Baked
Nov 24, 2004, 10:53 PM
Problem with the new ATI drivers?

I thought I saw mention of an update for the older video cards on the new OS updates, the new drivers may have a problem with certain resolution/scan rate combinations -- since it's happening on a third of the machines.

---

Otherwise this can happen with resolution/scan rate combinations on a computer/monitor combination as it gets older -- something that worked for years may suddenly cause problems as the circuits drift with age.

slooksterPSV
Nov 24, 2004, 10:59 PM
Its strange, but my brothers computer seems to run faster just because of the refresh rate on it. Mine, right now, is set to 60hz and thats all it supports, on his its like 75 so everything is smoother and faster running (or so it looks)

Makosuke
Nov 25, 2004, 04:52 AM
Problem with the new ATI drivers?

I thought I saw mention of an update for the older video cards on the new OS updates, the new drivers may have a problem with certain resolution/scan rate combinations -- since it's happening on a third of the machines.
Actually, though I didn't have time to test at work tonight (and as curious as I am, I'm not going back at 2:30am to check), I suspect that the problem is present with all of them, and I just wasn't putting my finger on the resolution the monitor was set to as the dependant variable. Maybe not, but since I know the two repeatedly seeing the problem regularly have their screens set to a higher resolution, it would make sense.

Likely the ones that "cleared up" miraculously did so because in double-checking the monitor settings I inadvertently changed the refresh rate to something acceptable.

As for the problem being ATI's drivers, where do those kick in during the boot process? I thought it was after the spinner appeared, not before. Obviously there's something driving the monitor before that, of course, so ATI or otherwise that would be where the problem lies. The fact that it has no problems after it's finished the initial boot phase (it can change the resolution as soon as it reaches the blue screen without issue) sort of points to it being something lower level, but then I don't know that much about 10.3's architecture in this area.

I'll have to see what happens if I boot one into 9 and set it to a problem resolution, too.