PDA

View Full Version : Blu Ray ripping problems..




Chad H
Aug 11, 2010, 06:45 PM
Hey guys,
Just had a buddy come over and watch two movies off of his thumb drive using my xbox. I decided to add them to my iTunes library that I also stream with my Apple TV. Now, for some reason even when added to iTunes they won't show up on my Apple TV. So, I tried re-encoding them with Handbrake and when it's done the video is really slow and the audio is in super slow mo. The movie is also nearly double the length. I also noticed while in Handbrake its averaging 99 FPS or around that area. Does anyone know what could be the cause of this? I have chosen the Apple TV preset in handbrake and nothing more. The format of the two movies are .mp4 . He ripped them using windows 7.

Thanks!:apple:



Corndog5595
Aug 11, 2010, 06:48 PM
You could manually change the framerate to 30 and see if that works.

Chad H
Aug 11, 2010, 08:57 PM
Nope, I manually changed the FPS to 29.97 and it didn't make a difference. :(

brentsg
Aug 11, 2010, 09:34 PM
Make sure they aren't still 1080p.

Chad H
Aug 11, 2010, 10:29 PM
Hey would I test that or fix it so Apple TV can play them?

GermanSuplex
Aug 11, 2010, 11:29 PM
I've used Handbreak for all of my film encodes and have not had any issues. All of my films come out looking great and even longer movies like Avatar which I force to fit into a file under 4GB still look great.

My only issue is with concerts on Blu-Ray where the framerate is 29.97fps.... forcing them to a lower framerate makes them look jerky, so I haven't encoded them yet. Hopefully the next ATV allows for 29.97 720p, since the iPhone 4 and iPad can play back such files.

Chad H
Aug 12, 2010, 12:25 AM
What I'm wondering is if the files are 1080p why will they play on iTunes but not on the Apple TV or what I can do to remedy the problem?

roidy
Aug 12, 2010, 04:35 AM
What I'm wondering is if the files are 1080p why will they play on iTunes but not on the Apple TV or what I can do to remedy the problem?

Simple answer, because the ATV will only play 720p content and not 1080p. To remedy it you'll need to re-encode them as 720p files at no more that 24fps.

Chad H
Aug 12, 2010, 08:45 AM
Simple answer, because the ATV will only play 720p content and not 1080p. To remedy it you'll need to re-encode them as 720p files at no more that 24fps.
So just use Handbrake and select the FPS to be at 24? Appreciate the help guys. I wonder when I do encode the original and don't change the FPS does the video mess up like that? Everything is in slow mo and the movie length is doubled.

roidy
Aug 12, 2010, 10:11 AM
The ATV only supports video at the following resolutions and frame rates:-

1280x720 at upto 24fps
960x540 at upto 30fps

So it depends on the frame rate of your source. If your source is a Blu-ray then 9 times out of 10 the frame rate will be 23.976fps so you can encode it at 1280x720@23.976. If however the frame rate is over 24fps then you will have to decide weather to lower the resolution to 960x540 and keep the frame rate the same or encode at 1280x720 and lower the frame rate. Personally I would avoid changing the frame rate of a video as it can create problems with judderie playback.

So just use Handbrake and select the FPS to be at 24?

Ideally you want to use the 'Same as Source' setting for the frame rate in Handbrake.

rayward
Aug 12, 2010, 12:59 PM
So just use Handbrake and select the FPS to be at 24? Appreciate the help guys. I wonder when I do encode the original and don't change the FPS does the video mess up like that? Everything is in slow mo and the movie length is doubled.

Download Mediainfo (http://mediainfo.sourceforge.net/en), and it will tell you all the details of your movie files. As mentioned in other posts, most Blu Ray content is a 23.xxx FPS, so you can leave Handbrake's frame rate setting as "Same as Source". If it's higher, you're going to have to set it to 24, and hope that the encode isn't choppy.

Also, if it's still 1080p, open Handbrake's Picture settings and (some of this is preference rather than cast in stone) set Anamorphic to "None", check the Keep Aspect Ratio option, and change the file width to 1280. The file height will set itself (because of the aspect ratio lock) and should then be 720 if the original file has been cropped for a widescreen TV, or something less than that if the original full frame width has been maintained.

Encode with these settings, and you'll get a 720p/24fps file that your ATV can handle.

On last thing: Apple TV is sensitive to high bit rates. This happens on movies where these is a lot of detail - "Hurt Locker" for example, because (presumably) of the detail required to show the sand. B&W movies tend to trip up here too, which has always struck me as odd (both "Young Frankenstein" and "Clerks" encoded with very high bit rates that overwhelmed my ATV). If you encode as described above, yet your movie still won't sync up to your ATV, re-encode but scale down the bit rate a touch, not much, then re-encode and see how that goes. There may be a bit of trial and error here as you find the highest bit rate that ATV will accept, but you'll get there in the end.

Chad H
Aug 12, 2010, 01:00 PM
The ATV only supports video at the following resolutions and frame rates:-

1280x720 at upto 24fps
960x540 at upto 30fps

So it depends on the frame rate of your source. If your source is a Blu-ray then 9 times out of 10 the frame rate will be 23.976fps so you can encode it at 1280x720@23.976. If however the frame rate is over 24fps then you will have to decide weather to lower the resolution to 960x540 and keep the frame rate the same or encode at 1280x720 and lower the frame rate. Personally I would avoid changing the frame rate of a video as it can create problems with judderie playback.



Ideally you want to use the 'Same as Source' setting for the frame rate in Handbrake.

Sorry for all the questions. But, do I just select the preset ATV and let it go? That's what I have been doing and its causing the slo mo problem when the video is complete.

brentsg
Aug 12, 2010, 01:04 PM
No.

Select the AppleTV preset, but then go into Picture Settings (or something like that) and change the resolution to 720p. By default the ATV preset uses Optimal I think, so that keeps it at 1080p which the ATV will not play.

Sorry if I'm off a bit on the settings. I don't have Handbrake to my disposal right now.

rayward
Aug 12, 2010, 01:06 PM
Sorry for all the questions. But, do I just select the preset ATV and let it go? That's what I have been doing and its causing the slo mo problem when the video is complete.

Jumping in if I may...

The ATV preset gives you an SD quality product. Perfect for DVD-sourced files, but no good if you want an HD product. See my post above about the setting adjustments needed to get a 720p HD file.

The easiest way is to select the Apple TV preset, then make the suggested adjustments. I use this so much that I have made a custom preset that does this automatically, which is recommended (and simple) if you're going to be doing this a lot.

roidy
Aug 12, 2010, 01:28 PM
Regardless of what settings anyone tells you to use, try and avoid changing the frame rate at any cost. If your file is over 24fps then lower the resolution and not the frame rate. Lowering the frame rate from 30fps to 24fps means that you're losing frames which can end up making the motion of the file choppy.

Chad H
Aug 12, 2010, 05:42 PM
Well, I tried changing the fps to 24 and changing the aspect ratio to 1280 and set anamorphic to none, neither worked. When you play the video that comes out its slighter slower than normal and the audio is all messed up and slow mo. The original file plays fine. The encoded file reads Role Models (Unrated) 2008 BRRip H264 AAC-MS.mp4.

Chad H
Aug 15, 2010, 02:32 PM
Okay guys after further investigation the video comes out fine even on Apple TV default. It's the audio that's messing up. Sorry, the audio being off so badly made the think the video was slowing down too. As it turns out the audio is just in super slow mo. Does anybody know how to fix this? Thanks. :):apple:

omni
Aug 15, 2010, 11:16 PM
How has this thread gone on for so long?

First of all - you aren't ripping a blu ray or this could have been solved after the first post. More than likely it's a mkv file and who knows what is inside it.

Second - with out some sort of log or anything, everyone here is just guessing.

Under audio options in handbrake - what does it say the Audio is? Is it a mp3, wav, dts, etc?

And if it has chapters that handbrake can see, encode just 1 chapter instead of the whole movie when testing things.

Chad H
Aug 16, 2010, 05:57 PM
How has this thread gone on for so long?

First of all - you aren't ripping a blu ray or this could have been solved after the first post. More than likely it's a mkv file and who knows what is inside it.

Second - with out some sort of log or anything, everyone here is just guessing.

Under audio options in handbrake - what does it say the Audio is? Is it a mp3, wav, dts, etc?

And if it has chapters that handbrake can see, encode just 1 chapter instead of the whole movie when testing things.

The file extension is .mp4 . Under audio in Handbrake is lists the following.

Source: (Unknown) AAC
Audio Codec: AAC(Core Audio)
Mixdown: Stereo
Sample Rate: Auto
Bitrate: 128