PDA

View Full Version : Settings not appearing when App is upgdated




zerocustom1989
Aug 17, 2010, 07:57 PM
Ok, I've posted this like everywhere and no one has been able to help me.
Does Apple have an Engineering number I can just call?

I'm ready to release my app, but I've got one hang-up.

I download my app from the app-store (version 1.0) and when i upgrade it to 2.0 via Xcode the application settings option that I've added to V 2.0 does not appear in the settings app.

Does anyone have experience submitting an app Update that added a Settings.Bundle. Did everything go smoothly? did you notice any problems?



Luke Redpath
Aug 17, 2010, 08:16 PM
Just a hunch but it could be that because the copy of your app you installed from the app store and the version you built using Xcode use different provisioning profiles that the OS considers them to be different apps which is why its not picking up your settings bundle changes.

zerocustom1989
Aug 17, 2010, 08:50 PM
Just a hunch but it could be that because the copy of your app you installed from the app store and the version you built using Xcode use different provisioning profiles that the OS considers them to be different apps which is why its not picking up your settings bundle changes.

Yea, I thought of that, so I changed the provisioning profile to the distribution one I used for my previous app store submission. Still no appearance of the settings. If it's not going to be a problem I'll proceed with submission, but i'd hate to be the guinea pig and piss off my userbase(small, but still).

nigeljh
Nov 15, 2010, 09:52 AM
Hi,

I'm having the same problem - works fine if I uninstall the app before I do an xcode install, but not if I update.

Did you get anywhere?

Thanks