Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 27, 2012, 09:03 PM   #1
micrors4racer
macrumors 6502
 
Join Date: Apr 2012
Video cannot be played on iPhone?

I remuxed a show from mkv using subler to turn it into an m4v with an ac3 track and aac 2 ch. track. It plays fineon my mac and through my network with my apple tv and iPhone using home sharing. How ever when I try to sync the video to my iPhone so I can watch it on the go it gives me an error saying "...were not copied to the iPhone because they cannot be played on this iPhone." I can get it to say something along the lines of the video being an unsupported format if I individually click the files on the error window. Why is it doing this? The files are obviously in the correct format because they play fine on the apple tv, mac, and even the iPhone I am trying to sync them to if I am using home sharing.

Here are the video file stats. I have 2 seasons worth of this show remuxed and all of the episodes refuse to sync.
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2012-11-27 at 6.51.35 PM.png
Views:	23
Size:	19.8 KB
ID:	380097  
micrors4racer is offline   0 Reply With Quote
Old Nov 28, 2012, 02:58 AM   #2
Menneisyys2
macrumors 601
 
Join Date: Jun 2011
Quote:
Originally Posted by micrors4racer View Post
I remuxed a show from mkv using subler to turn it into an m4v with an ac3 track and aac 2 ch. track. It plays fineon my mac and through my network with my apple tv and iPhone using home sharing. How ever when I try to sync the video to my iPhone so I can watch it on the go it gives me an error saying "...were not copied to the iPhone because they cannot be played on this iPhone." I can get it to say something along the lines of the video being an unsupported format if I individually click the files on the error window. Why is it doing this? The files are obviously in the correct format because they play fine on the apple tv, mac, and even the iPhone I am trying to sync them to if I am using home sharing.

Here are the video file stats. I have 2 seasons worth of this show remuxed and all of the episodes refuse to sync.
I think the H.264 level of the files is over 4.1. (Which shouldn't be the case with standard 720p files as 720p shouldn't be over 4.1. Some for example cameras, however, are known for incorrectly setting it.)

Videos with AAC + AC3 audio tracks and level 4.1 or less should sync just great with iOS - for example, the one at https://dl.dropbox.com/u/81986513/11...yframe-l41.m4v (give it a try to check if it indeed synches to yours!). The same file with level 5.1, however, can't be synched - it's at https://dl.dropbox.com/u/81986513/11...thKeyframe.m4v

Check the level with Subler or MediaInfo. I can even paste my H.264-level specific tutorials if you don't know what this all is about.
Menneisyys2 is offline   0 Reply With Quote
Old Nov 28, 2012, 11:44 PM   #3
micrors4racer
Thread Starter
macrumors 6502
 
Join Date: Apr 2012
Quote:
Originally Posted by Menneisyys2 View Post
I think the H.264 level of the files is over 4.1. (Which shouldn't be the case with standard 720p files as 720p shouldn't be over 4.1. Some for example cameras, however, are known for incorrectly setting it.)

Videos with AAC + AC3 audio tracks and level 4.1 or less should sync just great with iOS - for example, the one at https://dl.dropbox.com/u/81986513/11...yframe-l41.m4v (give it a try to check if it indeed synches to yours!). The same file with level 5.1, however, can't be synched - it's at https://dl.dropbox.com/u/81986513/11...thKeyframe.m4v

Check the level with Subler or MediaInfo. I can even paste my H.264-level specific tutorials if you don't know what this all is about.
The files are level 4.1 according to subler does that sound correct?
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2012-11-28 at 9.45.00 PM.png
Views:	12
Size:	34.2 KB
ID:	380330   Click image for larger version

Name:	Screen Shot 2012-11-28 at 9.40.44 PM.png
Views:	14
Size:	22.2 KB
ID:	380328  
micrors4racer is offline   0 Reply With Quote
Old Nov 29, 2012, 02:02 AM   #4
Menneisyys2
macrumors 601
 
Join Date: Jun 2011
Quote:
Originally Posted by micrors4racer View Post
The files are level 4.1 according to subler does that sound correct?
1, it sounds normal. Did you try synching the file I've linked to, in order to see whether it's a generic problem with your iTunes?

2, if it works, can you post your video online (say, Dropbox) so that I can try it too? If it's too big, just split it (via, say, QuickTime 7 Pro), and, making sure the splitted video can't be synched either, post the short chunk?

EDIT: forget the above. The problem is that your AAC track isn't enabled - hence the unchecked AAC checkbox in Subler. This has no effect in VLC but it has in both iTunes when trying to play it back (it'll grey out the second audio track) and, particularly, when you try to synch the video to an iDevice.

The solution: just enable the AAC checbox in Subler and save.

Last edited by Menneisyys2; Nov 29, 2012 at 07:55 AM.
Menneisyys2 is offline   0 Reply With Quote
Old Nov 29, 2012, 07:56 AM   #5
Menneisyys2
macrumors 601
 
Join Date: Jun 2011
Quote:
Originally Posted by Menneisyys2 View Post
EDIT: forget the above. The problem is that your AAC track isn't enabled - hence the unchecked AAC checkbox in Subler. This has no effect in VLC but it has in both iTunes when trying to play it back (it'll grey out the second audio track) and, particularly, when you try to synch the video to an iDevice.

The solution: just enable the AAC checbox in Subler and save.
Bumping the thread, should you already have read my previous answer.
Menneisyys2 is offline   0 Reply With Quote
Old Nov 29, 2012, 10:39 AM   #6
micrors4racer
Thread Starter
macrumors 6502
 
Join Date: Apr 2012
Quote:
Originally Posted by Menneisyys2 View Post
Bumping the thread, should you already have read my previous answer.
It is greyed out in iTunes so you are on to something. But before I run everything through subler again; wouldn't enabling both tracks cause them to play at the same time? Should I check the subtitle track on my videos with subtitles or leave them unchecked?


One last thing, could I just run the M4Vs through subler or do I have to start fro my MKVs again?
micrors4racer is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
How do I stream a video that is being played in Safari to an Apple TV? moonman239 iPhone/iPad Programming 2 Apr 14, 2014 11:13 AM
How do I stream a video that is being played in Safari to an Apple TV? moonman239 OS X Mavericks (10.9) 2 Apr 5, 2014 03:02 PM
Video DVD's burned on my MBP won't be played by DVD-players ConscienceNL MacBook Pro 0 Aug 18, 2012 06:41 AM
Boom... How a company played the whole iPhone rumor industry for fools Big.Mac.Daddy iPhone 24 Aug 17, 2012 06:56 PM
iTunes Video opens up in a separate window when played. How to deactivate it? SethRogen Mac Applications and Mac App Store 1 Jul 4, 2012 04:25 PM

Forum Jump

All times are GMT -5. The time now is 06:30 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC