Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 29, 2012, 10:46 AM   #1
zlayde
macrumors newbie
 
Join Date: Dec 2012
Problem with Air & USB 3.0 hub

Hi all -

I'm a new Macbook Air owner and needed a USB 3 hub for all my stuff.

I bought one of these:

http://www.amazon.com/gp/product/B00...ls_o00_s00_i02

...which seemed best rated and reviewed and such. It works just fine except that it won't recognize my external HD (which is in a usb 3 enclosure). Everything else gets picked up. The drive shows up just fine plugged directly into the Mac.

Is there anything I can do to make this work or should I be shopping for another hub? If so, which do you recommend?

Thanks,
Rich
zlayde is offline   0 Reply With Quote
Old Dec 29, 2012, 10:51 AM   #2
pure3d2
macrumors 6502
 
Join Date: Mar 2012
Quote:
Originally Posted by zlayde View Post
Hi all -

I'm a new Macbook Air owner and needed a USB 3 hub for all my stuff.

I bought one of these:

http://www.amazon.com/gp/product/B00...ls_o00_s00_i02

...which seemed best rated and reviewed and such. It works just fine except that it won't recognize my external HD (which is in a usb 3 enclosure). Everything else gets picked up. The drive shows up just fine plugged directly into the Mac.

Is there anything I can do to make this work or should I be shopping for another hub? If so, which do you recommend?

Thanks,
Rich
Do you have the 12V power adapter plugged in? It's not picking up your external HD because the HD isn't getting enough power from the hub.
pure3d2 is offline   0 Reply With Quote
Old Dec 29, 2012, 11:41 AM   #3
zlayde
Thread Starter
macrumors newbie
 
Join Date: Dec 2012
Yep

Yeh I do.
zlayde is offline   0 Reply With Quote
Old Dec 29, 2012, 03:08 PM   #4
krravi
macrumors 6502a
 
Join Date: Nov 2010
Quote:
Originally Posted by zlayde View Post
Yeh I do.
The second comment on that product page seems to have had the same issue...

"This hub was used on the USB 3.0 port of a new MacBook Pro. It had a sporadic (defective) connection on Port-1. This port usually did not work, although on a rare occasion it did connect for a time, before dropping out and unmounting the drive with an error message. This presented the potential for file/data corruption."

Try other ports and best, return it and try another brand.
__________________
Lots of Apple,Sony and other gadgets.
krravi is offline   0 Reply With Quote
Old Dec 29, 2012, 03:23 PM   #5
zlayde
Thread Starter
macrumors newbie
 
Join Date: Dec 2012
I tried other ports. I'll toy around a bit more.

My guess is I'm going to have to just try another brand..
zlayde is offline   0 Reply With Quote
Old Dec 29, 2012, 05:41 PM   #6
andothfc
macrumors regular
 
Join Date: Jul 2008
Issues with USB 3 drives in general seem to be pretty common with these first lot of Macs that support it. Iíve all sorts of trouble trying to get either my MacBook Air or MacBook Pro Retina to mount my USB 3 drive with any regularity.
andothfc is offline   0 Reply With Quote
Old Jan 5, 2013, 03:44 PM   #7
i-Moi
macrumors newbie
 
Join Date: Feb 2010
Same Hub, same problem

Hi,

UPDATE :
After my problems, Uspeed sent me —they proposed it— a brand new Hub : the responsible was the USB 3 cable. They just were great.

i-Moi
_______
I also just received this Hub from Amazon, for my MacBook Air bought on november 2012, and it just doesn't work. I plugged several devices on it, on the following ports :
  1. External USB 3 hard disk (3.5") : NO
  2. External USB 3 hard disks (3.5") : NO
  3. iPhone 4S (USB ?) : YES
  4. Flash card reader (USB 2) : YES
  5. DVD drive (USB 2) : YES

Then I changed ports : here are the results.
  1. iPhone 4S (USB ?) : OK
  2. Nothing
  3. Flash card reader (USB 2) : OK
  4. External USB 3 hard disk (3.5") : OK
  5. DVD drive (USB 2) : OK
  6. External USB 3 hard disks (3.5") : OK

The first 3 ports seem to work badly, at least with USB 3 devices and on a MBA. Hope it helps.

Last edited by i-Moi; Jan 25, 2013 at 03:55 AM.
i-Moi is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:14 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC