Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 13, 2011, 01:05 AM   #1
bdzer
macrumors member
 
Join Date: Oct 2011
Location: Washington
Problems with iMessage...

I'm having a problem, maybe I just don't know how to use my phone well..

I try to create a new iMessage to someone or make it as a group, I enter my Text Message app and click the new message button at the top right, my iMessage contacts don't appear on there when I search for them and it is making a new text message. Does anyone know how to change this or make a new iMessage to a person/group?
bdzer is offline   0 Reply With Quote
Old Dec 13, 2011, 01:09 AM   #2
Jare
macrumors 65816
 
Jare's Avatar
 
Join Date: Jun 2010
Location: Canada
Quote:
Originally Posted by bdzer View Post
I'm having a problem, maybe I just don't know how to use my phone well..

I try to create a new iMessage to someone or make it as a group, I enter my Text Message app and click the new message button at the top right, my iMessage contacts don't appear on there when I search for them and it is making a new text message. Does anyone know how to change this or make a new iMessage to a person/group?
/facepalm.

Your contacts use their apple ID and or phone numbers as their iMessage address. There aren't "iMessage contacts", your phone automatically determines this while attempting to send a text.

This is all explained in the user manuals.
__________________
"Feels like I'm wearing NOTHING AT ALL!" - Stupid Sexy Flanders
iOS, OS X & Android Developer
13" MacBook Air, Space Grey iPhone 5S, Moto X, Google Glass Explorers Kit
Jare is offline   0 Reply With Quote
Old Dec 13, 2011, 01:21 AM   #3
bdzer
Thread Starter
macrumors member
 
Join Date: Oct 2011
Location: Washington
Quote:
Originally Posted by Jare View Post
/facepalm.

Your contacts use their apple ID and or phone numbers as their iMessage address. There aren't "iMessage contacts", your phone automatically determines this while attempting to send a text.

This is all explained in the user manuals.
I already have iMessage chats open with some of my friends but when I try to open a new one it's a Text Message. Am I misinterpreting something? Did I put their e-mail in a bad category or something?
bdzer is offline   0 Reply With Quote
Old Dec 13, 2011, 01:23 AM   #4
Jare
macrumors 65816
 
Jare's Avatar
 
Join Date: Jun 2010
Location: Canada
Quote:
Originally Posted by bdzer View Post
I already have iMessage chats open with some of my friends but when I try to open a new one it's a Text Message. Am I misinterpreting something? Did I put their e-mail in a bad category or something?
That would mean (I'm just assuming here) that they are unavailable for iMessage.
__________________
"Feels like I'm wearing NOTHING AT ALL!" - Stupid Sexy Flanders
iOS, OS X & Android Developer
13" MacBook Air, Space Grey iPhone 5S, Moto X, Google Glass Explorers Kit
Jare is offline   0 Reply With Quote
Old Dec 13, 2011, 01:23 AM   #5
digitard
macrumors 6502a
 
Join Date: Sep 2004
Location: Gilbert, AZ
I just load all my iMessage contacts as the iPhone listing, and it seems to always go to iMessage that way unless I turn it off.
__________________
MBP: Late 2013 (16GB / SSD / 750GTX)
32GB iPad3 (WiFi)
32GB iPhone 5 (Verizon)
16GB iPod Touch 5th Gen
digitard is offline   0 Reply With Quote
Old Dec 13, 2011, 01:26 AM   #6
bdzer
Thread Starter
macrumors member
 
Join Date: Oct 2011
Location: Washington
Quote:
Originally Posted by Jare View Post
That would mean (I'm just assuming here) that they are unavailable for iMessage.
They are available

I wanted to make a group iMessage, which I did, but I had to delete the whole conversation with one of my friends then go into my contacts and click their contact to finally press Send Message and it opened up a 'New iMessage' instead of 'New Message' (Text). The only way I can iMessage someone is to go into contacts and I can't make a new iMessage directly from the Text app.
bdzer is offline   0 Reply With Quote
Old Dec 13, 2011, 03:15 PM   #7
bdzer
Thread Starter
macrumors member
 
Join Date: Oct 2011
Location: Washington
I haven't found the solution, my iMessage works fine, I just can't make a new iMessage as it is always a text message.
bdzer is offline   0 Reply With Quote
Old Dec 13, 2011, 03:55 PM   #8
sweetbrat
macrumors 65816
 
sweetbrat's Avatar
 
Join Date: Jun 2009
Location: Redford, MI
Are you sure that all people that you're trying to send to have iOS5 and have iMessage turned on?
__________________
15" MacBook Pro 2.2GHz i7, Crucial M4 SSD (Early 2011); 15" MacBook Pro (late 2008); Mac Pro 1,1 2.66GHz Dual-Core Xeon; 32GB iPad Mini; iPhone 4S 32GB; 6th gen iPod Nano
sweetbrat is offline   0 Reply With Quote
Old Dec 13, 2011, 04:23 PM   #9
AlphaVictor87
macrumors 6502a
 
AlphaVictor87's Avatar
 
Join Date: Sep 2011
Location: Saint Louis, MO
i do know that certain people you iMessage with and your phone still has that info in memory, it will have a nice symbol to show you if they have iMessage enabled when starting a new text.

AlphaVictor87 is offline   0 Reply With Quote
Old Dec 13, 2011, 04:30 PM   #10
bdzer
Thread Starter
macrumors member
 
Join Date: Oct 2011
Location: Washington
Quote:
Originally Posted by sweetbrat View Post
Are you sure that all people that you're trying to send to have iOS5 and have iMessage turned on?
Yeah, they do.

If it helps, I iMessage them using their Apple ID E-Mails and not their phone numbers because they are in Australia and Canada.

----------

Quote:
Originally Posted by AlphaVictor87 View Post
i do know that certain people you iMessage with and your phone still has that info in memory, it will have a nice symbol to show you if they have iMessage enabled when starting a new text.

Image
Your screenshot shows the @ sign, and the ability to type in .'s but when I go to make a new message mine does not. My iMessage works though as I have a few conversations open with other people.
bdzer is offline   0 Reply With Quote
Old Dec 13, 2011, 07:26 PM   #11
bdzer
Thread Starter
macrumors member
 
Join Date: Oct 2011
Location: Washington
Does anyone have the same problem as me? I can't type .'s or @'s when trying to create a new message.
bdzer is offline   0 Reply With Quote
Old Dec 13, 2011, 07:32 PM   #12
verwon
macrumors 68030
 
verwon's Avatar
 
Join Date: Jul 2011
Location: Seattle
Quote:
Originally Posted by bdzer View Post
Yeah, they do.

If it helps, I iMessage them using their Apple ID E-Mails and not their phone numbers because they are in Australia and Canada.

----------



Your screenshot shows the @ sign, and the ability to type in .'s but when I go to make a new message mine does not. My iMessage works though as I have a few conversations open with other people.
On iMessage, where they are located doesn't matter. It's still only data use, if it sends via iMessage.
verwon is offline   0 Reply With Quote
Old Dec 14, 2011, 02:10 AM   #13
bdzer
Thread Starter
macrumors member
 
Join Date: Oct 2011
Location: Washington
Quote:
Originally Posted by verwon View Post
On iMessage, where they are located doesn't matter. It's still only data use, if it sends via iMessage.
I know it does not matter.
bdzer is offline   0 Reply With Quote
Old Dec 14, 2011, 01:05 PM   #14
AlphaVictor87
macrumors 6502a
 
AlphaVictor87's Avatar
 
Join Date: Sep 2011
Location: Saint Louis, MO
Quote:
Originally Posted by bdzer View Post
Your screenshot shows the @ sign, and the ability to type in .'s but when I go to make a new message mine does not. My iMessage works though as I have a few conversations open with other people.
Mine shows the @ and . when i'm typing in the "To:" part of the message. Once i switch to the body of the message and what is actually going to be sent, then it switches to just a space bar and those two buttons go back to where it normally was after you press the "123+" button

EDIT: also in my original message i was talking about the little blue bubble next to the first contact
AlphaVictor87 is offline   0 Reply With Quote
Old Dec 15, 2011, 07:33 AM   #15
bdzer
Thread Starter
macrumors member
 
Join Date: Oct 2011
Location: Washington
Quote:
Originally Posted by AlphaVictor87 View Post
Mine shows the @ and . when i'm typing in the "To:" part of the message. Once i switch to the body of the message and what is actually going to be sent, then it switches to just a space bar and those two buttons go back to where it normally was after you press the "123+" button

EDIT: also in my original message i was talking about the little blue bubble next to the first contact
I have the blue bubbles only when I go into Phone -> Contacts -> Send Message, that's the only time I can make a new iMessage, I cannot make one directly in the Texting app.
bdzer is offline   0 Reply With Quote
Old Dec 15, 2011, 09:22 AM   #16
AlphaVictor87
macrumors 6502a
 
AlphaVictor87's Avatar
 
Join Date: Sep 2011
Location: Saint Louis, MO
Quote:
Originally Posted by bdzer View Post
I have the blue bubbles only when I go into Phone -> Contacts -> Send Message, that's the only time I can make a new iMessage, I cannot make one directly in the Texting app.
well that's just weird. I'd try backing up your phone and doing a restore just to see if it helps
AlphaVictor87 is offline   0 Reply With Quote
Old Dec 15, 2011, 05:12 PM   #17
bdzer
Thread Starter
macrumors member
 
Join Date: Oct 2011
Location: Washington
Quote:
Originally Posted by AlphaVictor87 View Post
well that's just weird. I'd try backing up your phone and doing a restore just to see if it helps
I might try when I have the time to restore.
bdzer is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iMessage problems since 9/12 /dev/toaster iOS 7 1 Sep 13, 2013 01:53 PM
iMessage problems applequeen22 iOS 6 0 Mar 10, 2013 11:46 AM
Problems with iMessage jbrown Mac Applications and Mac App Store 0 Nov 13, 2012 01:54 PM
Imessage problems jfk3674 Mac Applications and Mac App Store 0 Sep 24, 2012 11:32 AM
iMessage Problems rcallahan iOS 6 3 Jul 27, 2012 08:22 AM

Forum Jump

All times are GMT -5. The time now is 06:32 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC