Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 19, 2012, 04:21 PM   #1
JoeGoldman
macrumors newbie
 
Join Date: Feb 2012
OS X Server 10.7.3 Open Dir issues

Hi Forum.

Thought i'd ask this here, as there seems to be a plethora of knowledge on Mac Hardware obviously.

Recently at the office we got a Mac Mini server with OS X Server Lion on it. I set it up mostly, and started using it myself as a proof of concept. Network account, with mobile account creation, home sync etc. Thats all we really want it for. It worked great.

Recently, logging on to the server, the Server Admin.app and what not could not log in to the server for administration. Found this was a problem with a service not starting, and an upgrade to 10.7.3 fixed this issue.

Now today we wanted to start migrating other users over to it, and no account can log in from a remote machine. I have created the users on the server, I can log into the users on the server (i.e. locally), but when trying to log in to a user from a remote machine, I just get an error 'Unable to log into this account at this time'.

If I use the wrong password, it appears to notice as it shakes notifying of wrong password, but when using the correct password it pops up the error.

Any insight into how these services work and mesh together is greatly appreciated.

THanks,
Joe
JoeGoldman is offline   0 Reply With Quote
Old Feb 19, 2012, 09:35 PM   #2
mainstay
macrumors 6502
 
Join Date: Feb 2011
Location: BC
client computers are bound to the server?

the username is NOT the same on the local computer as on the server?

using SSL encryption between client and server?
__________________
mainstay is offline   0 Reply With Quote
Old Feb 19, 2012, 10:54 PM   #3
JoeGoldman
Thread Starter
macrumors newbie
 
Join Date: Feb 2012
Quote:
Originally Posted by mainstay View Post
client computers are bound to the server?

the username is NOT the same on the local computer as on the server?

using SSL encryption between client and server?
Computers are definitely bound.

No local users by the same name.

SSL Encryption is on, but non-signed cert and get prompted to add exception (which we have done so).

For filesharing and other things, it works perfect for the users. It appears to be 'just' logging into accounts is the issue.
JoeGoldman is offline   0 Reply With Quote
Old Feb 20, 2012, 03:09 AM   #4
satty
macrumors 6502
 
Join Date: Mar 2004
Location: You can't beat Wellington on a good day
Quote:
Originally Posted by JoeGoldman View Post
Computers are definitely bound.

No local users by the same name.

SSL Encryption is on, but non-signed cert and get prompted to add exception (which we have done so).

For filesharing and other things, it works perfect for the users. It appears to be 'just' logging into accounts is the issue.
I'm not a complete expert, but check on the client machines:
System Preferences - Users & Groups - Login options - Network Account server
Should contain your OD server and show it with a green LED.

Check in the Workgroup manager, that the flag Access Account for the user is set.

Check in the Server Admin, that the users are assigned to service Login Window

Another problem, can be authorities on the users' home directory on the server.
satty is offline   0 Reply With Quote
Old Feb 20, 2012, 03:28 AM   #5
JoeGoldman
Thread Starter
macrumors newbie
 
Join Date: Feb 2012
Quote:
Originally Posted by satty View Post
I'm not a complete expert, but check on the client machines:
System Preferences - Users & Groups - Login options - Network Account server
Should contain your OD server and show it with a green LED.

Check in the Workgroup manager, that the flag Access Account for the user is set.

Check in the Server Admin, that the users are assigned to service Login Window

Another problem, can be authorities on the users' home directory on the server.
Hi Satty,

Checked all that. It was definitely associated with the OD, as if you used the wrong password it would identify that, then if you used the right password, it would then throw the error, so it was successfully connecting to the server and authenticating, then not allowing the log in to continue, for whatever reason....


Since I was the only one using it, and I used it as a mobile account, I simply reformatted the server and its currently re-installing. Going to re-configure it from scratch as there were messy things I did first time around that I wanted to fix up anyways. I'll just re-create my account and copy my files and settings back over the home dir once it's created.

Boss has pretty much said if it screws up again we are just going to can the idea, have local users, and rsync our home dir to a file server every night. We don't get the full roaming capabilities then, but it's better than nothing.

Thanks to all who looked at this
JoeGoldman is offline   0 Reply With Quote
Old Feb 22, 2012, 03:12 AM   #6
satty
macrumors 6502
 
Join Date: Mar 2004
Location: You can't beat Wellington on a good day
Quote:
Originally Posted by JoeGoldman View Post
Checked all that. It was definitely associated with the OD, as if you used the wrong password it would identify that, then if you used the right password, it would then throw the error, so it was successfully connecting to the server and authenticating, then not allowing the log in to continue, for whatever reason....
One last thing... Ensure in the workgroup manager that the users are created in OD and not locally on the server.

And let us know how your re-configuration is going.
satty is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Can't open files from SMB file server j0sh1130 OS X Mavericks (10.9) 2 Oct 30, 2013 10:27 AM
Server Upgrade Issues kiantech Mac OS X Server, Xserve, and Networking 9 Oct 27, 2013 04:53 PM
How to migrate Open Directory from 10.6 to another server with 10.8? carlosribas Mac OS X Server, Xserve, and Networking 0 Jun 19, 2013 12:05 PM
10.6 Server Install Issues randallisation Mac OS X Server, Xserve, and Networking 4 Dec 9, 2012 03:48 PM
New Open Warfare Server COD4 xffmosha Mac and PC Games 0 Aug 1, 2012 08:03 AM

Forum Jump

All times are GMT -5. The time now is 01:25 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC