Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 11, 2012, 04:27 PM   #1
Reao
macrumors member
 
Join Date: Feb 2008
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

I have an older g5 computer running 10.5 server. I am using it for web hosting and I have a site with php on it. I followed the steps to turn php on in leopard and restarted my web service. After the restart my site the parts with php still do not work. Is there another way to turn php on in leopard server? I know this OS is quite old but any help would be grate.
__________________
:|: 15" Retina MacBook Pro | Wacom Cintiq 12wx | Canon Rebel XSi | Adobe Cloud :|:
Reao is offline   0 Reply With Quote
Old Mar 11, 2012, 09:59 PM   #2
1911
macrumors member
 
Join Date: Mar 2008
Re: Php on leopard server

What instructions did you follow?
What files did you edit?
Do you have a phpinfo.php file? If so does it load?
1911 is offline   0 Reply With Quote
Old Mar 12, 2012, 08:19 AM   #3
Reao
Thread Starter
macrumors member
 
Join Date: Feb 2008
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

http://foundationphp.com/tutorials/php_leopard.php here is what I followed. I am thinking I did not edit the right file for having the server OS.
__________________
:|: 15" Retina MacBook Pro | Wacom Cintiq 12wx | Canon Rebel XSi | Adobe Cloud :|:
Reao is offline   0 Reply With Quote
Old Mar 12, 2012, 11:04 AM   #4
Reao
Thread Starter
macrumors member
 
Join Date: Feb 2008
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

I have not made a test file just the site with the code I am trying to run. I know the code works it runs fine on a Linux box with php.
__________________
:|: 15" Retina MacBook Pro | Wacom Cintiq 12wx | Canon Rebel XSi | Adobe Cloud :|:

Last edited by Reao; Mar 12, 2012 at 11:45 AM.
Reao is offline   0 Reply With Quote
Old Mar 12, 2012, 03:45 PM   #5
etchtech09
macrumors member
 
Join Date: Jun 2010
One issue I have run into is that the fat binary acts funny with PHP. You may need to lipo the binary to only include your specific architecture.

Check this page for your specific system:

https://developer.apple.com/library/...doc/man/3/arch

You will also want to read the man page for the command lipo.

You will also need to be careful with the Apache binary as well. If you need more help with the commands, as you will need to do this from the command line, we can work more as it will be specific to your system.
etchtech09 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
PHP not working in OS X Server Jaggions Mac OS X Server, Xserve, and Networking 6 Oct 7, 2013 05:22 PM
Snow Leopard Server VS. OS X Server 10.8 Jaggions Mac OS X Server, Xserve, and Networking 7 Sep 20, 2013 12:33 PM
How to have an Apache server host a Gopher site? Can PHP do it? blanka Web Design and Development 1 Sep 5, 2013 06:11 AM
Anyone upgrade from Snow Leopard Server to Mountain Lion + Server.app? talmy Mac OS X Server, Xserve, and Networking 13 Jul 14, 2013 11:22 AM
Just looking at the performance, Snow Leopard server or Mountain Lion server? bl00dyg33k Mac OS X Server, Xserve, and Networking 0 Aug 23, 2012 07:55 AM

Forum Jump

All times are GMT -5. The time now is 03:43 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC