Go Back   MacRumors Forums > Apple Hardware > Desktops > iMac

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 17, 2012, 07:00 PM   #26
forty2j
macrumors 68030
 
forty2j's Avatar
 
Join Date: Jul 2008
Location: NJ
.. Apparently the combination of forgetting networks, clearing keychain entries, AND power-cycling both the router and the repeater did the trick. For now.
__________________
 2012 iMac 3.2GHz 27" 680MX Fusion  iPhone 6  Apple TV 2  iPad Air 
forty2j is offline   0 Reply With Quote
Old Apr 11, 2012, 01:45 PM   #27
Pbhd
macrumors newbie
 
Join Date: Apr 2012
Possible Solution

I had to turn off my blue tooth on my phone and computer. I also went into the network preferences and deleted the network I was trying to connect to and then had the computer search for it again. It is now working again.

(For some reason, I have had problems with the blue tooth connecting to wireless headsets. I haven't had the chance to research that yet.)
Pbhd is offline   0 Reply With Quote
Old Apr 19, 2012, 07:40 AM   #28
PaddyLock
macrumors newbie
 
Join Date: Apr 2012
Wifi connection FIXED!

Hi, I had a similar problem as the original post of this thread. The solution which I found, and was the only one that worked for me is to follow these steps:

firstly remove the wifi connection from your list: Apple menu -> System Preferences -> Network -> Wi-Fi -> Advanced highlight your wifi connection and click minus symbol.

then type the ip address for your router in a browser and THIS IS THE IMPORTANT BIT, Change the name of your Wi-Fi connection.

Then follow the first step above and add a new Wi-Fi connection using the new name.

Then you can connect to Wi-Fi again, happy days!

Hope this helps someone else out.

Patrick
PaddyLock is offline   0 Reply With Quote
Old May 5, 2012, 06:34 AM   #29
kkhair
macrumors newbie
 
Join Date: Nov 2011
A solution

Hi all;
I had the same problem, and I was able to fix it following these steps:

1- remove the Wifi network from your preferred networks, System Preferences ->Network->Wi-Fi->advanced.

2- Click OK to return to the network window.

3- click the Assist me ... button.

4- follow the instructions.

These steps always worked for me whenever my Macbook pro stops connecting to one of my networks.

Hope it helps ..
Khaled
kkhair is offline   0 Reply With Quote
Old Jun 15, 2012, 05:30 PM   #30
philwhln
macrumors newbie
 
Join Date: Jul 2008
Quote:
Originally Posted by kkhair View Post
I just removed the network for the Preferred network list (Sys Pref->Network->Wifi->advanced ->wifi) , then added it manually (with the + sign under the list) with a wrong password and tried to connect, the password window showed up and when I entered the correct password, it worked perfectly, hope this helps
This worked for me after I changed the password on the router. I had to add it manually to Mac Network Settings. Phew!
philwhln is offline   0 Reply With Quote
Old Jun 27, 2012, 04:53 AM   #31
fattakin
macrumors newbie
 
Join Date: May 2010
I've been plagued with this since i bought my mid 2010 MBP.

Ive tried everything above at it always comes back.

delete keychains
rename router
change router security & channel
setup new locations
use manual ip's
3 different brand routers included 1st gen timecapsule
Snow Leopard & Lion.

So after trying top call apple, they wanted 35 to even speak to me on the phone I decided to buy a used wifi card off ebay and went for an 8gb ram upgrade too. (Kingston)

The wifi card hasnt arrived yet but i upgraded the ram last week.

Guess what, its been a week and the wifi hasnt dropped and has connected from sleep every time!!! To say im puzzled is an understatement. Im too afraid to boot into Lion to check so am staying on SL and not changing a thing. Its so refreshing to lit the lid and the b*stard actually connects .. or not have etehrnet cables across the living room.. or being able to leave the house and not have my wife phoning saying the wifi is down again. Windows devices & iphone4/galaxy s2 never had any issues this whole time.
fattakin is offline   0 Reply With Quote
Old Jul 4, 2012, 01:38 AM   #32
nicolebinn
macrumors newbie
 
Join Date: Jul 2012
Talking Fixed!

I had the same problem with my mac, where out of the blue I could not connect to my wifi, always typing in my password and receiving "connection timeout".

I tried just about everything, and then finally realized the only way to truly fix the problem is fix the source.

I unplugged router and all of the connections, and then I shut down my computer for a few minutes.

When I turned it back on, wah-lah, the internet magically is already connected with no password even asked.
nicolebinn is offline   0 Reply With Quote
Old Jul 5, 2012, 02:22 PM   #33
hancock
macrumors member
 
Join Date: Jan 2008
I am having a similar problem to most of you, however, I cannot change the router settings because my MBA only displays a connection timeout at work. I connect to my works' guest wifi network with my laptop because the xp computers here are awful. For the first two weeks my laptop connected with no problem, then earlier this week it stopped being able to connect to the network. It displays a connection timeout immediately every time I try to connect. I have tried deleting my preferences and creating a custom location. My iPad and iPhone connect to the network without any problem. I even tried copying the tcp/ip information from my iPad but the problem persists. One final note, in order to connect to this network you must accept terms on a redirect page. Any suggestions would be greatly appreciated, this problem has proven overwhelming so far.
__________________
MBA
hancock is offline   0 Reply With Quote
Old Jul 16, 2012, 01:47 AM   #34
HAE
macrumors newbie
 
Join Date: Jul 2012
Quote:
Originally Posted by kkhair View Post
I just removed the network for the Preferred network list (Sys Pref->Network->Wifi->advanced ->wifi) , then added it manually (with the + sign under the list) with a wrong password and tried to connect, the password window showed up and when I entered the correct password, it worked perfectly, hope this helps
i made this account just to say THANKKK YOUUUUUUU OMMGG !!!! I spent all night yesterday and this morning to fix it and this worked !!! THANK YOU THANK YOU THANK YOUUU!! Freaking life saver !!!
HAE is offline   0 Reply With Quote
Old Jul 20, 2012, 07:49 AM   #35
sparky9999
macrumors newbie
 
Join Date: Jul 2012
Connection timeout problem fixed

Okay, nothing anyone else suggested worked for me. What did was to use Keychain Access to delete the keychain entry, then create a new keychain entry and MANUALLY enter the wifi password for the router.

I gather that other solutions worked for other people, but none of those worked for me. This did.
sparky9999 is offline   0 Reply With Quote
Old Sep 10, 2012, 12:49 AM   #36
n4wbie
macrumors newbie
 
Join Date: Dec 2011
My connection timeout and can't cannot to my rounter.

recently i found out a solution it does work for my mba 2011 mid.

1 : delete all ur network key
2 : do not remember your network
3 : the troublesome things is to everytime u have to manually key in password to connect to your router
4 : sometimes there will have connection timeout. u try again and again it still will show u connection timeout. so whenever u saw connection timeout click on okay and then just close ur lid and open it again . try to connect again . it works for me .
everytime i have to open and close my lid 2 to 3 times then it works.

hope this help u guys.
n4wbie is offline   0 Reply With Quote
Old Sep 11, 2012, 10:41 AM   #37
CIU
macrumors newbie
 
Join Date: Sep 2012
My solution

I had the same problem and just solved by going into Keychain Access and deleting the key for the network, then deleting the network from Network Preferences, turning WiFi off and on and joining again. It did the trick for now...
CIU is offline   0 Reply With Quote
Old Sep 12, 2012, 11:43 AM   #38
tom.brekke
macrumors newbie
 
Join Date: Sep 2012
same problem, resetting the keychain worked.

Quote:
Originally Posted by nyeates1 View Post
Image

The problem for many of you is likely a corrupt entry in your keychain. To fix this, open up "Keychain Access" (in "Applications/Utilities") and search for the entry which matchs the name of your wifi network. Then, select all the matching entries (there were two in my case) and delete them.

See this discussion for more details: https://discussions.apple.com/thread/3244298
Just to throw in my two cents: I run Lion and I was having the same problem ("Could not join <name>, a connection timeout occurred"). The only problem was that it was the university's wifi so I don't have access to the router to play with it's settings (which also means that it was probably a problem with my computer as no one else was complaining about the wifi on campus) the above worked like a charm. Thanks!
tom.brekke is offline   0 Reply With Quote
Old Sep 25, 2012, 05:47 PM   #39
sbb1909
macrumors newbie
 
Join Date: Sep 2012
Real solution?

Hi all,

All the options I found so far were... working for a while... but not the solution.

It seems that Lion and ML does basically change the Kext (driver) of our wifi card...
so to put it back here is the solution I used and that is working.
http://www.youtube.com/watch?v=1Iy5lRgVjYM

enjoy and let me know if it works
sbb1909 is offline   0 Reply With Quote
Old Nov 6, 2012, 08:39 AM   #40
dra3b
macrumors newbie
 
Join Date: Jun 2009
Quote:
Originally Posted by PaddyLock View Post
Hi, I had a similar problem as the original post of this thread. The solution which I found, and was the only one that worked for me is to follow these steps:

firstly remove the wifi connection from your list: Apple menu -> System Preferences -> Network -> Wi-Fi -> Advanced highlight your wifi connection and click minus symbol.

then type the ip address for your router in a browser and THIS IS THE IMPORTANT BIT, Change the name of your Wi-Fi connection.

Then follow the first step above and add a new Wi-Fi connection using the new name.

Then you can connect to Wi-Fi again, happy days!

Hope this helps someone else out.

Patrick

THIS WORKED ... I had the original problem "Connection timed out" ... and this ACTUALLY WORKED

Thanks
dra3b is offline   0 Reply With Quote
Old Dec 18, 2012, 08:01 AM   #41
domkane
macrumors newbie
 
Join Date: Feb 2009
Personally, my fix each time has been to access the router admin from a connected device (192.168.0.1) and then change the "Mode" from "54g Auto" to either "54g Performance" or "802.11b Only".

Doesn't seem to matter which one I change from/to, but each time I do that, my Mac connects easily.
domkane is offline   0 Reply With Quote
Old Dec 18, 2012, 08:20 AM   #42
majkom
macrumors 6502a
 
Join Date: May 2011
only solution to all wifi problems is Mountain Lion... go for it
majkom is offline   0 Reply With Quote
Old Jan 7, 2013, 09:10 PM   #43
ima-zfan
macrumors newbie
 
Join Date: Jan 2013
Lion Wifi Connection Timeout.

After a very frustrating 48 hours trying to overcome the "Connection timeout." failure to connect to our network, and a fruitless visit to the local Apple Store, I have finally fixed our problem by re-setting the Airport Extreme. I followed the online instructions (accessed via our Mobile Broadband that we use when travelling) and unplugged the power, pushed a paper clip into the re-set button, and held it down while the power was reconnected and the light started flashing. I don't know whether the fix will last, but all four of our Macs are now back on line via the network.

Hope this will help someone.
ima-zfan is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > iMac

Tags
connection, imac, lion, timeout, wifi

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
MBA 2014, Wifi connection timeout ReelAction MacBook Air 0 May 19, 2014 10:33 PM
Wifi Connection Timeout dankfire Mac Basics and Help 1 May 12, 2013 10:23 PM
Wifi connection timeout issue Serban iMac 5 Apr 16, 2013 03:35 AM
Connection timeout on wifi Maggot FF Mac Peripherals 0 Jan 29, 2013 09:46 PM
Wifi connection Timeout ReservedName Mac Basics and Help 0 Jun 29, 2012 06:29 PM

Forum Jump

All times are GMT -5. The time now is 06:35 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC