Go Back   MacRumors Forums > Special Interests > Visual Media > Design and Graphics

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 8, 2010, 01:41 PM   #26
design-is
macrumors 65816
 
design-is's Avatar
 
Join Date: Oct 2007
Location: London / U.K.
Quote:
Originally Posted by jag-mac-2010 View Post
It must be some Flash based bug (ironically) that is screwing up Illustrator.

So if you have this trouble, it too and your not using firefox, just try closing out of all of your open web pages, no matter what browser.
Strangely I always guessed (without putting any thought into it) that it was a JavaScript issue... But I think your theory is far more likely.
__________________
design-is.co.uk - freelance projects
dougbarned.co.uk - personal site & blog - twitter
feralinteractive.com - designer day job - twitter
design-is is offline   1 Reply With Quote
Old Jan 14, 2011, 04:50 PM   #27
spillahcrown
macrumors newbie
 
Join Date: Feb 2009
I had the same problem in CS5. All my quick keys stopped functioning. I read this thread, quit firefox and Illustrator started to work again.

Very strange.
spillahcrown is offline   0 Reply With Quote
Old Jan 17, 2011, 03:05 PM   #28
Wee Beastie
macrumors regular
 
Join Date: Aug 2007
Location: In the snow with Rosebud
This has been bugging me for a really long time. I just ignore it mostly, but then I randomly find myself super annoyed by it (like right now). I too find that it happens with both Chrome and Firefox.

I am finding a tentative connection with logging in to various things, like Basecamp for instance. If I fire up Illustrator and I'm already logged in using Chrome, keys disabled. Log out, close down browser and problem solved. I can then open Chrome and log back in and work normally. I could be mistaken about the connection, but that's been my feeling for a long time.

Also I think the above solution works more consistently with Chrome than FF. I have been using Chrome more and more for both work and casual browsing.

It's silly but damn is it annoying. Big shame that it persists in CS5. Can I get a big WTF?
__________________
iMac 2.8 24"
MBP 2.4 i5 15" AG
Wee Beastie is offline   0 Reply With Quote
Old Feb 2, 2011, 06:38 PM   #29
mmcvicar
macrumors newbie
 
Join Date: Feb 2011
RealPlayer Downloader

I was having the same issue with the space bar shortcut not working in Illustrator CS4 and I used Activity Monitor to quit the program "RealPlayer Downloader". That fixed the problem once I restarted Illustrator, but I haven't been able to recreate that issue, so it might just be general interference from other applications that causes this problem. Good Luck!
mmcvicar is offline   0 Reply With Quote
Old Feb 3, 2011, 05:17 AM   #30
autacraft
Guest
 
For Future Reference

I cant remember the past bugs of CS3/4 or if they had this functionality, but on CS5 you can check the status of keyboard commands and shortcuts but going to your file bar then EDIT....KEYBOARD SHORTCUTS.

This will display a complete list of assigned (either default or set) tools and menu command shortcuts - you can also re-set to default.

I'm posting this, because if previous versions do have that function its a good way to accertain if its a fault within Illustrator or an other app conflict i.e - if illustrator shows that you have 'spacebar' enabled for dragging and it isnt working, then chances are its conflicting with another app, if it displays that spacebar isnt assigned for dragging, assign it again and see what happens!

Cheers
  0 Reply With Quote
Old Feb 23, 2011, 05:31 AM   #31
lennoxcs
macrumors newbie
 
Join Date: Feb 2011
firefox

As soon as i quit firefox, everything worked again!
lennoxcs is offline   0 Reply With Quote
Old Mar 2, 2011, 04:40 PM   #32
markd61
macrumors newbie
 
Join Date: Mar 2011
Thank you Jag-Mac-2010!

Yeah this is an older thread but it has the answer.

That is exactly what was causing my problem in Photoshop CS5.

I had switched to Chrome and I did have a couple of windows open. Closing them but not quitting Chrome solved the problem.
markd61 is offline   0 Reply With Quote
Old Mar 30, 2011, 03:48 PM   #33
droon
macrumors newbie
 
Join Date: Oct 2007
Same here with illustrator cs5 and the new firefox 4.
I quit firefox and fixed it was.

It has to be something in osx that's set up stupidly.
droon is offline   0 Reply With Quote
Old Sep 6, 2011, 05:34 PM   #34
ladySubrosa
macrumors newbie
 
Join Date: Sep 2011
I am just coming in here to confirm that it has to be some kind of website related thing. Closing Basecamp specifically fixed this issue for me. So, for someone else it was Mint.com. Be mindful of websites like that that may use flash or javascript in a way that overrides your keyboard function.
ladySubrosa is offline   0 Reply With Quote
Old Sep 20, 2011, 02:59 PM   #35
slazareth
macrumors regular
 
Join Date: Feb 2006
For me it was youtube.com causing the issue. Regardless of site I'm pretty sure this is a flash issue. My guess is that it happens mostly with flash video as flash video usually has a keyboard shortcut of spacebar to play/pause video.
slazareth is offline   0 Reply With Quote
Old Oct 3, 2011, 08:02 PM   #36
MacPhyle
macrumors newbie
 
Join Date: Jul 2003
Location: Sequim, WA
Send a message via AIM to MacPhyle
Quote:
Originally Posted by DennyMcEntire View Post
I was having the same issue. VERY frustrating. After reading this thread I noticed that I, too had Firefox opened (same as ox4dboy). So I quit firefox and my keyboard shortcuts were back! Seems like a pretty obscure bug.
It was Google Chrome for me, but thanks for the info - relaunching Chrome did the trick!
__________________
Beth
graphic designer
MacPhyle is offline   0 Reply With Quote
Old Oct 10, 2011, 07:35 AM   #37
oNo
macrumors newbie
 
Join Date: Oct 2011
Location: Germany
screensharing/vcn/applejack

For me, messing with the 'Screensharing' caused the whole issue. Running 'Applejack' solved it.
Thx for all the input
oNo is offline   0 Reply With Quote
Old Oct 28, 2011, 10:32 AM   #38
xocasil
macrumors newbie
 
Join Date: Oct 2011
Quote:
Originally Posted by DennyMcEntire View Post
I was having the same issue. VERY frustrating. After reading this thread I noticed that I, too had Firefox opened (same as ox4dboy). So I quit firefox and my keyboard shortcuts were back! Seems like a pretty obscure bug.
When I closed out FireFox, everything started working again.
xocasil is offline   0 Reply With Quote
Old Nov 20, 2011, 09:06 AM   #39
anthonycollini
macrumors newbie
 
Join Date: Nov 2011
Quit Firefox

Quitting firefox fixed the issue for me.
anthonycollini is offline   0 Reply With Quote
Old Nov 25, 2011, 10:12 AM   #40
will-s-t
macrumors newbie
 
Join Date: Nov 2011
Quitting Word worked for me. Evil program...
will-s-t is offline   0 Reply With Quote
Old Feb 8, 2012, 06:23 AM   #41
kemo
macrumors 6502a
 
kemo's Avatar
 
Join Date: Oct 2008
Location: /Users/kemo
weird, quitting Chrome did the trick for me, does it use some shared components... ?
__________________
~ http://tehkemo.com
~ AKG k701 + Nuforce Icon HDP
kemo is offline   0 Reply With Quote
Old Oct 17, 2012, 07:00 PM   #42
ivnbrv
macrumors newbie
 
Join Date: Feb 2011
Had the same issue... just trashed plist cntr+opt+cmmd and disabled spotlight... thats it... it work'd

Thanks mates!
ivnbrv is offline   0 Reply With Quote
Old Nov 11, 2012, 10:12 PM   #43
monsieurmorris
macrumors newbie
 
Join Date: Nov 2012
Turning off fonts kills this bug

Seems if you have too many fonts activated this bug pops up now and then. An easy fix is to disable a bunch and try again.
monsieurmorris is offline   0 Reply With Quote
Old Jan 17, 2013, 01:27 AM   #44
mckinleymedia
macrumors newbie
 
Join Date: Jan 2013
Same issue for me - fixed by closing Chrome

I had to force quit Chrome. Immediately Illustrator started working again. I've never had this issue before and am in Illustrator every day.
mckinleymedia is offline   0 Reply With Quote
Old May 21, 2013, 11:02 AM   #45
mattbepler
macrumors newbie
 
Join Date: May 2013
web-related, likely Flash

All the other fixes... trash Ai prefs, quit Word, quit Firefox didn't work for me. All I had open was Safari, and a few sites. Quit Safari, keys worked immediately. I agree with post that said likely flash... like YouTube or other sites. I have Not tested that all the way out, but that seems like it. And yes, Ironic... Adobe, and flash... conflict?
mattbepler is offline   0 Reply With Quote
Old May 28, 2013, 04:30 AM   #46
thepitcanary
macrumors newbie
 
Join Date: Jan 2009
Quote:
Originally Posted by mckinleymedia View Post
I had to force quit Chrome. Immediately Illustrator started working again. I've never had this issue before and am in Illustrator every day.
I've just had the select tool alt functions - hand / zoom / scale functionality - die in InDesign 5.5.

I checked that Spotlight wasn't hijacking it (it does that) in keyboard shortcuts then killed Chrome (lots of windows open, though not as many as 31!) as recommended and instantly bam, those alt functions are back. So whatever it is, yeah there's obviously some random browser/flash hijacking going on.

thanks for the help, MR people!
thepitcanary is offline   0 Reply With Quote
Old Aug 13, 2013, 01:38 PM   #47
tduane62
macrumors newbie
 
Join Date: Aug 2013
I have the answer to how to avoid disabling the spacebar hand tool shortcut

If you use COMMAND-H to hide a window while any Adobe software is running, it disables the spacebar hand tool shortcut. I've tried every other solution and this is the only one that has worked for the past four weeks. So do NOT use COMMAND-H to hide windows. If you do so, and disable the shortcut, the only way to get it working again is to re-start your machine.
tduane62 is offline   0 Reply With Quote
Old Aug 16, 2013, 08:15 PM   #48
anteanterior
macrumors newbie
 
Join Date: Nov 2009
Adobe vs. Flash

Whaaaaaat? This is the weirdest bug I've seen in quite a while. Now on os 10.8.4, yet still with CS4, and this thing persists.
And yes, quitting Safari (with an open youtube window) solved it.

m
anteanterior is offline   0 Reply With Quote
Old Aug 23, 2013, 12:38 PM   #49
Äpfelchen
macrumors newbie
 
Join Date: Aug 2013
CS 5 here, same problem.
I confirm that the app-closing trick worked for me.

Closing the application 1Password did it for me. I couldn’t reproduce the problem though. I agree that this might be coincidence and that 1Password might not be the actual culprit.

Thanks so much to all of you for your suggestions!
Äpfelchen is offline   0 Reply With Quote
Old Jun 2, 2014, 01:03 PM   #50
jimmy2names
macrumors newbie
 
Join Date: Jun 2014
Finally after trying everything, I got it sorted!

Hi All,

Thanks for all your posts about possible processes and apps etc stopping the space bar from using the hand tool.

I have webroot anti-virus (used to be prevx) I closed it down and straight away the hand tool was back. I opened it again and no hand tool. I went in to the settings and there was a setting under 'Realtime Shield' with a tick in the box for 'Secure keyboard entry mode' I took the tick out and everything is fine in Photoshop once again. I even have Chrome open with the webroot password manager plugin running with no problems. It was just that secure keyboard entry bugger messing things up. I assume other anti-virus programs might have something similar. It's worth a go if nothing else has worked. I guess this should sort other Adobe products with the same feature. Now I can re-install all the programs I took off trying to sort this out!

Good luck, I hope this helps some of you.

All the best,

Jimmy
jimmy2names is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Visual Media > Design and Graphics

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Lost ability to copy and paste or drag HELP theresa b thoma MacBook Pro 1 Jan 3, 2014 04:31 PM
Command + C copy function not working after downloading Mavericks UNIR OS X Mavericks (10.9) 3 Oct 25, 2013 01:10 PM
command+option+esc problem? yvonnars MacBook Pro 4 May 14, 2013 11:39 PM
Illustrator CS6 Help via Command-Shift-/ nuke557 Design and Graphics 0 Oct 23, 2012 10:35 PM
Disable Alt/Option Click and Drag Window DJAKO Mac Basics and Help 0 Aug 16, 2012 12:44 PM

Forum Jump

All times are GMT -5. The time now is 09:38 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC