Go Back   MacRumors Forums > iPhone, iPod and iPad > iPad > iPad Tips, Help and Troubleshooting

Thread Tools Search this Thread Display Modes
Old Jul 29, 2012, 09:23 AM   #1
macrumors 6502
Join Date: Dec 2008
Unable to establish a secure connection to iTunes

Ever since wiping my harddrive and doing a clean install of Mountain Lion, I cannot get iTunes to connect to my jailbroken iPad. Whenever I plug it in, it says:

"iTunes could not connect to this iPad. Could not establish a secure connection to the device."

My jailbroken iPhone worked perfectly fine. Any ideas on how to fix this? I haven't found too much on the web about this.
Sdevante is offline   0 Reply With Quote
Old Jul 30, 2012, 06:40 PM   #2
Thread Starter
macrumors 6502
Join Date: Dec 2008

The iPad has also stopped working with Diskaid, which gives an error message about the iPad having a Passcode preventing it from connecting.

Except, I never have had password protection on the iPad.
Sdevante is offline   0 Reply With Quote
Old Aug 4, 2012, 04:12 AM   #3
macrumors newbie
Join Date: Jul 2012
I have exactly the same problem. Just received my new Macbook Pro, fresh Mountain Lion install and my Ipad 3 (jailbreaked) receive the same error message.

Itunes 10.6.3
Ios 5.1.1 Jailbreaked with absinthe

But my Jailbreaked Iphone 3GS Ios 5.1.1 + Absinthe is working great with this Itunes.
mbpmbpmbp is offline   0 Reply With Quote
Old Aug 13, 2012, 04:28 PM   #4
macrumors 6502a
Join Date: May 2008
Hope you guys are still watching this thread. SOLVED.

Here's what you have to do. You need a backup of your old Mac prior to upgrading, or prior to wiping and reinstalling.

You need to open Console on your new mac, and see the error message when you plug your phone into itunes and get that error, this will show up in your console:

8/13/12 1:21:04.537 PM iTunes[491]: AMDeviceValidatePairing (thread 0x11c313000): Could not load pairing record /var/db/lockdown//<device id>.plist

Then you need to go to your time machine backup and navigate to that same folder, and find the missing file. Copy that file back to your new machine into the /var/db/lockdown and you will magically be able to access your device again.

Happy hunting! AND ALWAYS BACK UP YOUR SYSTEM. ALWAYS. Time Machine is a god send, and so easy to use why wouldn't people do it?
djrobsd is offline   0 Reply With Quote
Old Nov 20, 2012, 03:05 AM   #5
macrumors regular
Join Date: May 2012
Location: Copenhagen, Denmark
Same problem here with my iPhone 4. Unfortunately my old mac is dead and my time machine backup used to be done at my old place of work, which I can no-longer access.

Is there any solution to do this without a backup?

Alternatively, I've managed to extract all my music from the phone and other stuff (like contacts, etc.) are stored on my iCloud. Is there any way of backing up my apps and sms', then do a clean install?

icebergx is offline   0 Reply With Quote
Old Nov 22, 2012, 12:06 PM   #6
macrumors newbie
Join Date: Nov 2012
I have the same issue, but in my situation I am going from PC to a MAC. I have OSX 10.8.2 and my iphone connected just fine, but my iPad 3 cannot connect because of the secure connection to the device. It will sync to my PC just fine, but I cannot get it to sync to my mac which is now my current updated laptop that holds everything and that I want to WiFi sync to.

Any solution to this?
manolodf is offline   1 Reply With Quote

MacRumors Forums > iPhone, iPod and iPad > iPad > iPad Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Safari can't establish secure connection Steelseries MacBook Air 8 Oct 12, 2013 02:21 AM
Safari 6 OS 10.8 - Can't establish a secure connection lentife OS X 10.8 Mountain Lion 14 Aug 23, 2013 04:20 PM
Unable to establish an Internet connection jdmdelsol97 MacBook 1 Jul 16, 2013 10:37 AM
Latest OS Update: Safari can't establish a secure connection with accounts.google.com Kankki OS X 10.8 Mountain Lion 2 Sep 9, 2012 02:22 AM
Can't establish a secure connection. GRMCKR OS X 10.8 Mountain Lion 5 Jul 28, 2012 07:55 AM

Forum Jump

All times are GMT -5. The time now is 04:33 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2015, MacRumors.com, LLC