Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPod touch

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old Nov 22, 2012, 02:18 PM   #1
Jibbajabba
macrumors 6502a
 
Join Date: Aug 2011
Found my 1st Gen Touch ..... Damn slow ...

....and it is either useless or I am just used to quicker devices. Thought I lost it when moving country but found it today. Restored it (3.1.3) and synced some music onto it - nothing else (apps or movies) and the thing is rotten slow.

The touchscreen is slow, opening 'iPod' takes half a minute to display and JB brings it down to such slow crawl that it is unusable.

Battery is great funnily enough - third day on the table and sits at 75% (granted - no use at all).

Not really a question but more likely an observation - whatever it is, the thing seems to degrade over time. I'd understand it by constant use, similar to constant writes on SSDs, but with no use at all, it seems odd that it becomes unusable. I had it two years ago and it was fine.

R.I.P I guess ....
Jibbajabba is offline   1 Reply With Quote

 
MacRumors Forums > iPhone, iPod and iPad > iPod touch

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:38 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC