Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 23, 2012, 10:35 PM   #1
Garthilk
macrumors newbie
 
Join Date: Nov 2012
Loading Forever Does Not Play / Will Airplay

So, the issue is that whenever I select a movie or TV show from my Itunes Homeshared hard drive. I get the black screen and the spinning circle indicating it's loading. And nothing happens. Just sits and spins forever.

However, if I'm on my computer in iTunes playing a movie and I change the destination to my Apple TV it loads up and starts playing under 5 seconds.
Garthilk is offline   1 Reply With Quote
Old Nov 24, 2012, 12:05 AM   #2
capt601
macrumors member
 
Join Date: Jun 2008
Mine does the same thing except sending to apple tv from computer it still freezes after a couple of minutes playing the movie. So either way it doesn't work.
capt601 is offline   0 Reply With Quote
Old Nov 24, 2012, 08:24 AM   #3
mic j
macrumors 68000
 
Join Date: Mar 2012
Could be:
1) weak wifi network (router using "g" or "n"?)
2) if using mkv as source file, may need ethernet connection to aTV
3) if mp4, may benefit from being "optimized" either in Subler or Handbrake

More info on your home connection format and file type would be helpful.
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Nov 24, 2012, 11:43 AM   #4
capt601
macrumors member
 
Join Date: Jun 2008
Quote:
Originally Posted by mic j View Post
Could be:
1) weak wifi network (router using "g" or "n"?)
2) if using mkv as source file, may need ethernet connection to aTV
3) if mp4, may benefit from being "optimized" either in Subler or Handbrake

More info on your home connection format and file type would be helpful.
Not weak network,
Other movies have worked before and no issues. This happened after last apple tv update, and iTunes update. Have been reading about others having problems after last iTunes update.
All movies done through handbrake apple tv3 setting. Also iPad setting does same thing.
capt601 is offline   0 Reply With Quote
Old Nov 24, 2012, 11:53 AM   #5
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by capt601 View Post
Not weak network,
Other movies have worked before and no issues. This happened after last apple tv update, and iTunes update. Have been reading about others having problems after last iTunes update.
All movies done through handbrake apple tv3 setting. Also iPad setting does same thing.
Well, you seemed to have all the bases covered! Just as a shot, do you have HB web optimize the files? If not, you can take one that has been transcoded and optimize it with Subler. Yes, it's probably update related but for 5 minutes worth of work, it would be interesting to see if optimization helps. I have done both the aTV and iTunes updates and everything has been running fine.
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Nov 24, 2012, 09:31 PM   #6
Garthilk
Thread Starter
macrumors newbie
 
Join Date: Nov 2012
Well, if I hit play from the apple tv it loads forever.

If I hit play in Itunes and tell it to play on Apple TV it doesn't take longer than 3 seconds to load using the same wired connection.

So it's not a wifi issue.
Garthilk is offline   0 Reply With Quote
Old Nov 24, 2012, 11:07 PM   #7
capt601
macrumors member
 
Join Date: Jun 2008
I just spent some time downgrading from the lates apple tv update 5.1 To 5.0.2,
And iTunes from 10.7 to 10.6.3. And didn't appear to be a difference after the 5.1 to 5.0.2 apple tv update. But after downgrading to 10.6.3 everything has worked normal again, so far.
I have read many other reports of people having to do the same thing and it working for them. It was a pain to do the iTunes downgrade but it worked in the long run.
capt601 is offline   0 Reply With Quote
Old Nov 25, 2012, 02:08 PM   #8
Menneisyys2
macrumors 601
 
Join Date: Jun 2011
Quote:
Originally Posted by mic j View Post
Well, you seemed to have all the bases covered! Just as a shot, do you have HB web optimize the files? If not, you can take one that has been transcoded and optimize it with Subler.
BTW, my optimization tutorial (along with tons of other goodies) is at http://forums.macrumors.com/showthread.php?p=16361320
Menneisyys2 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:58 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC