Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 28, 2012, 06:17 PM   #1
gizmotek
macrumors newbie
 
Join Date: Nov 2012
Location: Denver
Hidden Network Share

Hello all, first time posting.
I'm having an odd issue with my server. I have a Mac with OSX 10.8.2 Server installed, that shares a RAID drive via AFP to a couple other macs. It's worked flawlessly for the last few months, until a couple days ago. I rebooted the server, and the shared drive was no longer on the desktop or in the finder sidebar! I immediately freaked out, and went to the disk utility. Sure enough, it was there and mounted. I checked the server's finder preferences, and nothing changed there either. I looked in the /Volumes folder, and no drive.
But, here comes the interesting part. If I specifically go to /Volumes/MyDrive using 'Go to Folder', it shows up! But it is grayed out, like a hidden file (like the home library folder is).

What's more, the same thing happens when you mount the drive from another computer, it shows up as hidden. Which means no icon on the desktop or in the sidebar for the networked computers either.

Any thoughts on what I might have done to create this problem? I'm at a loss.
Attached Images
 
gizmotek is offline   0 Reply With Quote
Old Nov 28, 2012, 09:40 PM   #2
motorboating
macrumors newbie
 
Join Date: Nov 2012
Using terminal, can you inspect the directory under /Volumes at all?
motorboating is offline   0 Reply With Quote
Old Nov 29, 2012, 01:28 AM   #3
gizmotek
Thread Starter
macrumors newbie
 
Join Date: Nov 2012
Location: Denver
Just checked, I can get in the volume using Terminal too, with everything visible.
It's just Finder that refuses to see it, all other programs (Disk Utility, Terminal, even recent documents in Word) can see the volume just fine. It's bizarre.
gizmotek is offline   0 Reply With Quote
Old Nov 29, 2012, 08:43 AM   #4
switon
macrumors 6502a
 
Join Date: Sep 2012
RE: Finder...

Hi gizmotek,

Have you killed the Finder? I would start by killing all Finders from the Terminal:

killall Finder

This should kill all Finders and restart them. You should notice that all of your desktop disk icons should disappear momentarily and then reappear. Does the "hidden" drive now appear? If not, then I would check the permissions on the problem drive. Do you have read and write access? If you do, then the next thing I would do is to reboot both machines and the RAID drive: first reboot the RAID drive, then the machine that shares the RAID drive, then lastly your computer. It is possible that your server has fouled up its AFP service and thus rebooting may fix this.

Let us know what happens.

Regards,
Switon
switon is offline   0 Reply With Quote
Old Nov 29, 2012, 11:29 AM   #5
gizmotek
Thread Starter
macrumors newbie
 
Join Date: Nov 2012
Location: Denver
I've restarted a few times now to see if I could resolve it, and reinstalled the RAID drivers without any change. I'm beginning to think if it's permission related too. I tested sharing a subfolder on the SAN, and it shows up normally to the client computers. Is there an easy way to reset permissions on a volume via a terminal command?
gizmotek is offline   0 Reply With Quote
Old Nov 29, 2012, 04:27 PM   #6
switon
macrumors 6502a
 
Join Date: Sep 2012
RE: chmod, chown, etc...

Hi,

Yes, you can use chmod and chown to reset the owner, group, and permissions. If you use the -R option, then the permissions are recursively propagated down the subdirectory hierarchy. See the man pages for these commands for further information. Be careful that you do the right thing before proceeding. An example of the type of commands you will use is:

chmod -R ug+rw .[A-z]*
chmod -R ug+rw [A-z]*

The first command is required since all files that begin with a dot (.) will not be picked up by a simple star (*) wildcard under the bash shell, thus you must specify them with a separate command.

There are also finer-grained ACL permissions commands too.

Good luck,
Switon

P.S. Just to let you know, you can also get Mac OS X Server to alter the permissions for you from the File Sharing pane of the Server.app. If you use this method, be careful to wait long enough before killing the Server.app for it to finish changing all of the permissions throughout the entire volume's directory hierarchy --- this can take quite a long time.

Last edited by switon; Nov 29, 2012 at 04:50 PM. Reason: Added P.S.
switon is offline   0 Reply With Quote
Old Dec 3, 2012, 09:09 AM   #7
gizmotek
Thread Starter
macrumors newbie
 
Join Date: Nov 2012
Location: Denver
Well now I'm feeling sheepish. I figured out the problem, and I only had to look up hidden file attributes. Thanks to this thread:
http://forums.macrumors.com/showthread.php?t=843620
I just ran that on /Volumes/MyVolume, and voila! Everything appears to be working great now. Not sure how the hidden flag got put on my volume, but there it is. Thanks for working through this with me!
gizmotek is offline   1 Reply With Quote
Old Dec 3, 2012, 09:34 AM   #8
mwhities
macrumors 6502a
 
Join Date: Jul 2011
Location: Mississippi
Send a message via AIM to mwhities Send a message via MSN to mwhities
Quote:
Originally Posted by gizmotek View Post
Well now I'm feeling sheepish. I figured out the problem, and I only had to look up hidden file attributes. Thanks to this thread:
http://forums.macrumors.com/showthread.php?t=843620
I just ran that on /Volumes/MyVolume, and voila! Everything appears to be working great now. Not sure how the hidden flag got put on my volume, but there it is. Thanks for working through this with me!
Thanks for posting a fix for it. I like to read these and I save the info in my lil 'notes.
__________________
Late '11 MBP 17" - Blue Nano 8G - Black 4S 16G/64G - Black iPad2 16G - Black iPad mini 16G - 2TB TC
mwhities is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Problem with mounting a network share Scottland OS X 0 Aug 10, 2013 02:02 AM
General: Network share file browser? Dorkington Jailbreaks and iOS Hacks 1 Jun 30, 2013 08:48 AM
Network Share Monitor damato300 Mac OS X 10.7 Lion 0 Nov 4, 2012 07:54 PM
Creating hidden Ad-Hoc network Inspiratron OS X 10.8 Mountain Lion 3 Sep 1, 2012 05:29 AM
2 Music Folders On Network Share Ope OS X 10.8 Mountain Lion 4 Aug 14, 2012 04:27 PM

Forum Jump

All times are GMT -5. The time now is 11:23 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC