Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 11, 2008, 06:58 PM   #1
thedragonb
macrumors newbie
 
Join Date: Nov 2008
Mac OS 10.5.5's Disk Utility formatting Ext. HD differently from 10.4?.

Mac OS 10.5.5 Disk Utility not formatting Ext. HD properly.

I was originally able to use my external Hard drive Seagate 300GB right out the box without formatting on my Phillips DIVX-compatible DVD players as well as my Sony PS3 to watch .AVI and MPG files on TV.

Well, last night I needed to swap some files via Time Machine and had to re-formatted my Ext HD. So once that is done I go to format back with Mac OS 10.5.5's Disk Utility, but this time using the MS-DOS (FAT32) option since that is how it will work with the DVD players and PS3. But the drive wasn't recognizable with either DVD players or Sony PS3.

Now here's the kicker! I had my old iBook with Mac OS 10.4 and decided to format the drive using it's Disk Utility version and now the drive is recognizable on both DVD players and PS3.

Obviously something is different with the latest version of Disk Utility on Mac OS 10.5.5! Does anyone know why Leopard Mac OS's Disk Utility is formatting differently than previous versions of Mac OS? What's the deal here?

Good thing I didn't give away my old iBook... Is this an Apple conflict or ???
thedragonb is offline   0 Reply With Quote
Old Nov 11, 2008, 10:01 PM   #2
NoSmokingBandit
macrumors 68000
 
NoSmokingBandit's Avatar
 
Join Date: Apr 2008
Are you just formatting it or are you repartitioning it? Iirc, PPC-based macs partition with a different partition map than intel macs.
NoSmokingBandit is offline   0 Reply With Quote
Old Nov 11, 2008, 10:26 PM   #3
sickmacdoc
macrumors 68020
 
sickmacdoc's Avatar
 
Join Date: Jun 2008
Location: New Hampshire
I feel sure that NoSmokingBandit's take on it is exactly right.

Leopard's Disk Utility offers three types of Partition Map Schemes: APM (Apple Partition Map- bootable on PPC Macs), GUID Partition Table (bootable on Intel Macs) and MBR (Master Boot Record (as it would be formatted from a Windows machine, and often the partition map that comes on new drives).

You can see what your drive is currently by selecting the drive in the left column of Disk Utility and looking at the info at the bottom of the page. Look at the "Partition Map Scheme:" entry for the answer.

To make it work almost surely, the drive could be redone to simulate a new drive prepared for PC use as most new ones are by going into the Partition part of Disk Utility and setting the Partition Scheme to "Master Boot Record" (using the "Options" button at the bottom) and the format type to "MS-DOS (FAT)" as Apple calls FAT32.

Other combos may work (MS-DOS (FAT) and APM partition scheme come to mind) but the previous combo should pretty much guarantee it.
sickmacdoc is offline   0 Reply With Quote
Old Nov 15, 2008, 08:58 AM   #4
thedragonb
Thread Starter
macrumors newbie
 
Join Date: Nov 2008
Thanks for the feed back everyone!

I was formatting the entire drive. No partioning using the ERASE tab and MS-DOS option. There is no option to make it a Master Boot Record to make it bootable or compatible with MS-DOS format. It would be completely unrecognizable on my DVD pleyers and PS3.

Yet, when trying to create a partition I didn't see about the OPTION button and have the option to partition with MS-DOS(FAT32) until you guys alerted me to it. It was right there all along at the bottom. NOW I see how I can partition for part MS-DOS and part MAC - I'll need to try that Master Boot Record option and see if that corrects my problem.

Thanks for the heads up.. I will try it out on my external drive and see if it works.
thedragonb is offline   0 Reply With Quote
Old Nov 15, 2008, 09:21 AM   #5
brkirch
macrumors regular
 
Join Date: Oct 2001
You probably accidently selected the partition when you actually wanted to format the whole disk; that would explain why reformatting didn't change the partition map to MBR (IIRC, reformatting the whole disk with FAT32 defaults the partition map to MBR).
brkirch is offline   0 Reply With Quote
Old Nov 15, 2008, 10:40 AM   #6
sickmacdoc
macrumors 68020
 
sickmacdoc's Avatar
 
Join Date: Jun 2008
Location: New Hampshire
Just be aware that the partition map scheme (the MBR, APM or GUID) applies to the whole disk, not single partitions- only one per physical hard drive.

The format (MS-DOS (FAT), Mac OS Extended (Journaled), etc.) can be applied on an individual partition by partition basis.
sickmacdoc is offline   0 Reply With Quote
Old Dec 7, 2012, 07:32 PM   #7
tjthom
macrumors newbie
 
Join Date: Dec 2012
I need to start from fresh!

Hi everyone,

Sorry to reopen this, but I've been having issues reformatting my external hard drive for several days. Everything I have found has been related to fixing the drive that Mac is installed on, which is not what my issue is.

The story:
I had this external hard drive that I was occasionally making Time Machine back-ups to. Then I did the following and screwed it up...
  • created a second partition on the device
  • used Time Machine to encrypt the first and second partitions
  • (this then created what appered to be two separate devices in the list; obviously not the case)
  • Tried to delete the second partition that I made to go back to what I originally had

Now I have this mess (see attached picture.)

At this point there is zero data on any of the partitions. I've "erased" each partition several times and tried reformatting them to different types of systems (Mac, ExFAT, etc.) But overall... I cannot merge them to start over for the life of me.

If I click the top level device, the ONLY two tabs that are listed are "First Aid" and "Partition"

When I click on the "Partition" tab, the button below that says "Options" is grayed out and I cannot click it. The only thing that is available is the "minus" sign for only ONE of the partitions (the first one.) And when I click it, the pictured error is what I get.

LONG STORY SHORT....
I THINK if I am able to reformat the MBR on the external hard-drive, that it will fix it enough to the point where I can delete partitions. I'm just struggling to figure out how to redo the MBR. ADDITIONALLY: when I click on the device, the info at the bottom doesn't even list "Partition Map Scheme" which leads me to believe it's really messed up.

Can anyone help?

I'm using Mac 10.8.2 if it helps. Thanks!
Attached Thumbnails
Click image for larger version

Name:	Unable to Erase Disk.jpg
Views:	22
Size:	321.1 KB
ID:	382205  
tjthom is offline   0 Reply With Quote
Old Dec 7, 2012, 07:45 PM   #8
tjthom
macrumors newbie
 
Join Date: Dec 2012
Nevermind!!!!

I tried one last search for "Logical Volume Group" and after a few links got this....

http://www.g8production.com/post/296...-failed-how-to

That definitely helped and all of my other options are now back! FEWWW!!!

Sorry to anyone that got annoyed by this!
tjthom is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Disk Utility stuck around 50% when formatting SSD kuramayoko10 MacBook Pro 12 Feb 17, 2014 10:04 AM
Discrepancy in Available disk space being reported by Disk Utility and Mac HD desktop Attonine OS X 10.8 Mountain Lion 0 Dec 30, 2013 02:54 PM
Formatting Ext HD for PS3? Big Stevie Mac Peripherals 1 Jan 7, 2013 06:05 AM
Lacie minimus usb 3 ext HD wont mount in disk utility, desktop 512maxhealth Mac Basics and Help 2 Jul 16, 2012 07:52 PM
WD Ext HD wont mount but in Disk Utility apatel87 Mac Peripherals 2 Jun 7, 2012 06:42 PM

Forum Jump

All times are GMT -5. The time now is 01:19 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC