Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Mac Peripherals

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 12, 2012, 09:38 AM   #1
baxlobs
macrumors member
 
Join Date: Nov 2012
Location: Suffolk UK
Laserjet 1022 problem

I have been setting up my new iMac, (moved from Windows) I attached my printers today. The Canon ip4600 setup just fine, I was able to download the Canon print utility and it works OK.

The Laserjet however prints one page and then all 3 lights flash and nothing further can be done, switching off and on clears the lights and one more page can be printed.

Any ideas, are there likely to be newer drivers, or is it a problem with Mountain Lion 10.8.2?
baxlobs is offline   0 Reply With Quote
Old Dec 12, 2012, 11:35 AM   #2
apedance
macrumors member
 
Join Date: Sep 2012
Location: Vienna
hey.

strange problem. maybe the issue is the printer itself, not the OS.

i found this.

http://www.justanswer.com/printers/4...-blinking.html

do you get any error messages in the print utility?

do you get any errors when you launch the OS built in "console" ?
apedance is offline   0 Reply With Quote
Old Dec 13, 2012, 04:37 AM   #3
baxlobs
Thread Starter
macrumors member
 
Join Date: Nov 2012
Location: Suffolk UK
Quote:
Originally Posted by apedance View Post
hey.

strange problem. maybe the issue is the printer itself, not the OS.

i found this.

http://www.justanswer.com/printers/4...-blinking.html

do you get any error messages in the print utility?

do you get any errors when you launch the OS built in "console" ?
The printer works fine from Windows, it also printed OK from my wife's iPad via HandyPrint installed on the iMac. I tried again this morning, and it printed one page OK, but when I tried it failed again after printing one page and the first line of the second. Curiously it ejected 3 pages the correct length of the document.

I looked at the link you posted, but they want 35 to 40 depending on "detail" provided.

I have looked in "console" it is pretty confusing for a Mac newbie, I could say a reference to printing, but there did not appear to be an error.

Last edited by baxlobs; Dec 13, 2012 at 04:41 AM. Reason: Added para
baxlobs is offline   0 Reply With Quote
Old Dec 13, 2012, 06:06 AM   #4
apedance
macrumors member
 
Join Date: Sep 2012
Location: Vienna
forget this link.

ok. looks like a driver issue.

i can just tell what i would do with this problem.


Canon Pixma iP4600 right?

(i) what driver are you running?
did mac os x recommended a driver when you plugged in the printer? (i guess it is usb, isn't it?)

(ii) what os x version are you using? (OSX 10.8.2, ...?)

try reinstalling the driver.

also try the driver provided here

never install multiple drivers. always uninstall the old driver before you try a different one.
apedance is offline   0 Reply With Quote
Old Dec 13, 2012, 11:38 AM   #5
baxlobs
Thread Starter
macrumors member
 
Join Date: Nov 2012
Location: Suffolk UK
Quote:
Originally Posted by apedance View Post
forget this link.

ok. looks like a driver issue.

i can just tell what i would do with this problem.


Canon Pixma iP4600 right?

(i) what driver are you running?
did mac os x recommended a driver when you plugged in the printer? (i guess it is usb, isn't it?)

(ii) what os x version are you using? (OSX 10.8.2, ...?)

try reinstalling the driver.

also try the driver provided here

never install multiple drivers. always uninstall the old driver before you try a different one.
Thanks for your reply, the problem is with the Laserjet, not the Canon which works just fine.

I am currently engaged with Apple support to try and resolve this problem, which has turned out to be related to my User, the printer works OK with a different user!
baxlobs is offline   0 Reply With Quote
Old Dec 13, 2012, 12:52 PM   #6
baxlobs
Thread Starter
macrumors member
 
Join Date: Nov 2012
Location: Suffolk UK
Quote:
Originally Posted by baxlobs View Post
Thanks for your reply, the problem is with the Laserjet, not the Canon which works just fine.

I am currently engaged with Apple support to try and resolve this problem, which has turned out to be related to my User, the printer works OK with a different user!
Thanks for all suggestions, as I said in my last post the problem was due to major problems with Users and Keychains. An online session with Apple support has (hopefully) resolved all the issues.
baxlobs is offline   0 Reply With Quote
Old Dec 13, 2012, 03:28 PM   #7
apedance
macrumors member
 
Join Date: Sep 2012
Location: Vienna
Quote:
Originally Posted by baxlobs View Post
Thanks for your reply, the problem is with the Laserjet, not the Canon which works just fine.

I am currently engaged with Apple support to try and resolve this problem, which has turned out to be related to my User, the printer works OK with a different user!
oooooohhhhh.

i thought canon ip4600 is the laserjet because you did not specify the laserjets manufacturer. hahahahaha

anyways. good luck fixing your problem.

cheers
apedance is offline   0 Reply With Quote
Old Dec 18, 2012, 10:57 AM   #8
baxlobs
Thread Starter
macrumors member
 
Join Date: Nov 2012
Location: Suffolk UK
Further to this problem, even though my other problems appear to have been sorted by Apple support, this printer still does not work correctly. There is no duplex option, and it randomly misses pages from documents.

I have installed Windows using Parallels, and looking at the printer there in Control Panel, although it is named "Laserjet 1022" the dialog shows it as a Colorjet series printer with entirely different options.

I deleted this printer and added the Laserjet using the original Windows driver CD. Once setup it now can print duplex, and does not miss out pages. Result

However it is still wrong on the iMac side. I am assuming because the iMac originally misidentified it as a Colorjet and installed the wrong drivers although it gave it the correct name.

I thought if I deleted it in System preferences and reconnected it it might be correctly identified, but nothing happens and I need to Add it back again with new drivers, any idea how I manage to do this?
baxlobs is offline   0 Reply With Quote
Old Dec 19, 2012, 11:57 AM   #9
baxlobs
Thread Starter
macrumors member
 
Join Date: Nov 2012
Location: Suffolk UK
Further update, I found that when I re-booted the iMac the printer was re-installed. However still with the wrong driver. Investigating in XP/Parallels I find that the iMac identifies the Laserjet 1022 as a Colorjet 8500PS with the appropriate options for that printer - presumably.

This would explain why my Laserjet does not work properly.

I have advised someone at Apple support of the problem. I can only hope that an answer can be found. There is obviously something badly wrong with the iMac's HP printer drivers.
baxlobs is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Mac Peripherals

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Which colour laserjet printer for my new Macbook? wotsit Mac Peripherals 7 Feb 21, 2014 03:14 AM
HP Laserjet P1100w driver Mobgr OS X 10.8 Mountain Lion 2 Oct 9, 2013 01:04 PM
No support for scanner on HP laserjet jimbo2112work iMac 0 May 27, 2013 05:37 PM
HP LaserJet 6 MP and Mountain Lion RAMtheSSD Mac Basics and Help 3 Mar 29, 2013 06:00 PM
ipad - how to print with old hp laserjet blackbirdz iPad 6 Aug 6, 2012 08:11 AM

Forum Jump

All times are GMT -5. The time now is 02:02 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC