Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 21, 2012, 12:04 PM   #1
iOrbit
macrumors 6502
 
Join Date: Mar 2012
Handbrake question + Subler

i finally added my library of films to my itunes movies. but i realised while doing the last one today, that while doing all the settings the way i wanted for the visual and subtitle side of things, i have overlooked Audio.

i havent touched the bitrate of audio nor did i realise you could change the mixdown!

i wanted to keep my films 5.1 surround sound as originally were, but iv been encoding these with the Dolby pro logic II mix down.

does this mean i'v lost all the surround sound 5.1 mixes for the films? can i get them back in anyway?
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.
iOrbit is online now   0 Reply With Quote
Old Dec 21, 2012, 12:17 PM   #2
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by iOrbit View Post
i finally added my library of films to my itunes movies. but i realised while doing the last one today, that while doing all the settings the way i wanted for the visual and subtitle side of things, i have overlooked Audio.

i havent touched the bitrate of audio nor did i realise you could change the mixdown!

i wanted to keep my films 5.1 surround sound as originally were, but iv been encoding these with the Dolby pro logic II mix down.

does this mean i'v lost all the surround sound 5.1 mixes for the films? can i get them back in anyway?
Were you using a preset or your own settings?
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Dec 21, 2012, 12:38 PM   #3
iOrbit
Thread Starter
macrumors 6502
 
Join Date: Mar 2012
Quote:
Originally Posted by mic j View Post
Were you using a preset or your own settings?
i customized a preset i think.

i select apple tv 3 preset, and then change some settings, as follows:

set video to strict aspect.

set video quality to 18.5 (differs some times)

set the frame rate to same as source.

subtitles if applicable, i do burned in PGS subs.
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.
iOrbit is online now   0 Reply With Quote
Old Dec 21, 2012, 12:46 PM   #4
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by iOrbit View Post
i customized a preset i think.

i select apple tv 3 preset, and then change some settings, as follows:

set video to strict aspect.

set video quality to 18.5 (differs some times)

set the frame rate to same as source.

subtitles if applicable, i do burned in PGS subs.
If you used the aTV preset, with only the adjustments you have noted, it should have created 2 tracks, AAC Dolby Prologic II and AC3 passthrough (or 6-channel discrete if source is DTS). Have you checked with MediaInfo or Subler to see if both tracks are there?

Also, no need to set framerate as "same as source". HB will do that as part of the preset. The 30 fps value in the box is simply a maximum value to match the spec's of the aTV3. I might also like to suggest checking "Web Optimize" as that will enhance streaming ability.
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Dec 21, 2012, 01:14 PM   #5
iOrbit
Thread Starter
macrumors 6502
 
Join Date: Mar 2012
Quote:
Originally Posted by mic j View Post
If you used the aTV preset, with only the adjustments you have noted, it should have created 2 tracks, AAC Dolby Prologic II and AC3 passthrough (or 6-channel discrete if source is DTS). Have you checked with MediaInfo or Subler to see if both tracks are there?

Also, no need to set framerate as "same as source". HB will do that as part of the preset. The 30 fps value in the box is simply a maximum value to match the spec's of the aTV3. I might also like to suggest checking "Web Optimize" as that will enhance streaming ability.
ah shoot. so there was a handy setting for something im using often.. streaming. all my movies are on a nas. from my experience, most the time, they play the whole film without an issue. but sometimes, particularly when wanting to revisit a favourite scene or two, it can start 'buffering'. can i web optimise these still without re encoding the whole thing?

i just put one in subler, and im seeing something that always confused me:

i see 7 tracks for this particular video, only two boxes are checked - track 1, and track 2. called Video track and Stereo. video being h.264 and audio being AAC 2 ch. track 3 is called Surround! and its AC-3, 6 ch. 4 is stereo, matching track 2,, 6 is video track, jpeg, - is that subtitles? i dont even remember if i put any one this one. last track is chapter track.

does this mean iv still got the original 5.1 surround sounds for my videos?

i noticed opening the video in vlc, i can play the surround file, but not in itunes (greyed out). it definitely sounds different, but without a 5.1 surround sound system i can't tell if its true 5.1, or just dolby pro logic II (i admit i know nothing about these things).

i just googled the web optimise, based on what i read, someone says it prevents the streaming playback from taking longer to begin playing - thats definitely something i noticed but never been bothered about - it takes about a second or 2 to begin playing. am i missing out on general streaming performance through out the film? thats the part that would concern me most.
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.
iOrbit is online now   0 Reply With Quote
Old Dec 21, 2012, 01:19 PM   #6
dynaflash
macrumors 68020
 
Join Date: Mar 2003
yes, Optimize in Subler does the exact same thing as "Web Optimized" does in HB, so you can do that in subler without re-encoding.

if you have both an aac stereo track and a Surround track, you have preserved your surround sound. Sounds like you are ok.
dynaflash is offline   0 Reply With Quote
Old Dec 21, 2012, 01:43 PM   #7
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by iOrbit View Post
ah shoot. so there was a handy setting for something im using often.. streaming. all my movies are on a nas. from my experience, most the time, they play the whole film without an issue. but sometimes, particularly when wanting to revisit a favourite scene or two, it can start 'buffering'. can i web optimise these still without re encoding the whole thing?

i just put one in subler, and im seeing something that always confused me:

i see 7 tracks for this particular video, only two boxes are checked - track 1, and track 2. called Video track and Stereo. video being h.264 and audio being AAC 2 ch. track 3 is called Surround! and its AC-3, 6 ch. 4 is stereo, matching track 2,, 6 is video track, jpeg, - is that subtitles? i dont even remember if i put any one this one. last track is chapter track.

does this mean iv still got the original 5.1 surround sounds for my videos?

i noticed opening the video in vlc, i can play the surround file, but not in itunes (greyed out). it definitely sounds different, but without a 5.1 surround sound system i can't tell if its true 5.1, or just dolby pro logic II (i admit i know nothing about these things).

i just googled the web optimise, based on what i read, someone says it prevents the streaming playback from taking longer to begin playing - thats definitely something i noticed but never been bothered about - it takes about a second or 2 to begin playing. am i missing out on general streaming performance through out the film? thats the part that would concern me most.
What Dynaflash said, plus...

Track 1 is the video
Track 2 is the stereo (will provide synthetic surround with capable receiver)
Track 3 is surround sound (Dolby Digital 5.1)
Track 4 not sure but could be like director's commentary or something which you can probably get rid of (check what it is in VLC)
Track 5 not sure (check in mediainfo or vlc)
Track 6 is chapter pictures
Track 7 is chapters

The only tracks you need for basic playing are 1,2,3,6,7

Optimization moves an "atom" in the file that contains file information used for playback from the end of the file to the front. Doing that allows the file to start playing before it is fully loaded. It really doesn't do anything for streaming consistency once the file has started. Just good practice to do as it doesn't hurt anything and I feel it's effects are more noticeable on the large BR files than regular dvds.
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Dec 21, 2012, 02:20 PM   #8
dynaflash
macrumors 68020
 
Join Date: Mar 2003
Oh, and optimized just means it will start playing sooner usually on a low bandwidth network. Once the movie is going it really does nothing to enhance streaming. It is also referred to as "quick start". If you are getting buffering during your movie optimize will not help that.
dynaflash is offline   0 Reply With Quote
Old Dec 21, 2012, 02:42 PM   #9
iOrbit
Thread Starter
macrumors 6502
 
Join Date: Mar 2012
thanks you guys, that really took a weight off my shoulders. im sure then that i do still have the surround sound tracks, the only thing i ever messed with on the audio settings was picking tracks, and i pick all english ones or applicable ones, including directors commentary (i find myself more likely to finally experience those commentaries on my laptop or computer, when just revisiting old favourites!)


do i need to do anything in subler to use my surround sound tracks (not all the tracks are boxed checked? but i believe vlc let me select the surround track for playback)

i think for the time being i will leave web optimised, i dont mind the 1 or 2 second delay, when i click play on a film its quick enough for me, theres no known hurry to get a film to play snap-quick, were not watching these in cinemas with ads
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.
iOrbit is online now   0 Reply With Quote
Old Dec 21, 2012, 02:48 PM   #10
dynaflash
macrumors 68020
 
Join Date: Mar 2003
Quote:
Originally Posted by iOrbit View Post
do i need to do anything in subler to use my surround sound tracks (not all the tracks are boxed checked? but i believe vlc let me select the surround track for playback)
Nope, you are fine. Carry on.
dynaflash is offline   0 Reply With Quote
Old Dec 21, 2012, 04:33 PM   #11
iOrbit
Thread Starter
macrumors 6502
 
Join Date: Mar 2012
i just checked all 70 odd videos in my library by dragging them into subler.
approximately 12 of them do not have a 'surround' track , all of them are 'stereo 2 ch' tracks. i checked my videos and they are supposed to have surround tracks! i am very confused.. i did all of my videos consistently the same way.

does anyone have any idea why this would happen?

i just re did one chapter of one of the videos, in making sure my usual settings produced the same result and it did.
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.
iOrbit is online now   0 Reply With Quote
Old Dec 21, 2012, 04:59 PM   #12
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by iOrbit View Post
i just checked all 70 odd videos in my library by dragging them into subler.
approximately 12 of them do not have a 'surround' track , all of them are 'stereo 2 ch' tracks. i checked my videos and they are supposed to have surround tracks! i am very confused.. i did all of my videos consistently the same way.

does anyone have any idea why this would happen?

i just re did one chapter of one of the videos, in making sure my usual settings produced the same result and it did.
What is the source you are going back to for checking, dvd or mkv?
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Dec 21, 2012, 05:24 PM   #13
iOrbit
Thread Starter
macrumors 6502
 
Join Date: Mar 2012
Quote:
Originally Posted by mic j View Post
What is the source you are going back to for checking, dvd or mkv?
MKV, all of them have always been MKV's.
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.
iOrbit is online now   0 Reply With Quote
Old Dec 21, 2012, 05:55 PM   #14
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by iOrbit View Post
MKV, all of them have always been MKV's.
I suspect your mkv is missing the surround track. Open the mkv in Subler and see if it shows the surround track. I have never had seen a problem with HB not including all tracks properly, if the preset is used. Now if you're doing it manually, it's easy to miss looking at the audio tab and making the proper selections. I'm gone for the rest of tonight but will me looking forward to seeing what you find.
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Dec 21, 2012, 07:17 PM   #15
iOrbit
Thread Starter
macrumors 6502
 
Join Date: Mar 2012
well, i just checked, all the tracks appear to be there, check boxed. lossless, 3/2+1, 2/0. 3 separate tracks. is it of any significance that all 3 says dolby pro logic II under 'action' ?

they should be 5.1 tracks, when i make the MKV i always rip all tracks and all english subs.
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.
iOrbit is online now   0 Reply With Quote
Old Dec 21, 2012, 10:03 PM   #16
Pyromonkey83
macrumors 6502
 
Join Date: May 2009
FYI, in order to play the 5.1 AC3 audio track on your Apple TV, go to settings -> Audio & Video -> Dolby Digital -> set to "ON" (NOT AUTO).

This will play your 5.1 audio by default. If the video does not have a 5.1 track, it will default to the primary audio track.
Pyromonkey83 is offline   0 Reply With Quote
Old Dec 22, 2012, 08:11 AM   #17
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by iOrbit View Post
well, i just checked, all the tracks appear to be there, check boxed. lossless, 3/2+1, 2/0. 3 separate tracks. is it of any significance that all 3 says dolby pro logic II under 'action' ?

they should be 5.1 tracks, when i make the MKV i always rip all tracks and all english subs.
So, to summarize, your mkv has a surround sound track (3/2+1). When you run a chapter through HB, using the aTV3 preset, you end up with only the AAC Dolby Prologic track and no AC3 track. Correct?

Try running the chapter again, and when you select the preset, go to the HB audio tab and verify that you see the 1st track as AAC Dolby Prologic II and the next track as AC3 passthrough. If that is the the way the audio tab is set, run the chapter and post back the output m4v results.
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Dec 23, 2012, 07:29 AM   #18
iOrbit
Thread Starter
macrumors 6502
 
Join Date: Mar 2012
Quote:
Originally Posted by Pyromonkey83 View Post
FYI, in order to play the 5.1 AC3 audio track on your Apple TV, go to settings -> Audio & Video -> Dolby Digital -> set to "ON" (NOT AUTO).

This will play your 5.1 audio by default. If the video does not have a 5.1 track, it will default to the primary audio track.
i tried this but half my files stopped playing with sound.

Quote:
Originally Posted by mic j View Post
So, to summarize, your mkv has a surround sound track (3/2+1). When you run a chapter through HB, using the aTV3 preset, you end up with only the AAC Dolby Prologic track and no AC3 track. Correct?

Try running the chapter again, and when you select the preset, go to the HB audio tab and verify that you see the 1st track as AAC Dolby Prologic II and the next track as AC3 passthrough. If that is the the way the audio tab is set, run the chapter and post back the output m4v results.
i just did this again, and the MKV has the 3 tracks i mentioned

the 2 surround tracks, Lossless and 3/2+1 are both DTS, 6ch tracks.

the 2/0 track is AC-3, 2ch.

i have a question:

for the videos missing surround tracks, can i readd them from the original mkv's using subtler? im new to this really but i do realise that subler can remove and add tracks to a file? i really would like to avoid reencoding the 10 or so files missing surround tracks. im hoping i can recreate the original MKV's for them and just add the missing surround tracks manually with subler.

im gonna edit this post after i run a test as you instructed.

edit**

okay i noticed something unusual, when i went to the audio tab, two audio tracks were automatically selected - both are repeating the same track, track 2. (english) it avoided putting track 0 or track 1 (non english language) into the list. on the track tab it says ac3 dolby surround in brackets, under the codec track, the first one is AAC and the second one is AC3 Passthru.

i'm certain when i did the original encode of this mkv, i selected all 3 tracks, in fact i know i did because the resulting file included all 3 tracks but did not keep the DTS ones in surround format. and theres no way i made this mistake 10 or so times on other files, including some personal favourites.

im going to run a couple encoding tests see if i get the same result again.

just to make sure i didnt make a mistake 1st time, i did the same way i usually do, and again, same result:

all 3 tracks become stereo, listed as 2ch.

test 2: gonna not mess with any settings, just standard at3 preset.

okay, test 2, didnt touch quality, aspect ratio settings (loose/strict etc) or frame rate, i didnt even touch audio. so it defaulted with repeating track 2 twice. the track 2 which is supposed to be commentary in stereo. this time i put the resulting encode in subler, and what do you know? it includes 2 tracks, one stereo as default , AAC 2 ch, and a surround track, AC-3 but says '2ch'! i dont know how to make sense of that.

okay, my last test for now atleast - i tried the same thing as test 2 but only selecting the dts hd surround track, in subler, it only shows a stereo track AAC 2ch.

so subler or hb is having an issue here?

im hoping to just take out the original tracks from the original mkv and put them in my m4v file if thats possible?
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.

Last edited by iOrbit; Dec 23, 2012 at 08:17 AM.
iOrbit is online now   0 Reply With Quote
Old Dec 23, 2012, 08:32 AM   #19
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by iOrbit View Post
i tried this but half my files stopped playing with sound.



i just did this again, and the MKV has the 3 tracks i mentioned

the 2 surround tracks, Lossless and 3/2+1 are both DTS, 6ch tracks.

the 2/0 track is AC-3, 2ch.

i have a question:

for the videos missing surround tracks, can i readd them from the original mkv's using subtler? im new to this really but i do realise that subler can remove and add tracks to a file? i really would like to avoid reencoding the 10 or so files missing surround tracks. im hoping i can recreate the original MKV's for them and just add the missing surround tracks manually with subler.

im gonna edit this post after i run a test as you instructed.

edit**

okay i noticed something unusual, when i went to the audio tab, two audio tracks were automatically selected - both are repeating the same track, track 2. (english) it avoided putting track 0 or track 1 (non english language) into the list. on the track tab it says ac3 dolby surround in brackets, under the codec track, the first one is AAC and the second one is AC3 Passthru.

i'm certain when i did the original encode of this mkv, i selected all 3 tracks, in fact i know i did because the resulting file included all 3 tracks but did not keep the DTS ones in surround format. and theres no way i made this mistake 10 or so times on other files, including some personal favourites.

im going to run a couple encoding tests see if i get the same result again.

just to make sure i didnt make a mistake 1st time, i did the same way i usually do, and again, same result:

all 3 tracks become stereo, listed as 2ch.

test 2: gonna not mess with any settings, just standard at3 preset.

okay, test 2, didnt touch quality, aspect ratio settings (loose/strict etc) or frame rate, i didnt even touch audio. so it defaulted with repeating track 2 twice. the track 2 which is supposed to be commentary in stereo. this time i put the resulting encode in subler, and what do you know? it includes 2 tracks, one stereo as default , AAC 2 ch, and a surround track, AC-3 but says '2ch'! i dont know how to make sense of that.
Looks like HB is seeing the Dolby (AC3) commentary track as your main audio track. Which means you will have to manually select your track preferences. I never include the commentary tracks, which is probably why I have never encountered this. So select:

track 0: English DTS, AAC (CoreAudio), Dolby Pro Logic II
track 1: English DTS, AC3 (ffmpeg), 6-channel discrete
track 2: English AC3, AC3 passthrough, stereo

As for adding the missing surround tracks to your already ripped mkv. I know you could re-rip, extract the track and add it to your original mkv using mkvtoolnix but not sure there is much advantage of doing that over just re-ripping the dvd to mkv. Ripping to mkv doesn't take that long (compared to converting to mp4).
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Dec 23, 2012, 08:53 AM   #20
iOrbit
Thread Starter
macrumors 6502
 
Join Date: Mar 2012
Quote:
Originally Posted by mic j View Post
Looks like HB is seeing the Dolby (AC3) commentary track as your main audio track. Which means you will have to manually select your track preferences. I never include the commentary tracks, which is probably why I have never encountered this. So select:

track 0: English DTS, AAC (CoreAudio), Dolby Pro Logic II
track 1: English DTS, AC3 (ffmpeg), 6-channel discrete
track 2: English AC3, AC3 passthrough, stereo

As for adding the missing surround tracks to your already ripped mkv. I know you could re-rip, extract the track and add it to your original mkv using mkvtoolnix but not sure there is much advantage of doing that over just re-ripping the dvd to mkv. Ripping to mkv doesn't take that long (compared to converting to mp4).
im going to try your test, just before i do i thought i better clear up what i meant:

i meant can i re rip the dvds to MKV, extract the missing tracks from the MKV and add them into the encodes i already did (m4v/mp4 files) ? i don't want to reencode the 10 or so files i did unless i have to (they take hours each)

by the way, im running the test, but isn't selecting the 3 tracks following very closely to what i always was doing with these? and 2nd question, if i am making the 2nd track(track 1) AC3 (5.1 mixdown) im assuming that might give me a surround track, but wouldn't i want to have a true surround track of the DTS HD (track 0)?

okay, test 2 resulted in a surround track in the file, subler says: AC-3, 6ch.

in future should i do this with DTS HD track, isnt that track meant to be the best one?
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.

Last edited by iOrbit; Dec 23, 2012 at 09:07 AM.
iOrbit is online now   0 Reply With Quote
Old Dec 23, 2012, 09:31 AM   #21
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by iOrbit View Post
im going to try your test, just before i do i thought i better clear up what i meant:

i meant can i re rip the dvds to MKV, extract the missing tracks from the MKV and add them into the encodes i already did (m4v/mp4 files) ? i don't want to reencode the 10 or so files i did unless i have to (they take hours each)

by the way, im running the test, but isn't selecting the 3 tracks following very closely to what i always was doing with these? and 2nd question, if i am making the 2nd track(track 1) AC3 (5.1 mixdown) im assuming that might give me a surround track, but wouldn't i want to have a true surround track of the DTS HD (track 0)?

okay, test 2 resulted in a surround track in the file, subler says: AC-3, 6ch.

in future should i do this with DTS HD track, isnt that track meant to be the best one?
Good! Some success. My understanding is that starting with the HD audio track does not yield a better AC3 track. That is, if you start with an HD audio track, it simply extracts the core DTS track for conversion to AC3. Same as if you select the DTS track (if available in your mkv) manually. I would always keep the HD audio track in the mkv however as that is a future proof.

As for adding the audio track from the mkv to the mp4, I think it is possible, but you have to convert the DTS surround track to AC3 before adding it. I have never done that but I am pretty sure there are apps that can do that. Also, not sure, if after remuxing the AC3 track into the mp4, you will not experience audio time issues. Just not something I have ever done, so maybe other can chime in here.

Finally, even when using the aTV3 preset, I check the values in all 3 tabs (video, audio, subtitles) in HB just to make sure they all say what I want. Make it a simple habit and I promise, it will save you lots of encoding time.
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Dec 23, 2012, 09:42 AM   #22
iOrbit
Thread Starter
macrumors 6502
 
Join Date: Mar 2012
Quote:
Originally Posted by mic j View Post
Good! Some success. My understanding is that starting with the HD audio track does not yield a better AC3 track. That is, if you start with an HD audio track, it simply extracts the core DTS track for conversion to AC3. Same as if you select the DTS track (if available in your mkv) manually. I would always keep the HD audio track in the mkv however as that is a future proof.

As for adding the audio track from the mkv to the mp4, I think it is possible, but you have to convert the DTS surround track to AC3 before adding it. I have never done that but I am pretty sure there are apps that can do that. Also, not sure, if after remuxing the AC3 track into the mp4, you will not experience audio time issues. Just not something I have ever done, so maybe other can chime in here.

Finally, even when using the aTV3 preset, I check the values in all 3 tabs (video, audio, subtitles) in HB just to make sure they all say what I want. Make it a simple habit and I promise, it will save you lots of encoding time.
im a bit confused, i don't really understand how handbrake works, i always assumed that the tracks you pick in the audio tab, are the tracks the file will have in the encoded result (so if you don't pick a track, you wont get it in the encoded finished file), so i'v always been selecting DTS HD track as the first track in an effort to make it default - thats what i was doing under my own assumption, sounds like i couldve had a full quality DTS HD track in the file if i Didn't select it? or select it as track 1? sorry, this is all a bit confusing this part for me. i can live with not having a lossless track to the files, aslong as i have the surround sound i'll be happy. i mean, i'd be happier being content in that situation than convincing myself to re encode 70 odd videos, hours each.

okay, i'll avoid trying to add tracks with subler, so in future, i should always do a single chapter test result on encoding an mkv, to look out for this rare bug/issue where handbrake wont handle the audio tracks properly? and if i happen to come accross one with this issue, what should i do consistently to get a surround track? because im a bit confused how to make sure i will get one.
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.
iOrbit is online now   0 Reply With Quote
Old Dec 23, 2012, 10:44 AM   #23
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by iOrbit View Post
im a bit confused, i don't really understand how handbrake works, i always assumed that the tracks you pick in the audio tab, are the tracks the file will have in the encoded result (so if you don't pick a track, you wont get it in the encoded finished file), so i'v always been selecting DTS HD track as the first track in an effort to make it default - thats what i was doing under my own assumption, sounds like i couldve had a full quality DTS HD track in the file if i Didn't select it? or select it as track 1? sorry, this is all a bit confusing this part for me. i can live with not having a lossless track to the files, aslong as i have the surround sound i'll be happy. i mean, i'd be happier being content in that situation than convincing myself to re encode 70 odd videos, hours each.

okay, i'll avoid trying to add tracks with subler, so in future, i should always do a single chapter test result on encoding an mkv, to look out for this rare bug/issue where handbrake wont handle the audio tracks properly? and if i happen to come accross one with this issue, what should i do consistently to get a surround track? because im a bit confused how to make sure i will get one.
No, you're making this too hard. You don't need to do a test chapter, you just need to check the audio tab settings. Here's what you should do (assuming you are using MakeMKV to rip your dvd/BR's):

After MakeMKV scans your disc, select the tracks you really want to keep. Run.
Open the mkv in HB, then select your aTV3 preset.
Check your video setting to make sure they are right (anamorphic strict, web optimize, 30fps, etc). Adjust if needed (I have never had to do that).
Check your audio settings. HB should select your 1st 2 tracks automatically. For DD 5.1 (from mkv): AAC/Dolby Prologic stereo 1st track, AC3 passthrough 2nd track
For DTS or DTS-HD (from mkv): AAC Prologic stereo, AC3 (ffmpeg), 6-channel discrete
If you have other tracks you want to include from the mkv, you can select the next track in the series and make your selection(s) from the choices it provides you.

Here is where you may be getting confused, although you can add a dts (or dts-hd) track, it is non-functional with the aTV (and most other players). DTS (whether normal or HD) has to be converted to either AAC or Dolby Digital (AC3) for the aTV to play it. The aTV requires you to have the AAC track as your first track.
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Dec 23, 2012, 11:53 AM   #24
iOrbit
Thread Starter
macrumors 6502
 
Join Date: Mar 2012
Quote:
Originally Posted by mic j View Post
No, you're making this too hard. You don't need to do a test chapter, you just need to check the audio tab settings. Here's what you should do (assuming you are using MakeMKV to rip your dvd/BR's):

After MakeMKV scans your disc, select the tracks you really want to keep. Run.
Open the mkv in HB, then select your aTV3 preset.
Check your video setting to make sure they are right (anamorphic strict, web optimize, 30fps, etc). Adjust if needed (I have never had to do that).
Check your audio settings. HB should select your 1st 2 tracks automatically. For DD 5.1 (from mkv): AAC/Dolby Prologic stereo 1st track, AC3 passthrough 2nd track
For DTS or DTS-HD (from mkv): AAC Prologic stereo, AC3 (ffmpeg), 6-channel discrete
If you have other tracks you want to include from the mkv, you can select the next track in the series and make your selection(s) from the choices it provides you.

Here is where you may be getting confused, although you can add a dts (or dts-hd) track, it is non-functional with the aTV (and most other players). DTS (whether normal or HD) has to be converted to either AAC or Dolby Digital (AC3) for the aTV to play it. The aTV requires you to have the AAC track as your first track.
ah, thanks for clearing everything up. so by the sounds of it, all of my videos that have surround tracks, only have dolby digital surround tracks that werent originally DTS. and any videos that were DTS only, have no surround tracks after being encoded.

i understand the audio part better now, i guess all my surround tracks in my videos are likely dolby tracks and not the original DTS HD ones. thats a bit of a bummer but i can live with it.

the reason why i never went with '30fps' is because i didnt know what handbrake would do, i assumed it would change the FPS of my videos to 30, which i don't want. i very much value the films to be native fps, as originally filmed, and i figured that apple at some point in the future will probably support 24fps playback, i'd like to think they will. so i went native with same as source on HB. even if apple don't, i want my videos to have their original FPS. since im from the uk and iv experienced the 25fps effect on the pitch of soundtracks nad voices, it was just a risk taht wasnt worth it for me.

i'll do web optimize on this reencode, and i notice a good difference i will try and 'web optimize' the rest of my library with subler, only problem is, i can't figure out how to do it in subler.
__________________
MacBook Pro - late 2011, 16GB Ram, 256GB SSD. iPad - 2nd Gen, White 16gb. iPhone 4s - Black 8gb. iPod Touch - 4th Gen, 8GB, White. TV - 3rd Gen.
iOrbit is online now   0 Reply With Quote
Old Dec 23, 2012, 12:28 PM   #25
mic j
macrumors 68000
 
Join Date: Mar 2012
Quote:
Originally Posted by iOrbit View Post
ah, thanks for clearing everything up. so by the sounds of it, all of my videos that have surround tracks, only have dolby digital surround tracks that werent originally DTS. and any videos that were DTS only, have no surround tracks after being encoded. That sounds like what is going on. Anything where the original was DD 5.1 transcoded fine with HB, anything that had DTS ended up with just stereo.

i understand the audio part better now, i guess all my surround tracks in my videos are likely dolby tracks and not the original DTS HD ones. thats a bit of a bummer but i can live with it. With the aTV you will not be able to play HD audio (Dolby True HD or DTS-HD) so it doesn't really matter it is not in the final transcode. As long as the AC3 5.1 track is there, that is the best sound you can have that the aTV will play.

the reason why i never went with '30fps' is because i didnt know what handbrake would do, i assumed it would change the FPS of my videos to 30, which i don't want. i very much value the films to be native fps, as originally filmed, and i figured that apple at some point in the future will probably support 24fps playback, i'd like to think they will. so i went native with same as source on HB. even if apple don't, i want my videos to have their original FPS. since im from the uk and iv experienced the 25fps effect on the pitch of soundtracks nad voices, it was just a risk taht wasnt worth it for me.The 30fps you see is just a maximum frame rate that is allowed for the aTV. It will transcode same as source even showing the 30fps in the box. So don't worry about it.

i'll do web optimize on this reencode, and i notice a good difference i will try and 'web optimize' the rest of my library with subler, only problem is, i can't figure out how to do it in subler.There are 2 ways to optimize your mp4 with Subler. Open the file, select>File>Optimize (or if greyed out, Save it and the Optimize capability should be enabled. Or, you can add the file to the Subler queue and down at the bottom it will give you the ability to set queue settings. One of the options is Optimize. Select it and anything your queue processes will be automatically optimized. I usually do the first way as I have HB optimize my files. Both optimizations are the same, I just like to make it part of the transcode process so I don't notice the time it takes.

Also, you can make the Web Optimize in HB part of the aTV3 preset, so you never have to try and figure out whether a file has been optimized or not...not the easiest of processes.

If you need anything else, head back here or pm me.
See comments above.
__________________
17" MacBook Pro, 2.66 GHz, 8GB RAM; AppleTV 3; iPad 2, 32GB; 2TB Time Capsule (RIP 9/12); AEBS w 1TB Seagate HDD; AE; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:44 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC