Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 30, 2012, 12:25 PM   #1
smcgil9899
macrumors member
 
Join Date: Jun 2008
USB 3.0 on 2011 17" MBP

Is there anyway to get USB 3.0 on a 17" 2011 MBP? I seen a serial card with 2 USB 3.0 ports from Sonnet. Will this work? My computer does have a Thunderbolt port.

Last edited by smcgil9899; Jun 30, 2012 at 02:44 PM.
smcgil9899 is offline   0 Reply With Quote
Old Jun 30, 2012, 11:42 PM   #2
Meever
macrumors 6502a
 
Join Date: Jun 2009
express to usb 3.0 But I don't think you can get the max speed from them.
Meever is offline   0 Reply With Quote
Old Jul 1, 2012, 08:04 AM   #3
cookiesnfooty
macrumors 6502
 
Join Date: Jul 2009
Location: Wilmslow
 
see vendor information in user profile
Thunderbolt hubs
__________________
Iphone 5 64GB White, Macbook pro 2011 16GB RAM & 1.02TB SSD RAID.

"I miss you Steve"....
cookiesnfooty is offline   1 Reply With Quote
Old Jul 1, 2012, 08:58 AM   #4
smcgil9899
Thread Starter
macrumors member
 
Join Date: Jun 2008
According to their site, you can get the same speed.

http://www.sonnettech.com/product/us...esscard34.html

Aren't the ThunderBolt hubs real expensive?
smcgil9899 is offline   1 Reply With Quote
Old Jul 1, 2012, 09:04 AM   #5
Bazzy
macrumors regular
 
Join Date: Jun 2009
Hi All,

I too would love to find a reasonable solution to this - most reviews of the various Expresscard USB 3.0 adapters (e.g. Amazon etc) have not been very encouraging - would really like to find one that is reasonably priced & fully works with OSX without issues!!

Bazzy!

Last edited by Bazzy; Jul 1, 2012 at 02:19 PM.
Bazzy is offline   0 Reply With Quote
Old Jul 1, 2012, 02:16 PM   #6
Astroboy907
macrumors 65816
 
Astroboy907's Avatar
 
Join Date: May 2012
Location: Lunar Habitat 112
Quote:
Originally Posted by smcgil9899 View Post
Is there anyway to get USB 3.0 on a 17" 2011 MBP? I seen a serial card with 2 USB 3.0 ports from Sonnet. Will this work? My computer does have a Thunderbolt port.
I actually got this to work 4 days ago on my Late '08 MBP (15")

Basically, I got this card (Brand GMYLE) on Amazon for $10 total (http://www.amazon.com/gp/product/B00...pf_rd_i=507846)

Obviously it probably wouldn't work on mac... but i tried. Once I got the card I tried installing some drivers (caldigit, LaCie, etc), and none worked. On a whim tried Oyendigital drivers (their card is similar, and I based off of a comment on amazon that it worked with some issues)

Tried my 1 USB3 drive on USB2 using blackmagic disk speed test (MAS), got around ~30mB/s Read/Write

Tried it in expresscard and got ~40mB/s read and write in the beginning, but it was jumping around to ~100+ mB/s read and WRITE. True indeed, my drive is faster- I am very happy that it works ATM

Pros:
Supports USB3 AND USB2 devices
FAST- ~100 mb/s WRITE
Hot Swappable (Works perfectly, BTW)
Flush with laptop

Cons:
Gets a bit warm in slot, but ok by me
Ports are a bit close, and card is a bit easily pulled out by pulling device plug.
Does NOT support USB3 power specs (gets ~600ma total, rather than ~900ma per port)
Cannot support 2 powered (eg external portable hard drive) devices at once, but it can do 1 at a time (< havn't tested this yet.., but highly probable)
Due to bus speed might not hit full USB3 speeds

----------

Quote:
Originally Posted by Bazzy View Post
Hi All,

I too would lobe to find a reasonable solution to this - most reviews of the various Expresscard USB 3.0 adapters (e.g. Amazon etc) have not been very encouraging - would really like to find one that is reasonable priced & fully works with OSX with issues!!

Bazzy!
See above
__________________
Late '08 MBP, 15", 2.66 ghz C2D, 1TB/8gb.
Mac Mini '09, 2.26 C2D 160/2gb, Mediasonic RAID 10 8tb
iPhone 4S Jailbroken
My heatware!

Last edited by Astroboy907; Jul 1, 2012 at 02:33 PM. Reason: Link fix
Astroboy907 is offline   2 Reply With Quote
Old Jul 1, 2012, 02:41 PM   #7
Bazzy
macrumors regular
 
Join Date: Jun 2009
Quote:
Originally Posted by astroboy907 View Post
I actually got this to work 4 days ago on my Late '08 MBP (15")

Basically, I got this card (Brand GMYLE) on Amazon for $10 total (http://www.amazon.com/gp/product/B00...pf_rd_i=507846)

Obviously it probably wouldn't work on mac... but i tried. Once I got the card I tried installing some drivers (caldigit, LaCie, etc), and none worked. On a whim tried Oyendigital drivers (their card is similar, and I based off of a comment on amazon that it worked with some issues)

Tried my 1 USB3 drive on USB2 using blackmagic disk speed test (MAS), got around ~30mB/s Read/Write

Tried it in expresscard and got ~40mB/s read and write in the beginning, but it was jumping around to ~100+ mB/s read and WRITE. True indeed, my drive is faster- I am very happy that it works ATM

Pros:
Supports USB3 AND USB2 devices
FAST- ~100 mb/s WRITE
Hot Swappable (Works perfectly, BTW)
Flush with laptop

Cons:
Gets a bit warm in slot, but ok by me
Ports are a bit close, and card is a bit easily pulled out by pulling device plug.
Does NOT support USB3 power specs (gets ~600ma total, rather than ~900ma per port)
Cannot support 2 powered (eg external portable hard drive) devices at once, but it can do 1 at a time (< havn't tested this yet.., but highly probable)
Due to bus speed might not hit full USB3 speeds

----------


See above
Hi,

Thanks for the above - did this USB 3.0 card work with portable hard drives when connected?

Bazzy!
Bazzy is offline   0 Reply With Quote
Old Jul 1, 2012, 04:04 PM   #8
Astroboy907
macrumors 65816
 
Astroboy907's Avatar
 
Join Date: May 2012
Location: Lunar Habitat 112
Quote:
Originally Posted by Bazzy View Post
Hi,

Thanks for the above - did this USB 3.0 card work with portable hard drives when connected?

Bazzy!
I only have a USB 2.0 external (portable) drive, it worked fine with that and a flash drive plugged into the other port.
__________________
Late '08 MBP, 15", 2.66 ghz C2D, 1TB/8gb.
Mac Mini '09, 2.26 C2D 160/2gb, Mediasonic RAID 10 8tb
iPhone 4S Jailbroken
My heatware!
Astroboy907 is offline   0 Reply With Quote
Old Jul 1, 2012, 04:59 PM   #9
Bazzy
macrumors regular
 
Join Date: Jun 2009
Quote:
Originally Posted by astroboy907 View Post
I only have a USB 2.0 external (portable) drive, it worked fine with that and a flash drive plugged into the other port.
Hi,

Thanks for the info - may give it a go!

Bazzy!
Bazzy is offline   0 Reply With Quote
Old Jul 1, 2012, 05:08 PM   #10
boomhower
macrumors 65816
 
boomhower's Avatar
 
Join Date: Oct 2011
I'm hoping for a reasonably priced TB-> USB 3 adapter comes out soon. I don't need or want a $250 station with a bunch of ports, just something that goes TB-> USB 3.
__________________
2011 Macbook Pro 15 iPad Mini iPhone 5 Airport Extreme Gen 5
boomhower is offline   0 Reply With Quote
Old Jul 1, 2012, 05:17 PM   #11
smcgil9899
Thread Starter
macrumors member
 
Join Date: Jun 2008
Quote:
Originally Posted by boomhower View Post
I'm hoping for a reasonably priced TB-> USB 3 adapter comes out soon. I don't need or want a $250 station with a bunch of ports, just something that goes TB-> USB 3.
That is what I want also, just something simple.
smcgil9899 is offline   0 Reply With Quote
Old Jul 1, 2012, 05:37 PM   #12
InuNacho
macrumors 6502a
 
InuNacho's Avatar
 
Join Date: Apr 2008
Location: In that one place
Quote:
Originally Posted by astroboy907 View Post
I actually got this to work 4 days ago on my Late '08 MBP (15")

Basically, I got this card (Brand GMYLE) on Amazon for $10 total (http://www.amazon.com/gp/product/B00...pf_rd_i=507846)

Oh man thanks for sharing that, USB 3 for $10! Quick question, are you running Lion or Snow Leopard?
InuNacho is offline   0 Reply With Quote
Old Jul 1, 2012, 05:40 PM   #13
Astroboy907
macrumors 65816
 
Astroboy907's Avatar
 
Join Date: May 2012
Location: Lunar Habitat 112
Quote:
Originally Posted by InuNacho View Post
Oh man thanks for sharing that, USB 3 for $10! Quick question, are you running Lion or Snow Leopard?
Lion 10.7.4 ATM
though I do have a 10.6 partition on it if you need to check...
__________________
Late '08 MBP, 15", 2.66 ghz C2D, 1TB/8gb.
Mac Mini '09, 2.26 C2D 160/2gb, Mediasonic RAID 10 8tb
iPhone 4S Jailbroken
My heatware!
Astroboy907 is offline   0 Reply With Quote
Old Jul 2, 2012, 01:03 AM   #14
InuNacho
macrumors 6502a
 
InuNacho's Avatar
 
Join Date: Apr 2008
Location: In that one place
Quote:
Originally Posted by astroboy907 View Post
Lion 10.7.4 ATM
though I do have a 10.6 partition on it if you need to check...
Yes please!
InuNacho is offline   0 Reply With Quote
Old Jul 5, 2012, 12:57 AM   #15
Astroboy907
macrumors 65816
 
Astroboy907's Avatar
 
Join Date: May 2012
Location: Lunar Habitat 112
Quote:
Originally Posted by InuNacho View Post
Yes please!
Will check tomorrow... sorry I forgot a bit... got all up in 4th of july
__________________
Late '08 MBP, 15", 2.66 ghz C2D, 1TB/8gb.
Mac Mini '09, 2.26 C2D 160/2gb, Mediasonic RAID 10 8tb
iPhone 4S Jailbroken
My heatware!
Astroboy907 is offline   0 Reply With Quote
Old Jul 6, 2012, 12:15 AM   #16
Astroboy907
macrumors 65816
 
Astroboy907's Avatar
 
Join Date: May 2012
Location: Lunar Habitat 112
Quote:
Originally Posted by InuNacho View Post
Yes please!
GAH! Another day gone. I PROMISE to try tomorrow! *facepalm*
__________________
Late '08 MBP, 15", 2.66 ghz C2D, 1TB/8gb.
Mac Mini '09, 2.26 C2D 160/2gb, Mediasonic RAID 10 8tb
iPhone 4S Jailbroken
My heatware!
Astroboy907 is offline   0 Reply With Quote
Old Jul 7, 2012, 02:53 PM   #17
Astroboy907
macrumors 65816
 
Astroboy907's Avatar
 
Join Date: May 2012
Location: Lunar Habitat 112
Quote:
Originally Posted by InuNacho View Post
Yes please!
After much trial: in short. No. It didnt work

Tried oyendigitals drivers first, nada. The drive spun up like it was connected to something, but never read (actually did that for the entire test, with everything I tried)

Went on to caldigit drivers, nothing, then tried a hacked lacie driver, still nothing.

Reinstalled all drivers, nothing.

So it may just be a lion thing, OR the way I attempted to install it on my system was a bit wacked and somehow it decided to work. Basically, my installation was: Caldigit drivers > LaCie Drivers (installed mulitple times, and removed rather messily) > OyenDigital drivers


It *may* work as a USB2 card, but IDK. I didn't really try that...
Sorry man!


Edit: This was on a 10.6 partition, was not upgraded to 10.6.8/other
__________________
Late '08 MBP, 15", 2.66 ghz C2D, 1TB/8gb.
Mac Mini '09, 2.26 C2D 160/2gb, Mediasonic RAID 10 8tb
iPhone 4S Jailbroken
My heatware!
Astroboy907 is offline   0 Reply With Quote
Old Jul 7, 2012, 04:14 PM   #18
InuNacho
macrumors 6502a
 
InuNacho's Avatar
 
Join Date: Apr 2008
Location: In that one place
Quote:
Originally Posted by astroboy907 View Post
After much trial: in short. No. It didnt work
Aww man, thanks for trying though. I'm stuck on 10.6 due to a decent amount of PPC software and I'm not that big a fan of some of the features in Lion. Looks like I'm sticking with eSata for a while.
Thanks again!
InuNacho is offline   0 Reply With Quote
Old Jul 7, 2012, 11:23 PM   #19
Astroboy907
macrumors 65816
 
Astroboy907's Avatar
 
Join Date: May 2012
Location: Lunar Habitat 112
Quote:
Originally Posted by InuNacho View Post
Aww man, thanks for trying though. I'm stuck on 10.6 due to a decent amount of PPC software and I'm not that big a fan of some of the features in Lion. Looks like I'm sticking with eSata for a while.
Thanks again!
Well, dont give up *too* quickly. I'd say, if you can afford $10 shipped, its worth thinking about... and if it doesnt work at all (even as USB2), sell it to a windows guy

And yeah, lack of rosetta on lion sucks.. thats why I got the partition, to update a peice of software whose updater to intel was of course, a PPC app
__________________
Late '08 MBP, 15", 2.66 ghz C2D, 1TB/8gb.
Mac Mini '09, 2.26 C2D 160/2gb, Mediasonic RAID 10 8tb
iPhone 4S Jailbroken
My heatware!
Astroboy907 is offline   0 Reply With Quote
Old Oct 29, 2012, 08:11 AM   #20
luz42
macrumors newbie
 
Join Date: Oct 2012
Thumbs up my GMYLE USB 3.0 expressCard works with CalDigit drivers!

In contrary to @astroboy907's experience, who found Oyen digital driver to work with his card, mine did not (ordered from gmyle.com October 2012).

After some googling I found that, apparently, these GMYLE USB 3.0 express cards were produced in different batches with different chipsets.

So I tried the other driver options, and in my case the CalDigital driver (http://www.caldigit.com/KB/index.asp?KBID=108) works, on a MacBook PRO 17" 2010 with Mac OS X 10.8.

Thanks for all the hints in this discussion, which encouraged me to try the GMYLE card in the first place!
luz42 is offline   0 Reply With Quote
Old Nov 26, 2012, 02:03 PM   #21
rev.b
macrumors regular
 
Join Date: May 2009
Location: Portugal
Quote:
Originally Posted by luz42 View Post
In contrary to @astroboy907's experience, who found Oyen digital driver to work with his card, mine did not (ordered from gmyle.com October 2012).

After some googling I found that, apparently, these GMYLE USB 3.0 express cards were produced in different batches with different chipsets.

So I tried the other driver options, and in my case the CalDigital driver (http://www.caldigit.com/KB/index.asp?KBID=108) works, on a MacBook PRO 17" 2010 with Mac OS X 10.8.

Thanks for all the hints in this discussion, which encouraged me to try the GMYLE card in the first place!
Hello there.
I just got one of those cheap Gmyle BC628 from ebay, but I couldn't get it to work. I just installed Oyendigital and Caldigit drivers, but nothing. Power does get through, as a usb dvd drive spins, but nothing is recognised.

Here is my system profile for the card


Did you just ran the .pkg's or did something different?
rev.b is offline   0 Reply With Quote
Old Nov 28, 2012, 12:40 PM   #22
zackkmac
macrumors 6502a
 
Join Date: Jul 2008
Location: Tulsa
Quote:
Originally Posted by rev.b View Post
Hello there.
I just got one of those cheap Gmyle BC628 from ebay, but I couldn't get it to work. I just installed Oyendigital and Caldigit drivers, but nothing. Power does get through, as a usb dvd drive spins, but nothing is recognised.

Here is my system profile for the card
Image

Did you just ran the .pkg's or did something different?
Any luck on this? I'm also stuck in the same boat.
__________________
27" iMac 3.5GHz i7, 780M 4GB, 32GB RAM, 3TB Fusion Drive
15" MacBook Pro 2.2GHz i7, Hi-Res AG, 16GB RAM, 960GB SSD, Blu-Ray SuperDrive
13" MacBook Pro 2.5GHz i5, 16GB RAM, 256GB SSD
zackkmac is offline   0 Reply With Quote
Old Dec 2, 2012, 04:50 PM   #23
MasterDrow
macrumors newbie
 
Join Date: Dec 2012
Quote:
Originally Posted by zackkmac View Post
Any luck on this? I'm also stuck in the same boat.
I too am having this problem. Are either of you (zackkmac, or rev.b) running OSX 10.8?

The reason I ask is because I am running OSX 10.7 and it looks like Oyendigital updated their drivers to only work on 10.8 so I theorize that for 10.8 users the drivers will work but for 10.7 and below they are no longer providing the driver. (again just a theory)

A response would be kindly appreciated.
MasterDrow is offline   0 Reply With Quote
Old Dec 2, 2012, 05:02 PM   #24
zackkmac
macrumors 6502a
 
Join Date: Jul 2008
Location: Tulsa
Quote:
Originally Posted by MasterDrow View Post
I too am having this problem. Are either of you (zackkmac, or rev.b) running OSX 10.8?

The reason I ask is because I am running OSX 10.7 and it looks like Oyendigital updated their drivers to only work on 10.8 so I theorize that for 10.8 users the drivers will work but for 10.7 and below they are no longer providing the driver. (again just a theory)

A response would be kindly appreciated.
I'm running 10.8.2.
__________________
27" iMac 3.5GHz i7, 780M 4GB, 32GB RAM, 3TB Fusion Drive
15" MacBook Pro 2.2GHz i7, Hi-Res AG, 16GB RAM, 960GB SSD, Blu-Ray SuperDrive
13" MacBook Pro 2.5GHz i5, 16GB RAM, 256GB SSD
zackkmac is offline   0 Reply With Quote
Old Jan 3, 2013, 04:25 PM   #25
nxtlukas
macrumors newbie
 
Join Date: Nov 2012
Talking Working solution for GMYLE card BC628

I finally got the GMYLE card (BC628) to work with 10.8.3!! I can only recommend this 10$ card if you're ready for some hacking Here's what I did (This will probably not work with every GMYLE card as the chipset may vary):
1. Remove the card from the slot
2. Download a patched PXHCD.kext (Link for the one which worked for me, else see below)
3. copy the downloaded kext to /System/Library/Extensions/
4. Open Terminal and type the following commands:
a) sudo chmod -R 755 /System/Library/Extensions/PXHCD.kext
b) sudo chown -R root:wheel /System/Library/Extensions/PXHCD.kext
c) sudo rm -R /System/Library/Extensions.kextcache
d) sudo rm -R /System/Library/Extensions.mkext
NOTE: if step c) or d) returns any error don't worry just proceed
e) sudo reboot
5. After reboot open diskutilty and repair permissions
6. Now shutdown your computer
7. Connect your USB 3.0 card
8. Turn on your computer
9. You're already done if it works, else proceed to 10.

10. Open System Profiler and check Extensions (whether the PXHCD.kext is loaded successfully or not..)
11. If it is not listed open terminal and type:
sudo kextload -v /System/Library/Extensions/PXHCD.kext
12. Now check your System Profiler whether the USB Super-Speed Bus is present or not.

13. If the kext did not load automatically but did after 11. you would have to do this after every reboot.
The best workaround I could imagine is:
14. download this shell file: Link
15. Put the load_kext.sh into /Users/Shared
16. Tell OS X to load this on every boot by running:
sudo defaults write com.apple.loginwindow LoginHook /Users/Shared/load_kext.sh
And accepting with your password. The card should work now after the next reboot; it's also hot-pluggable.

I downloaded the kext from this forum: Link and re-uploaded the 1.0.10 so that you won't have to register for InsanelyMac...
The instructions are partly copied from here: Link
And last but not least Thanks to Apple for explaining Login hooks here: Link

Hope this helps,
Luk
nxtlukas is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:32 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC