Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Applications > iPad Apps

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 5, 2013, 02:49 AM   #1
farenden1829
macrumors newbie
 
Join Date: Jan 2013
imovies problem, please help!

Hi everyone,

I have iMovie HD version 6.0.3. I wanted to update it and looked on the Apple site and the latest version is iMovie 11 version 9.0.8. When I tried to upgrade it said the minimum requirements are OSX 10.7.4, I have OSX 10.6.8. Any idea if I can get the previous version or the latest one compatible with my Mac?

Thanks.
farenden1829 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > iPad Apps

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:52 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC