Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 4, 2013, 12:31 PM   #1
straber
macrumors member
 
Join Date: Jul 2012
Can't install app to device

I just purchased a new MacBook and can't successfully get Xcode to run my apps on a device. I've used Apple's Provisioning Assistant, installed new provisioning profiles and my certificate, but I always get the error "A valid provisioning profile for this executable was not found." The only weird thing I can see is that in keychain, next to my certificate it does not have the triangle that expands and says "iOS Developer" under it like it did on my old laptop.

Does anyone know what I'm doing wrong or how to get it let me run my apps on devices again?

Thanks in advance for any help.
straber is offline   0 Reply With Quote
Old Jan 7, 2013, 06:48 AM   #2
KoolStar
macrumors Demi-God
 
KoolStar's Avatar
 
Join Date: Oct 2006
Location: Kentucky
Send a message via AIM to KoolStar Send a message via Skype™ to KoolStar
This typically means that the private key is not added to the keychain. I would recommend deleting the signer identity and try re adding it to the keychain.
__________________
"Innovation distinguishes between a leader and a follower." : S.J.
KoolStar is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:26 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC