Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 8, 2013, 08:50 AM   #1
Jhene
macrumors newbie
 
Join Date: Jan 2013
deviantart.com front page doesn't load on my mac?

http://www.deviantart.com doesn't load on my mbp it stays blank page but the rest of the site works fine but the front page.

It displays fine on my PC and I tried using Google DNS.

It does work when I reset safari, any other time after that i have issues.
Jhene is offline   0 Reply With Quote
Old Jan 8, 2013, 08:54 AM   #2
old-wiz
macrumors 604
 
Join Date: Mar 2008
Location: West Suburban Boston Ma
works fine for me using google chrome
old-wiz is offline   0 Reply With Quote
Old Jan 8, 2013, 09:12 AM   #3
GGJstudios
macrumors Westmere
 
Join Date: May 2008
Quote:
Originally Posted by Jhene View Post
http://www.deviantart.com doesn't load on my mbp it stays blank page but the rest of the site works fine but the front page.

It displays fine on my PC and I tried using Google DNS.

It does work when I reset safari, any other time after that i have issues.
Disable any ad-blockers or extensions you may have. Clear your cache and cookies. If you haven't already done so, try changing your DNS servers on your Mac and your router to OpenDNS servers. This will show you how: Why am I being redirected to other sites?
GGJstudios is offline   0 Reply With Quote
Old Jan 8, 2013, 09:47 AM   #4
Weaselboy
macrumors G4
 
Weaselboy's Avatar
 
Join Date: Jan 2005
Quote:
Originally Posted by Jhene View Post
http://www.deviantart.com doesn't load on my mbp it stays blank page but the rest of the site works fine but the front page.

It displays fine on my PC and I tried using Google DNS.

It does work when I reset safari, any other time after that i have issues.
Working fine here on Safari. If the rest of the site works, and just the main page is blank, it would have nothing to do with DNS. Do you have any adblockers running?
Weaselboy is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:16 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC