Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 9, 2013, 09:29 AM   #1
The.316
macrumors 65816
 
The.316's Avatar
 
Join Date: Jul 2010
MAJOR screen issues with my 27" iMac

I have a 27" mid 2010 iMac, with a SSD in the optical drive. The last few days, I have been getting freezes on the screen. I could hear the background sound and see the mouse cursor move, but the screen would be frozen and I couldnt do anything except for restart. Just a little while ago, I get this:



and this happens:

Video

I dont know what to do now. I did a PRAM reset just to do it, but Im still getting the same problem. Worse case scenario, I send it in since I have 4 months left on my applecare, but Im wondering if anyone has any suggestions first.
__________________
27" iMac i7 13" MPB
16gb iPhone 5 32gb iPad Air
Apple TV 3
The.316 is offline   0 Reply With Quote
Old Jan 9, 2013, 09:39 AM   #2
justperry
macrumors 603
 
justperry's Avatar
 
Join Date: Aug 2007
Location: 7 Km South of an active upside down (boat) volcano.
Seems like GPU issues, you should run AHT, Hold d at startup.

Intel-based Macs: Using Apple Hardware Test
justperry is offline   0 Reply With Quote
Old Jan 9, 2013, 09:49 AM   #3
The.316
Thread Starter
macrumors 65816
 
The.316's Avatar
 
Join Date: Jul 2010
Quote:
Originally Posted by justperry View Post
Seems like GPU issues, you should run AHT, Hold d at startup.

Intel-based Macs: Using Apple Hardware Test
Thanks. I was looking for that earlier, but I forgot what it was called. Im glad I have the applecare though, because if I do have to send it away, they will probably replace my screen too because its got the yellow and dark spots all over.
__________________
27" iMac i7 13" MPB
16gb iPhone 5 32gb iPad Air
Apple TV 3
The.316 is offline   0 Reply With Quote
Old Jan 9, 2013, 10:10 AM   #4
The.316
Thread Starter
macrumors 65816
 
The.316's Avatar
 
Join Date: Jul 2010
Ran the hardware test, and it said that there were no issues. I am back from safe mode, and its back to normal. Anything else I can do? I think Im still going to send it away to get looked at.

Edit: I logged in as a guest on my iMac, and now Im not getting any problems whatsoever. Why would this be going on only when Im signed in?
__________________
27" iMac i7 13" MPB
16gb iPhone 5 32gb iPad Air
Apple TV 3

Last edited by The.316; Jan 9, 2013 at 02:44 PM.
The.316 is offline   0 Reply With Quote
Old Jan 10, 2013, 06:21 AM   #5
The.316
Thread Starter
macrumors 65816
 
The.316's Avatar
 
Join Date: Jul 2010
Anyone have any ideas? I left my iMac off all night, and just turned it on this afternoon. Its working fine so far, but Im sure that its going to start bugging out again. I just find it weird that when I logged in as a guest user, I didnt seem to have any problem, but as soon as I logged out, and in to my account, it froze immediately.
__________________
27" iMac i7 13" MPB
16gb iPhone 5 32gb iPad Air
Apple TV 3
The.316 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Late 2013 27" iMac, yellow screen issues :( forceroyale iMac 188 Apr 7, 2014 09:27 PM
Major screen rendering issues - Mavericks Update Pookieinc OS X Mavericks (10.9) 6 Oct 30, 2013 11:41 AM
2010 27" iMac screen issue..."dirty", "cloudy", image retention issues MMcCraryNJ iMac 1 May 18, 2013 04:02 PM
17" iMac Late 2006 Screen Issues MikFed87 iMac 1 Jan 19, 2013 06:30 AM
"screen lamination issues" = anti glare iMac mcpix iMac 10 Aug 9, 2012 10:06 AM

Forum Jump

All times are GMT -5. The time now is 07:26 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC