Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 23, 2012, 06:49 AM   #1
tmanto02
macrumors 6502a
 
tmanto02's Avatar
 
Join Date: Jun 2011
Location: Earth
Issue installing windows 8 pro retail via bootcamp

I have tried twice installing windows 8 pro onto my rMBP via bootcamp but failed both times.

After the step "Getting files ready for installation" completes, my macbook restarts as expected - launches back into the windows installation however the screen goes black with a purple stripe (see pic). The cursor is visible on the purple section however it looks squashed.





I deleted my bootcamp partition and tried again with the same result.

Am I doing something wrong?
__________________
iPhone 5 for on the go|iPad Air for on the couch|Mac mini for Plex Home Theatre
MacBook Pro w/ Retina display
for everything else
tmanto02 is offline   0 Reply With Quote
Old Dec 23, 2012, 04:12 PM   #2
tmanto02
Thread Starter
macrumors 6502a
 
tmanto02's Avatar
 
Join Date: Jun 2011
Location: Earth
Anybody else experience this?
__________________
iPhone 5 for on the go|iPad Air for on the couch|Mac mini for Plex Home Theatre
MacBook Pro w/ Retina display
for everything else
tmanto02 is offline   0 Reply With Quote
Old Dec 30, 2012, 01:33 PM   #3
vastoholic
macrumors 68000
 
vastoholic's Avatar
 
Join Date: Jan 2009
Location: Tulsa, OK
Unfortunately no. I just finished installing Windows 8 on my mini and everything went surprisingly smooth. The only issue I'm having is over scan on my monitor hooked up via HDMI. I have big black borders around the whole screen.
__________________
View my flickr sets....if you want. They're not too exciting.
vastoholic is offline   0 Reply With Quote
Old Jan 10, 2013, 09:27 AM   #4
tekkboi
macrumors newbie
 
Join Date: Jan 2013
Reboot Windows 8 in safe mode. (While win 8 loads hold down the Fn + F8 keys). Windows will then go to "Advanced startup" Choose "Troubleshoot" and "Advanced options" click "Startup settings" Choose "Enable low resolution video mode" When its done, Windows will magically restart normally and be ready to set up user account and install drivers.

Windows 8 just doesn't know what to do with the retina display resolution on some MBPr's yet at boot.

Last edited by tekkboi; Jan 10, 2013 at 09:54 AM.
tekkboi is offline   0 Reply With Quote
Old Jan 26, 2013, 11:26 AM   #5
Blunders
macrumors newbie
 
Join Date: Jan 2013
Question windows 8 issue macbook pro retina

Hello,

I had the same problem when I installed windows 8 on rMBP, also I am trying to deal with this purple - black screen that is caused the wrong resolution settings apparently.

I started windows 8 in safe mode en enabled low resolution settings. My computer restarted and everything was okay, it seemed. After that I installed the windows drivers because that was recommended on other forums.

Now when I start my computer in windows mode the purple black screen is back and for some sort of reason I can't get restart in safe mode. A moment ago I deleted the windows partition and I'm ready to try it again but I hope that someone can advise about what I'm doing wrong...Or what I should do.

Has anyone experienced the same problem? Or has a clue, by reading this post, of what I'm doing wrong

Thanks in advance for helping, sorry if I explain it vague, English is not my native language so my vocabulary is limited.

Regards,

Ron
Blunders is offline   0 Reply With Quote
Old Jan 27, 2013, 04:25 PM   #6
Swiss-G
macrumors 6502
 
Join Date: Jun 2010
Quote:
Originally Posted by Blunders View Post
Hello,

I had the same problem when I installed windows 8 on rMBP, also I am trying to deal with this purple - black screen that is caused the wrong resolution settings apparently.

I started windows 8 in safe mode en enabled low resolution settings. My computer restarted and everything was okay, it seemed. After that I installed the windows drivers because that was recommended on other forums.

Now when I start my computer in windows mode the purple black screen is back and for some sort of reason I can't get restart in safe mode. A moment ago I deleted the windows partition and I'm ready to try it again but I hope that someone can advise about what I'm doing wrong...Or what I should do.

Has anyone experienced the same problem? Or has a clue, by reading this post, of what I'm doing wrong

Thanks in advance for helping, sorry if I explain it vague, English is not my native language so my vocabulary is limited.

Regards,

Ron

OS X 10.8.3 will support Windows 8 via bootcamp and should include the correct drivers.

Should be released any day now.
Swiss-G is offline   0 Reply With Quote
Old Jan 27, 2013, 06:18 PM   #7
jenzjen
macrumors 68000
 
Join Date: Aug 2010
Unsure why you are getting that screen, I installed W8 pro on the rMBP and didn't have the resolution issue.
jenzjen is offline   0 Reply With Quote
Old Jan 28, 2013, 03:04 PM   #8
MiamiC70
macrumors member
 
Join Date: Oct 2011
Define "ANY DAY NOW"?
MiamiC70 is offline   0 Reply With Quote
Old Jan 28, 2013, 04:24 PM   #9
tmanto02
Thread Starter
macrumors 6502a
 
tmanto02's Avatar
 
Join Date: Jun 2011
Location: Earth
Quote:
Originally Posted by Blunders View Post
Hello,

I had the same problem when I installed windows 8 on rMBP, also I am trying to deal with this purple - black screen that is caused the wrong resolution settings apparently.

I started windows 8 in safe mode en enabled low resolution settings. My computer restarted and everything was okay, it seemed. After that I installed the windows drivers because that was recommended on other forums.

Now when I start my computer in windows mode the purple black screen is back and for some sort of reason I can't get restart in safe mode. A moment ago I deleted the windows partition and I'm ready to try it again but I hope that someone can advise about what I'm doing wrong...Or what I should do.

Has anyone experienced the same problem? Or has a clue, by reading this post, of what I'm doing wrong

Thanks in advance for helping, sorry if I explain it vague, English is not my native language so my vocabulary is limited.

Regards,

Ron
I had the same issue- there are two ways around it.

1- plug in an external monitor for set up

2- install ntfs for mac and you need to access the windows partition and delete the standard display driver file, when you restart into windows it repairs its self and all is good. ( I did this method as I didn't have a monitor, however I can't remember the name of the file, I googled things like "windows 8 install MacBook retina blank screen" and I eventually found a thread on another forum describing how to do it)

Sorry I don't have more information, goodluck

----------

Quote:
Originally Posted by Blunders View Post
Hello,

I had the same problem when I installed windows 8 on rMBP, also I am trying to deal with this purple - black screen that is caused the wrong resolution settings apparently.

I started windows 8 in safe mode en enabled low resolution settings. My computer restarted and everything was okay, it seemed. After that I installed the windows drivers because that was recommended on other forums.

Now when I start my computer in windows mode the purple black screen is back and for some sort of reason I can't get restart in safe mode. A moment ago I deleted the windows partition and I'm ready to try it again but I hope that someone can advise about what I'm doing wrong...Or what I should do.

Has anyone experienced the same problem? Or has a clue, by reading this post, of what I'm doing wrong

Thanks in advance for helping, sorry if I explain it vague, English is not my native language so my vocabulary is limited.

Regards,

Ron

Found it: install paragon ntfs free trial and follow these instructions:

Part 3b: Fixing Windows 8

For me, I experienced the black screen issue, where it would just sit there forever. A fix for this is to remove the igdkm64.sys from C:\Windows\System32\Drivers.

I just trashed the file and emptied trash and then rebooted and it did a quick repair process and voila!

heres the original link if you need it

http://thetecherra.com/2012/12/11/tu...ia-native-efi/
__________________
iPhone 5 for on the go|iPad Air for on the couch|Mac mini for Plex Home Theatre
MacBook Pro w/ Retina display
for everything else
tmanto02 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Issue installing Win7 via bootcamp melbri Windows, Linux & Others on the Mac 1 Jan 26, 2014 04:07 AM
Installing windows 7 in bootcamp issue daronj Mac Applications and Mac App Store 3 Jan 8, 2014 09:02 AM
Cannot boot to Windows after installing windows not through bootcamp haisergeant Windows, Linux & Others on the Mac 0 Jan 2, 2013 01:01 PM
Installing Windows 8 Pro Upgrade In Bootcamp Astroblu Windows, Linux & Others on the Mac 2 Dec 13, 2012 11:22 PM
Installing Windows 8 on Bootcamp - yes or no? imacken Windows, Linux & Others on the Mac 12 Nov 11, 2012 05:40 PM

Forum Jump

All times are GMT -5. The time now is 03:26 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC