Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Special Interests > Apple Collectors

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 14, 2013, 06:50 PM   #1
luvmac21
macrumors newbie
 
Join Date: Jan 2013
20th Anniversary Mac - European Plug Issue

Hi,
Does anyone know what could be wrong with my 20th anniv. mac or where I can go to get some help?

I have a 20th anniversary mac with European plug, placed a 115V adapter on the the plug and plugged it in to my U.S. wall outlet but nothing is happening. No green light below the subwoofer, or no power when when pressed on the power button. I even switch the 115V / 230V switch at the bottom of the subwoofer.

Another time, I plugged it into a 300W step-up converter and plug the converter into my outlet, that didn't work either.

Please help
luvmac21 is offline   0 Reply With Quote
Old Jan 15, 2013, 04:20 PM   #2
Lil Chillbil
macrumors 65816
 
Lil Chillbil's Avatar
 
Join Date: Jan 2012
Location: California
Please repost this in the Powerpc subforum you'll find a lot more help there
__________________
Check out my youtube Channel http://www.youtube.com/user/TheKull101
Mac skinned pc Luna netbook
Lil Chillbil is offline   0 Reply With Quote
Old Jan 22, 2013, 07:20 AM   #3
leon771
macrumors member
 
Join Date: Sep 2011
Location: Australia
Take he back off and press the CUDA button. Then try turning it on.
This happens to mine when my PRAM battery fails - only way to get it going is pressing CUDA then I usually replace the battery.
leon771 is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Apple Collectors

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Sling-box speed Issue Safari Plug In Joshiboi Mac Basics and Help 0 Jan 27, 2014 02:53 AM
OS-neutral: Doom's 20th Anniversary roadbloc Mac and PC Games 19 Dec 11, 2013 06:20 PM
O2 UK on Friday 20th order now or pickup to get on 20th? musio iPhone 2 Sep 11, 2013 02:28 PM
Resolved: USB plug and play issue - Haswell Air [Fixed] AXs MacBook Air 4 Aug 25, 2013 05:37 AM
Releasing a 20th Anniversary iMac, would you buy one? bembol iMac 5 Apr 8, 2013 09:28 AM

Forum Jump

All times are GMT -5. The time now is 07:35 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC